Faq page mislinked

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
Wafflez18
Registered User
Posts: 6
Joined: Tue Aug 15, 2017 11:09 pm

Faq page mislinked

Post by Wafflez18 » Sat Oct 14, 2017 5:04 am

So I'm running 2 forums on 1 device. The first one https://yataland.com/Forums/index.php installed just fine. The second one https://qfury.yataland.com/Forums/ I had to install 3.0 or 3.1 and then manually update it to 3.2 following the guide on this site because a straight fresh install of 3.2 caused it hang at like 15% for an hour or so. It looked like everything was good until I tried going to the FAQ page. The link seems to be messed up. It tries to go to https://qfury.yataland.com/Forums/help/faq instead of https://qfury.yataland.com/Forums/app.php/help/faq.

So how can I fix this? I've tried editing the link manually in the overall_header :

Code: Select all

<a href="https://qfury.yataland.com/Forums/app.php/help/faq" rel="help" title="{L_FAQ_EXPLAIN}" role="menuitem">
Then I purged the cache on the site and reloaded and it's still pulling the old link. Am I missing something? :geek:

Any help would be appreciated. :)

janus_zonstraal
Registered User
Posts: 1754
Joined: Sat Aug 30, 2014 1:30 pm

Re: Faq page mislinked

Post by janus_zonstraal » Sat Oct 14, 2017 6:46 am

Did you use the new .htaccess from phpbb3.2.1?

This must be inside

Code: Select all

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]
Sorry! My English is bat ;) !!!

Wafflez18
Registered User
Posts: 6
Joined: Tue Aug 15, 2017 11:09 pm

Re: Faq page mislinked

Post by Wafflez18 » Sat Oct 14, 2017 12:25 pm

I've honestly always have had issues with .htaccess files. Would it be funny to say the forum that is working doesn't have a .htaccess file? lol. I normally hard code the settings into apache's conf but I didn't hard code this. So I don't even know how the first Forum is working. :lol:

So to answer your question yes there is an .htaccess file in the second install from atleast 3.2.0. It does have that piece of code in it as well. Tried replacing the old Overall_header and hard coding that rule. Still no luck. :?
Last edited by Wafflez18 on Sat Oct 14, 2017 12:42 pm, edited 1 time in total.

janus_zonstraal
Registered User
Posts: 1754
Joined: Sat Aug 30, 2014 1:30 pm

Re: Faq page mislinked

Post by janus_zonstraal » Sat Oct 14, 2017 12:39 pm

Did you purge the cache after the changes in the HTML file?
Sorry! My English is bat ;) !!!

Wafflez18
Registered User
Posts: 6
Joined: Tue Aug 15, 2017 11:09 pm

Re: Faq page mislinked

Post by Wafflez18 » Sat Oct 14, 2017 12:42 pm

Yes, purged it, restarted Apache, and restarted the server just in case. :lol:

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: AmigoJack, janus_zonstraal, ZNL and 29 guests

cron