Extensions not working at all

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
Tusky
Registered User
Posts: 3
Joined: Mon Oct 09, 2017 12:45 pm

Extensions not working at all

Post by Tusky » Mon Oct 16, 2017 11:54 am

Hello!

We've recently started using phpbb and wanted to add a few extensions, however, none seem to show up in ACP. We've followed the instructions for each installation (which has been public_html - exe - the name of...), we've attempted to go into the phpbb folder and create an extension for it, however, nothing seems to work. Has anyone else had this issue at all?

We are running from the latest version and using cpanel to upload the files through godaddy.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 68242
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Extensions not working at all

Post by KevC » Mon Oct 16, 2017 12:02 pm

Please post a screenshot of your FTP window showing where you have the extensions and the expanded view of the folder you have uploaded.

You should have

/ext/authorname/extensionname
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
david63
Jr. Extension Validator
Posts: 14651
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Extensions not working at all

Post by david63 » Mon Oct 16, 2017 12:06 pm

This will almost certainly be a problem with your folder hierarchy. If you can post a screenshot showing the files and folders it will help.
Tusky wrote:
Mon Oct 16, 2017 11:54 am
using cpanel to upload the files through godaddy
That method is fraught with problems and may be contributing to your problem - you should download the zip file from wherever it is located, unzip it on your local machine and then use an ftp program (such as filezilla) to upload the files to your site.

Also if you are using cpanel/Godaddy would I be right in guessing that you have used Godaddy's "one click" install for phpBB - again this may also be contributing to your problems as there are many known issues with that product (which is nothing to do with phpBB other that they have modified the files)
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

Disco1969
Registered User
Posts: 5
Joined: Tue Jun 12, 2018 4:07 pm

Re: Extensions not working at all

Post by Disco1969 » Sun Jun 17, 2018 3:07 pm

Hello Ladies and Gentlemen :)

I was wondering if this topic was solved as i am having the same problem too.

I followed the instructions to upload files to the correct place but the extension does not show in the "ACP".

Any help would really be appreciated.

Thank you in advance.

Disco1969

Apollogies if i have posted in the wrong place

User avatar
KevC
Support Team Member
Support Team Member
Posts: 68242
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Extensions not working at all

Post by KevC » Sun Jun 17, 2018 3:22 pm

Always better to just start a new topic.

As with my first reply
KevC wrote:
Mon Oct 16, 2017 12:02 pm
Please post a screenshot of your FTP window showing where you have the extensions and the expanded view of the folder you have uploaded.

You should have

/ext/authorname/extensionname
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Disco1969
Registered User
Posts: 5
Joined: Tue Jun 12, 2018 4:07 pm

Re: Extensions not working at all

Post by Disco1969 » Sun Jun 17, 2018 3:42 pm

KevC wrote:
Sun Jun 17, 2018 3:22 pm
Always better to just start a new topic.

As with my first reply
KevC wrote:
Mon Oct 16, 2017 12:02 pm
Please post a screenshot of your FTP window showing where you have the extensions and the expanded view of the folder you have uploaded.

You should have

/ext/authorname/extensionname
This is the complete directory including the installation instructions i recieved from the seller
Attachments
a.jpg
b.jpg
c.jpg
d.jpg
e.jpg

User avatar
KevC
Support Team Member
Support Team Member
Posts: 68242
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Extensions not working at all

Post by KevC » Sun Jun 17, 2018 3:47 pm

You have them in the wrong place.

At the top level there is a folder called /ext
It looks like you've made a folder called /ext in the forum's /phpbb folder.
Attachments
b.jpg
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Disco1969
Registered User
Posts: 5
Joined: Tue Jun 12, 2018 4:07 pm

Re: Extensions not working at all

Post by Disco1969 » Sun Jun 17, 2018 4:15 pm

KevC wrote:
Sun Jun 17, 2018 3:47 pm
You have them in the wrong place.

At the top level there is a folder called /ext
It looks like you've made a folder called /ext in the forum's /phpbb folder.
I placed them in the new location and it is still not showing in my "ACP"

yeah, i followed the said instructions but there was no folder by that name so i assumed i had to create one. Does this folder need to be deleted?

Thank you for your help my friend. much appreciated :)

User avatar
KevC
Support Team Member
Support Team Member
Posts: 68242
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Extensions not working at all

Post by KevC » Sun Jun 17, 2018 4:18 pm

OK post up screenshots of where they are now.

I would delete the /phpbb/ext folder just to avoid confusion in future.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Disco1969
Registered User
Posts: 5
Joined: Tue Jun 12, 2018 4:07 pm

Re: Extensions not working at all

Post by Disco1969 » Sun Jun 17, 2018 4:31 pm

KevC wrote:
Sun Jun 17, 2018 4:18 pm
OK post up screenshots of where they are now.

I would delete the /phpbb/ext folder just to avoid confusion in future.
Ok im here at the moment, am i in the correct place my friend?
Attachments
ext 1.png
ext 2.png
ext 3.png
ext 4.png
ext 5.png

User avatar
KevC
Support Team Member
Support Team Member
Posts: 68242
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Extensions not working at all

Post by KevC » Sun Jun 17, 2018 4:38 pm

Nope

You've put it in to /ext/phpbb (this is where extensions written by the phpBB team go)

It just needs to be in /ext

Just as the instructions say on the right side of the screen in your screenshots.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
</Solidjeuh>
Registered User
Posts: 963
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Extensions not working at all

Post by </Solidjeuh> » Sun Jun 17, 2018 4:40 pm

Planet styles? I think that's a style, and not an ext.
Styles needs to be in: public_html/styles


== EDIT == Sorry, I'm wrong. Seems to be an ext in your screenshots :)
Wij promoten UW muziek in ons forum & delen alles via Sociale media!
Muziek wordt ook toegevoegd in de playlist van
textradio.be!
Mail uw single + hoesje + info naar: info@muziekpromo.net of Solidjeuh@textradio.be
===============
Onze Website: https://www.muziekpromo.net

User avatar
KevC
Support Team Member
Support Team Member
Posts: 68242
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Extensions not working at all

Post by KevC » Sun Jun 17, 2018 4:42 pm

No, it's a controller for a 3rd party style. It belongs in /ext/
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Disco1969
Registered User
Posts: 5
Joined: Tue Jun 12, 2018 4:07 pm

Re: Extensions not working at all

Post by Disco1969 » Sun Jun 17, 2018 4:45 pm

KevC wrote:
Sun Jun 17, 2018 4:38 pm
Nope

You've put it in to /ext/phpbb (this is where extensions written by the phpBB team go)

It just needs to be in /ext

Just as the instructions say on the right side of the screen in your screenshots.
OMG, YOU ROCK BROTHER...

Thank you so much, it works now. :)

You are a star.

:D :D

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: abrogard, jack terrier, Mannix_, maxwellqc13, Tarantino and 45 guests