Invalid form error when adding smilies.

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
Blacktiger63
Registered User
Posts: 48
Joined: Thu Oct 17, 2013 7:43 pm

Invalid form error when adding smilies.

Post by Blacktiger63 » Sat Oct 21, 2017 3:45 pm

Phpbb 3.2.1
Upgraded from 3.0.14
Installed extensions:
LMDI Multilinks 2.0.3
smilies scroll box 1.0.3
Stop Forum Spam 1.1.7
Tapatalk Plugin for phpBB 3.1/3.2 2.0.4
VigLink
Php v. 5.6.31
Mysql 5.5.53

I don't know if this is a bug, but I checked my error logs and found this on a hobby forum which I do technical administration for to help out:

Code: Select all

PHP Warning:  Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0, referer: https://www.mydomain.coml/forum/adm/index.php?i=acp_icons&sid=e2386658985cf6e182xxxxxxxxx0faf&mode=smilies
The max_input_vars however is 1000 by default.

We got several servers with all kind of forums including phpbb, but we never had to increase the max_input_vars ever. And this is even a small forum.

It might have something to do with the fact that the backup takes 500 MB, while attachments are -not- stored in the database.
I found some old chat crap in there which is not used anymore. Don't know if this can have any influence on this. But it seems strange that this value should be increased while this is not even necessary for larger forums we got.

There are people running forums running vBulletin, SMF and Phpbb 3.2. and this is the only forum this is happening with.

Found a similar issue here, but he wouldn't upgrade to 3.2 and I am already at 3.2 (from 3.0.14).
viewtopic.php?f=466&t=2406871

Any insight or fix would be very nice.

User avatar
Brf
Support Team Member
Support Team Member
Posts: 50714
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Invalid form error when adding smilies.

Post by Brf » Sat Oct 21, 2017 4:57 pm

This has nothing to do with backups or attachments.
The error message is saying that the form you are transmitting has more than 1000 input variables, which is believable, since there are like 8 or so for each smily. If you are adding 100 smilies, that would be 800 for just the smily list.

Blacktiger63
Registered User
Posts: 48
Joined: Thu Oct 17, 2013 7:43 pm

Re: Invalid form error when adding smilies.

Post by Blacktiger63 » Sat Oct 21, 2017 5:09 pm

Well oke, but that won't explain the problem then.
Because I was only trying to add 1 smiley, also tried with 2 smileys, same issue.
And this would only take 16 variables then, not more then 1000.

Or does it always count the amount of smilies present, even if they are not imported?
There are 554 files in the smilies directory. This is including the already imported list of smilies.

User avatar
Brf
Support Team Member
Support Team Member
Posts: 50714
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Invalid form error when adding smilies.

Post by Brf » Sat Oct 21, 2017 6:38 pm

It is counting whatever is there on the form.

Blacktiger63
Registered User
Posts: 48
Joined: Thu Oct 17, 2013 7:43 pm

Re: Invalid form error when adding smilies.

Post by Blacktiger63 » Sat Oct 21, 2017 9:25 pm

OMG... didn't know that. Thank you!

There are about 300 on the FTP which aren't used. So 300*8=2400. Now I understand if it's counted that way.
I will clear the ftp for unused smilies.

I presume best way is to export to smilies.pak so the installed ones are in the pack. Remove all smilies from the smilie directory and then install the pack again.
That way only the used smilies are back and the form is clear and we should not encounter this problem anymore when adding a couple of smilies. Correct?

Blacktiger63
Registered User
Posts: 48
Joined: Thu Oct 17, 2013 7:43 pm

Re: Invalid form error when adding smilies.

Post by Blacktiger63 » Sun Oct 22, 2017 1:00 pm

Fixed it. But a lot of manual work because the smilies.pak does not download the uses smilies also.
That would be a nice feature to sort things out.

Cleard out the unused smilies and now the error does not occur anymore.
Thank you.

Topic can be marked solved.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: maav, wickmesh and 25 guests

cron