Viewing Profile: Send email to 'user' reports wrong IP

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
dondri
Registered User
Posts: 34
Joined: Wed Jan 11, 2017 2:56 pm

Viewing Profile: Send email to 'user' reports wrong IP

Post by dondri » Fri Nov 17, 2017 4:05 am

I switched hosting companies a few weeks ago and I thought I had all the credentials set up correctly in the General / Email Settings as I can test an email and it confirms.

While Switching Host, the new Host gave me a Temp URL IP address until my Domain Name Transferred. Well, everything has transferred as of last week.

However, lets say that I search for a member and go to the Viewing Profile and click on "Send email to ______" I am finding out that the person that receives the email has the new Host Temp URL listed instead of the normal domain name URL.

For Example:

Hello user,

The following is an email sent to you by admin via your account on "anybodysite.com". If this message is spam, contains abusive or other comments you find offensive please contact the webmaster of the board at the following address:

http://"This part has the new Host Temp URL"/memberlist.php?mode=contactadmin

Include this full email (particularly the headers). Please note that the
reply address to this email has been set to that of admin.

Message sent to you follows
~~~~~~~~~~~~~~~~~~~~~~~~~~~

test host address

The email sent to user should have this:
http://"anybodysite.com"/memberlist.php?mode=contactadmin


I have checked as many places as I can in the phpbb admin panel and can not find where this adjustment would be. I would appreciate some help as the members that get emails from each other in this manner are seeing the Temp URL from new Host and I do not want that to happen. If a user bookmarks that Temp URL, then they get errors of wrong page.

janus_zonstraal
Registered User
Posts: 1808
Joined: Sat Aug 30, 2014 1:30 pm

Re: Viewing Profile: Send email to 'user' reports wrong IP

Post by janus_zonstraal » Fri Nov 17, 2017 6:49 am

First you said wrong IP address and after that you said wrong url.

Big difference I think?

Is your board working with a cloud server?
Sorry! My English is bat ;) !!!

User avatar
Brf
Support Team Member
Support Team Member
Posts: 50744
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Viewing Profile: Send email to 'user' reports wrong IP

Post by Brf » Fri Nov 17, 2017 1:14 pm

Your board's domain name is on the Server Settings page.

dondri
Registered User
Posts: 34
Joined: Wed Jan 11, 2017 2:56 pm

Re: Viewing Profile: Send email to 'user' reports wrong IP

Post by dondri » Fri Nov 17, 2017 3:15 pm

This forum is operating under a shared hosting account and not a cloud as far as I know of.

Brf,
yes, under General / Server Settigns is www.shipsofscale.com which is my site.
SMTP mail.shipsofscale.com
I even went to my phpbb_config in my database to see if something was off there, but all looks normal.

The hosting company gave me a temp IP address when I first signed up. Now that my site domain name is transferred, they gave me a permanent IP address.

Sorry janus_zonstraal that I did not provide the most accurate info to the other response, but not everyone that post here has complete knowledge of php, etc....if they did, they would not be here.

Here is an example that people get including myself:
If you want to view the topic, click the following link:
http://169.53.184.98/~...partialname/sosforums/viewtopic.php?f=52&t=1020

That IP address and path was a temp IP and Path that the web host set me up with until my Domain Name was transferred. I do not want to give out the "partialname" because it is part of my username to sign into my account.

This is what I used to get before I switched hosting
If you want to view the forum, click the following link:
http://shipsofscale.com/sosforums/viewforum.php?f=111

User avatar
Brf
Support Team Member
Support Team Member
Posts: 50744
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Viewing Profile: Send email to 'user' reports wrong IP

Post by Brf » Fri Nov 17, 2017 3:34 pm

If you had a temporary address you were using in your webbrowser's addressbar when you sent the email messages, that is the address that would be in the email messages.

dondri
Registered User
Posts: 34
Joined: Wed Jan 11, 2017 2:56 pm

Re: Viewing Profile: Send email to 'user' reports wrong IP (SOLVED)

Post by dondri » Fri Nov 17, 2017 6:58 pm

Ok, I solved the problem, and unfortunately, I can not remember what I did in the "email settings" in the board. But to repeat what my problem was doing this is the action taken on the board:

1) Quick Links / Members /
2) Click on Find a Member
3) enter their username
4) click search
5) user listed at bottom
6) Click on user
7) You are transported to "Viewer Profile"
8) in the middle Email address: Send email to "user"

that user should have a notification that says
If you want to view the forum, click the following link:
http://mysite.com/forums/viewforum.php?f=00000

But it did not. Instead, it "was" returning this --- but now it is corrected --- don't remember what I did

If you want to view the forum, click the following link:
http://123.456.789~mysi/forums/viewforum.php?f=00000

that IP address should not be there.
However, thank you all for your help.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: No registered users and 137 guests

cron