3.2 - 3.2.1 Catchable fatal error: Argument 7 passed to phpbb\template\twig\environment

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
maxwellqc13
Registered User
Posts: 117
Joined: Fri Mar 10, 2017 9:51 pm
Location: Iowa
Name: Max

3.2 - 3.2.1 Catchable fatal error: Argument 7 passed to phpbb\template\twig\environment

Post by maxwellqc13 » Thu Nov 23, 2017 5:11 am

I have been trying to do this update since it was released. I quit for a couple months out of frustration and decided to try again today. Unfortunately I have the same issues as before. I did search here and found a similar issue but no confirmed resolution or at least nothing I could understand.

The install goes through fine then I delete the install folder and when I go to the ACP I get this:
Catchable fatal error: Argument 7 passed to phpbb\template\twig\environment::__construct() must implement interface phpbb\event\dispatcher_interface, array given, called in /home/grainbel/domains/mysitename.com/public_html/GBN32_1/cache/production/container_4335734bbdd20f586549a504dff5f80c.php on line 1413 and defined in /home/grainbel/domains/mysitename.com/public_html/GBN32_1/phpbb/template/twig/environment.php on line 62

I have had a lot of patience over the past 9 months as I had to learn php and the related things from scratch to help my friend keep his site active. I think I am now at my breaking point with this error. Someone PLEASE help me and in words I can understand. I have had some very helpful people and information come from this site but on occasion there are things that will go straight over my head when someone assumes I know more then I do.

I am working on a copy of my site and DB. I always do upgrades this way then if it works I can just run install again with the active DB and then change the directory name to the active site.

I am on 3.2 upgrading to 3.2.1, I did exactly as directed here. Changed needed permissions from 755 to 777. Deleted the cache.

Thank you in advance for any assistance on this.

janus_zonstraal
Registered User
Posts: 1804
Joined: Sat Aug 30, 2014 1:30 pm

Re: 3.2 - 3.2.1 Catchable fatal error: Argument 7 passed to phpbb\template\twig\environment

Post by janus_zonstraal » Thu Nov 23, 2017 8:01 am

How do you upload the files and are you 100% sure you upload all the files?
Sorry! My English is bat ;) !!!

maxwellqc13
Registered User
Posts: 117
Joined: Fri Mar 10, 2017 9:51 pm
Location: Iowa
Name: Max

Re: 3.2 - 3.2.1 Catchable fatal error: Argument 7 passed to phpbb\template\twig\environment

Post by maxwellqc13 » Fri Nov 24, 2017 12:43 am

janus_zonstraal wrote:
Thu Nov 23, 2017 8:01 am
How do you upload the files and are you 100% sure you upload all the files?
FileZilla and yes 100%.

I unpack the new files then deleted the folders and file as listed in instructions.
Then delete the listed folders and files from the site (copy of active site).
Upload all the new files and choose overwrite were needed.
Update the DB.
Rename/delete the install folder.
Delete the Cache.
Try to enter site

User avatar
3Di
Registered User
Posts: 11865
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano - Frankfurt
Name: Marco
Contact:

Re: 3.2 - 3.2.1 Catchable fatal error: Argument 7 passed to phpbb\template\twig\environment

Post by 3Di » Fri Nov 24, 2017 12:58 am

Try this:

1 - delete or rename the actual vendor folder
2 - upload a fresh vendor folder from the full package
3 - run the database updater if not already done
4 . clear the cache
Want to compensate me for my interest? Donate
Please PM me only to request paid works. Thx.
Extensions, Scripts, MOD porting, Update/Upgrades

maxwellqc13
Registered User
Posts: 117
Joined: Fri Mar 10, 2017 9:51 pm
Location: Iowa
Name: Max

Re: 3.2 - 3.2.1 Catchable fatal error: Argument 7 passed to phpbb\template\twig\environment

Post by maxwellqc13 » Fri Nov 24, 2017 2:21 am

I did as you suggested and still got this
Catchable fatal error: Argument 7 passed to phpbb\template\twig\environment::__construct() must implement interface phpbb\event\dispatcher_interface, array given in /home/grainbel/domains/mysitename.com/public_html/GBN32_1/phpbb/template/twig/environment.php on line 62
When I did the 3.2 upgrade it went fairly smooth once I understood what I was doing. This one is basically the same process and not that many steps so what can I be doing wrong? Could it have anything to do with my copy I made of the DB?

I am using DirectAdmin now instead of the cPanel I had before but this should have no effect on things.

Someone told me I was not duplicating the DB properly but it works fine until I do the upgrade. I use phpMyAdmin to duplicate the DB with a new name and then change my config file in the root directory to match. I set the users in MySQL Management but I did notice that when I create the DB it says number of users -1 then when I add the user it says 0. My active DB on the active site says 1. Like I said though it does work fine until I do the upgrade

janus_zonstraal
Registered User
Posts: 1804
Joined: Sat Aug 30, 2014 1:30 pm

Re: 3.2 - 3.2.1 Catchable fatal error: Argument 7 passed to phpbb\template\twig\environment

Post by janus_zonstraal » Fri Nov 24, 2017 6:46 am

I set the users in MySQL Management but I did notice that when I create the DB it says number of users -1 then when I add the user it says 0. My active DB on the active site says 1. Like I said though it does work fine until I do the upgrade
You mean you add users directly into de DB?
Sorry! My English is bat ;) !!!

maxwellqc13
Registered User
Posts: 117
Joined: Fri Mar 10, 2017 9:51 pm
Location: Iowa
Name: Max

Re: 3.2 - 3.2.1 Catchable fatal error: Argument 7 passed to phpbb\template\twig\environment

Post by maxwellqc13 » Sun Nov 26, 2017 8:53 pm

janus_zonstraal wrote:
Fri Nov 24, 2017 6:46 am
I set the users in MySQL Management but I did notice that when I create the DB it says number of users -1 then when I add the user it says 0. My active DB on the active site says 1. Like I said though it does work fine until I do the upgrade
You mean you add users directly into de DB?
No and this is not the issue I created it this time via a dump and backup and got the same thing

maxwellqc13
Registered User
Posts: 117
Joined: Fri Mar 10, 2017 9:51 pm
Location: Iowa
Name: Max

Re: 3.2 - 3.2.1 Catchable fatal error: Argument 7 passed to phpbb\template\twig\environment

Post by maxwellqc13 » Sun Nov 26, 2017 11:30 pm

Deleted this individual post I a resolved it. Still getting error though

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: JoshyPHP and 147 guests

cron