Can't make post/create topics

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
dahamster
Registered User
Posts: 4
Joined: Fri Nov 24, 2017 10:02 pm

Can't make post/create topics

Post by dahamster » Fri Nov 24, 2017 10:23 pm

Support Request Template
What version of phpBB are you using? phpBB 3.2.1
Who do you host your board with? Centos 7 lamp stack
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.0.12
What extensions do you have installed? Advertisement Management
OneAll Social Login
What styles do you currently have installed? prosilver and IDLaunch_Fresh
Which database type/version are you using? MariaDB
What is your level of experience? Comfortable with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? there was an old install of phpBB 3.0.12 lots of mods and custom stuff, restored everything with support toolkit exported the users,topic and posts.
then upgraded to 3.2.1 and restored users, topics and posts
Please describe your problem. The problem is that no one can't start a new topic or reply to a topic.
after enableing phpBB debug i got some erros on the admin panel:

Code: Select all

[phpBB Debug] PHP Notice: in file [ROOT]/phpbb/log/log.php on line 649: Undefined index: post_id
[phpBB Debug] PHP Notice: in file [ROOT]/phpbb/auth/auth.php on line 918: Undefined offset: 233
[phpBB Debug] PHP Notice: in file [ROOT]/phpbb/auth/auth.php on line 919: Undefined offset: 0

and the apache/php error log:

Code: Select all

[proxy_fcgi:error] [pid 3004] [client xxx.xxx.xxx.xxx:xxxx] AH01071: Got error 'PHP message: PHP Fatal error: Uncaught exception 'RuntimeException' with message 'Cannot parse node 'php''' in /www/vendor/s9e/text-formatter/src/Configurator.php:2181\nStack trace:\n#0 /www/vendor/s9e/text-formatter/src/Configurator.php(2133): s9e\\TextFormatter\\Configurator\\Helpers\\TemplateParser::parseChildren(Object(DOMElement), Object(DOMElement))\n#1 /www/vendor/s9e/text-formatter/src/Configurator.php(5871): s9e\\TextFormatter\\Configurator\\Helpers\\TemplateParser::parse(' \\nif($_SERVER['...')\n#2 /www/vendor/s9e/text-formatter/src/Configurator.php(5844): s9e\\TextFormatter\\Configurator\\RendererGenerators\\PHP->generate(Object(s9e\\TextFormatter\\Configurator\\Rendering))\n#3 /www/vendor/s9e/text-formatter/src/Configurator.php(4686): s9e\\TextFormatter\\Configurator\\RendererGenerators\\PHP->getRenderer(Object(s9e\\TextFormatter\\Configurator\\Rendering))\n#4 /www/vendor/s9e/text-formatter/src/Configur...\n', referer: https://323fclub.nl/viewtopic.php?f=16&t=39584

Code: Select all

[proxy_fcgi:error] [pid 1876] [client xx.xx.xx.xx:xxxx] AH01071: Got error 'PHP message: PHP Fatal error: Call to undefined method bbcode::BBvideo_pass() in /www/includes/bbcode.php(121) : regexp code on line 1\n'

[Fri Nov 24 22:31:17.380077 2017] [proxy_fcgi:error] [pid 5608] [client xx.xx.xx.xx:xxxx] AH01071: Got error 'PHP message: PHP Fatal error: Call to undefined method bbcode::Text_effect_pass() in /www/includes/bbcode.php(121) : regexp code on line 1\n'
[Fri Nov 24 22:33:29.090535 2017] [proxy_fcgi:error] [pid 5608] [client xx.xx.xx.xx:xxxx] AH01071: Got error 'PHP message: PHP Fatal error: Call to undefined method bbcode::offtopic_pass() in /www/includes/bbcode.php(121) : regexp code on line 1\n'
Generated by SRT Generator
Last edited by dahamster on Mon Nov 27, 2017 11:50 pm, edited 1 time in total.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 47986
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Can't make post/create topics

Post by stevemaury » Sat Nov 25, 2017 12:16 am

You cannot import just users, topics and posts. As you see, it doesn't work. Clean the database with the SRT, import it all, and delete what you don't want.

See https://www.phpbb.com/support/docs/en/3 ... /upgrade3/
For REALLY good and VERY inexpensive hosting CLICK HERE

All unsolicited PMs will be ignored.

dahamster
Registered User
Posts: 4
Joined: Fri Nov 24, 2017 10:02 pm

Re: Can't make post/create topics

Post by dahamster » Sat Nov 25, 2017 2:37 pm

Even with the full DB restored it won't work

Code: Select all

Fatal error: Uncaught exception 'RuntimeException' with message 'Cannot parse node 'php''' in www\vendor\s9e\text-formatter\src\Configurator.php:2181 Stack trace: #0 www\vendor\s9e\text-formatter\src\Configurator.php(2133): s9e\TextFormatter\Configurator\Helpers\TemplateParser::parseChildren(Object(DOMElement), Object(DOMElement)) #1 www\vendor\s9e\text-formatter\src\Configurator.php(5871): s9e\TextFormatter\Configurator\Helpers\TemplateParser::parse(' \nif($_SERVER['...') #2 www\vendor\s9e\text-formatter\src\Configurator.php(5844): s9e\TextFormatter\Configurator\RendererGenerators\PHP->generate(Object(s9e\TextFormatter\Configurator\Rendering)) #3 www\vendor\s9e\text-formatter\src\Configurator.php(4686): s9e\TextFormatter\Configurator\RendererGenerators\PHP->getRenderer(Object(s9e\TextFormatter\Configurator\Rendering)) #4 www\vendor\s9e\text-formatter\src\Configurator.php(101): s9e\TextFormatter\Configurator\Rendering->getRenderer() #5 www in www\vendor\s9e\text-formatter\src\Configurator.php on line 2181

User avatar
JoshyPHP
Code Contributor
Posts: 754
Joined: Mon Jul 11, 2011 12:28 am

Re: Can't make post/create topics

Post by JoshyPHP » Sun Nov 26, 2017 4:22 pm

You have a BBCode with <?php and you need to remove that processing instruction.
I wrote the thing that does the BBCodes in 3.2. Unless it broke yours, in which case it was somebody else with a similar name.

dahamster
Registered User
Posts: 4
Joined: Fri Nov 24, 2017 10:02 pm

Re: Can't make post/create topics

Post by dahamster » Mon Nov 27, 2017 11:49 pm

JoshyPHP wrote:
Sun Nov 26, 2017 4:22 pm
You have a BBCode with <?php and you need to remove that processing instruction.
Thank you! that was the main problem after that i could fix the remaining parts

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Gr8Falcon and 153 guests

cron