Page 1 of 1

ACP no Module Management

Posted: Thu Dec 14, 2017 1:03 pm
by noudle
Hello,

im not very used to phpBB and there is obviously something wrong with my installation.

What happened before:

I recently upgraded from phpBB 3.0.12 to 3.2.1 using this approach: https://www.phpbb.com/support/docs/en/3 ... /upgrade3/
This did work very good, except for two "extra" tabs in showing up in the ACP after the upgrade (tabs name was "Extensions" and "ACP_notify_mods" or something like that) which I could not click on without getting a "General Error" page.

So I disabled that notify module in the phpbb3 database and those two tabs where gone.

Actual Problem: I do not have a Module Management section nor a Customize Tab in my ACP. My ACP -> System looks like this: Image

I already asked in the irc network on freenode about this and it seems that some modules are not installed or running properly. What can i do to debug this? How can i find out which modules are missing and then install/enable them?

Thanks in advance!

Re: ACP no Module Management

Posted: Thu Dec 14, 2017 3:14 pm
by warmweer
noudle wrote:
Thu Dec 14, 2017 1:03 pm
I recently upgraded from phpBB 3.0.12 to 3.2.1 using this approach: https://www.phpbb.com/support/docs/en/3 ... /upgrade3/
This did work very good, except for two "extra" tabs in showing up in the ACP after the upgrade (tabs name was "Extensions" and "ACP_notify_mods" or something like that) which I could not click on without getting a "General Error" page.
Those are probably leftovers from mods you installed on 3.0.12 (could even be a leftover from automod). Unfortunaetly I don't have my 3.0.12 backups anymore but going from memory there was a table from automod (phpBB_mods I think) which has to be removed, and also in another table with AC_xxx something with entries that have to be deleted.
Best way is to check which modifications you installed, look at the install files and see which values they added.

I would suggest re-upgrading then.

Re: ACP no Module Management

Posted: Thu Dec 14, 2017 3:39 pm
by noudle
warmweer wrote:
Thu Dec 14, 2017 3:14 pm
noudle wrote:
Thu Dec 14, 2017 1:03 pm
I recently upgraded from phpBB 3.0.12 to 3.2.1 using this approach: https://www.phpbb.com/support/docs/en/3 ... /upgrade3/
This did work very good, except for two "extra" tabs in showing up in the ACP after the upgrade (tabs name was "Extensions" and "ACP_notify_mods" or something like that) which I could not click on without getting a "General Error" page.
Those are probably leftovers from mods you installed on 3.0.12 (could even be a leftover from automod). Unfortunaetly I don't have my 3.0.12 backups anymore but going from memory there was a table from automod (phpBB_mods I think) which has to be removed, and also in another table with AC_xxx something with entries that have to be deleted.
Best way is to check which modifications you installed, look at the install files and see which values they added.

I would suggest re-upgrading then.
Thanks for your response, but i already solved the problem with those two tabs.

What I try to solve now is the fact that i do not have a Module Management or Customize Tab so I can't install any extension.

Re: ACP no Module Management

Posted: Thu Dec 14, 2017 4:01 pm
by david63
Do you have the requisite permissions to manage modules and extensions?

Re: ACP no Module Management

Posted: Thu Dec 14, 2017 4:13 pm
by noudle
I have founder status if thats the question.

Re: ACP no Module Management

Posted: Thu Jan 11, 2018 3:23 pm
by noudle
Thanks to #phpbb , solved it by deleting cache/production/ manually over ssh. Somehow the "purge cache" functionality did not work properly for me.

Re: ACP no Module Management

Posted: Thu Jan 11, 2018 3:40 pm
by RMcGirr83
Then you need to check the permissions on those directories.

https://www.phpbb.com/support/docs/en/3 ... rmissions/