Upgrading from phpbb 2.0.19 with PHP 7

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
lanikitacat
Registered User
Posts: 2
Joined: Fri Dec 15, 2017 11:25 am

Upgrading from phpbb 2.0.19 with PHP 7

Post by lanikitacat » Sat Dec 16, 2017 7:25 am

hello-

My forum is really old ( I believe it is phpbb 2.0.19). I have a WordPress site and upgraded to PHP 7 and now the forum does not come up in the browser at all and get errors in my google search console.

My question is what are the steps I would need to take to make my forum work again and keep PHP 7?

thanks, I appreciate your help!

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 7547
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: Upgrading from phpbb 2.0.19 with PHP 7

Post by _Vinny_ » Sat Dec 16, 2017 8:08 am

lanikitacat wrote:
Sat Dec 16, 2017 7:25 am
My question is what are the steps I would need to take to make my forum work again and keep PHP 7?
Support for phpBB2 has ended. Any support requests regarding phpBB2 are limited to help with conversion to phpBB 3.2 or higher. So probably upgrade to the latest version.

Information on how to convert from phpBB2 to phpBB 3.2 is here.

Basically, you must have both phpBB2 and phpBB 3.2 installed on the same server. After you have finished installing phpBB 3.2 you will have the option to convert your phpBB2 board using the built in converter. The information it asks you for is related to the phpBB2 installation and can be found in its config.php file on the server. All of your users, posts, forums, PMs etc are converted. However, styles and MODs are not (with the exception of the birthday and attachment MODs which are supported by the converter). The phpBB2 database is not converted per se, it is merely read and converted/moved to the new phpBB3 database, so if it goes wrong your old board will not be affected at all. At the end of the conversion, once you're happy it's all working, your phpBB2 database and files can be backed up and removed if you so wish. They are not connected to the new installation in any way.'

lanikitacat
Registered User
Posts: 2
Joined: Fri Dec 15, 2017 11:25 am

Re: Upgrading from phpbb 2.0.19 with PHP 7

Post by lanikitacat » Sun Dec 17, 2017 2:21 am

Thank you for the information!

Do I need to create a new database in my cpanel before I convert to 3.2 or does it create a new phpBB3 database automatically when I upgrade?

Thank you!

janus_zonstraal
Registered User
Posts: 2224
Joined: Sat Aug 30, 2014 1:30 pm

Re: Upgrading from phpbb 2.0.19 with PHP 7

Post by janus_zonstraal » Sun Dec 17, 2017 7:26 am

You have to create a database before you can install phpbb 3.2
Sorry! My English is bat ;) !!!

xeon235
Registered User
Posts: 8
Joined: Sat Dec 02, 2017 8:58 am

Re: Upgrading from phpbb 2.0.19 with PHP 7

Post by xeon235 » Sun Dec 17, 2017 1:49 pm

phpBB2 will not run on PHP7, I can not really run it on PHP 5.6 (at least it did not work on PHP 5.6 as it should be), the maximum version of PHP on which I was able to run phpBB2 is PHP5.4, migration by instructions run smoothly, provided that you do not have errors in the database as I did, for example I had duplicate nicknames (so far I do not know how), and of course I had a problem with bbcode, because I had records [size = 24pt] text [/ size] and the migration script has already displayed an error that the maximum font size is 200

User avatar
Mick
Support Team Member
Support Team Member
Posts: 18853
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Upgrading from phpbb 2.0.19 with PHP 7

Post by Mick » Sun Dec 17, 2017 2:41 pm

I don’t think you have to have phpBB2 running, you just need a copy of the database on the server. It’s a long time since I’ve done it so I could be talking hooey.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

xeon235
Registered User
Posts: 8
Joined: Sat Dec 02, 2017 8:58 am

Re: Upgrading from phpbb 2.0.19 with PHP 7

Post by xeon235 » Sun Dec 17, 2017 3:07 pm

I do not need to run, but you have to have phpBB 2.0.19 files uploaded, because if I remember correctly, you need to enter the path to install phpbb 2.0.19

User avatar
warmweer
Registered User
Posts: 963
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Upgrading from phpbb 2.0.19 with PHP 7

Post by warmweer » Sun Dec 17, 2017 3:27 pm

You could upgrade in 2 steps:
1. on localhost :2.0.19 > 3.0.14
2. upload the 3.0.14 database to your online host + upload the 3.2.1 files + run the upgrade
A bug is a feature that hasn't made it to the manual (yet)

User avatar
3Di
Registered User
Posts: 12362
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Upgrading from phpbb 2.0.19 with PHP 7

Post by 3Di » Mon Dec 18, 2017 5:16 am

xeon235 wrote:
Sun Dec 17, 2017 1:49 pm
phpBB2 will not run on PHP7, I can not really run it on PHP 5.6 (at least it did not work on PHP 5.6 as it should be), the maximum version of PHP on which I was able to run phpBB2 is PHP5.4, migration by instructions run smoothly, provided that you do not have errors in the database as I did, for example I had duplicate nicknames (so far I do not know how), and of course I had a problem with bbcode, because I had records [size = 24pt] text [/ size] and the migration script has already displayed an error that the maximum font size is 200
Let's see, you have PHP 5.6 ok?

1 - same server, in example "public_html" you have phpBB2 like my_www/phpBB2, now you need to create a folder named example my_www/phpBB3 and upload a fresh full copy (files) of 3.0.14, create a DB for it and leave it empty.

The directory structure would be like:

---WWW (public_html or whatever)
------ phpBB2 (contains the bb2 files connected to the bb2 DB)
------ phpBB3 (contains the bb3 files NOT YET connected to the empty bb3 DB)

2 - Point your browser to your my_www/phpBB3/install/index.php file and click-on the convert TAB
3 - Insert the info required (that should be my_www/phpBB2

The informations for the DB of phpBB2 are into its relative config.php file and the converter should automatically be able to connect and go ahead with the conversion

I am typing on the fly based on memories, if these are still serving you are done, almost at least..

Got converted? good, make a backup of the new phpBB3 DB and and files and keep'em safe, transfer the phpBB2's folders required as per the upgrade instructions (attachments and so on, see the docs).

Now you got a 3.0.14 running under PHP 5.6 which is enough to run 3.2.1 and its upgrader from 3.0.14 (not a conversion this time).

Once you get a 3.2.1 running you may switch to PHP7.

Don't forget to be sure you have always the 3.0.14 backups, in case, that would be your starting point for a new upgrade if the first goes wrong somehow.

Hope this helps, and to have not forgot some step. :geek: :)
Want to compensate me for my interest? Donate
Please PM me only to request paid works. Thx.
Extensions, Scripts, MOD porting, Update/Upgrades
My development's activity º PhpStorm's proud user

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: _dbnx_, Charlie_M, david63, lopoto, stevemaury and 43 guests