Page 1 of 1

Notification settings page not working

Posted: Sun Dec 17, 2017 5:35 am
by PELP
On the board I am managing, [url]hhtps://www.dfac.dk/fritforum [/url], the notification settings page in UCP gives the HTTP 500 error. We have recently updated to php 7.0, phpBB 3.2.1 and implemented SSL. When the error has arrisen I do not know. It was just observed by a user yesterday.

To me it sounds like a glitch in the code, which has not been touched.

Any suggestions?

Re: Notification settings page not working

Posted: Sun Dec 17, 2017 7:42 am
by janus_zonstraal
You forgot the redirect from http to https

And about the notification, is it the same in prosilver?

Because there is no we_universal style for 3.2 (that I know)

Re: Notification settings page not working

Posted: Tue Dec 19, 2017 3:46 pm
by PELP
Thanks Janus,

I´m not sure bout the "forgot to redirect". Everything else works in SSL. And I don´t think that that is the problem, because I found the culprit. It´s an extention, Advanced Polls, that I had to update along with 3.2.1. because the old version wouldn´t work with 3.2.1. I know it´s not approved yet, and will post my problem where the extention is discussed.

As for WE_universal, I know it hasn´t been approved for 3.2.1 because the original author has abandonned it, but a new author has picked up where he left off and revised it for 3.2.1 - but it´s still not official.

Re: Notification settings page not working

Posted: Tue Dec 19, 2017 4:29 pm
by janus_zonstraal
This is "also" working, so you have to make a redirect to https ;)

Code: Select all

http://www.dfac.dk/fritforum/

Re: Notification settings page not working

Posted: Tue Dec 19, 2017 5:04 pm
by Selective
If you are using https on your domain, then make sure https is forced in the (.htaccess) file for the forum also, so no matter what url people type or click on, the login page will always be https. If you don't, then people can still login under an http url address and that will cause major problems.

The (http / https) option in the ACP, that needs to be switched also, but it is better to leave that at http until you have a chance to fix the (.htaccess) file first. Then do the ACP option last.