Page 1 of 1

Update 3.2.1 >>> 3.2.2

Posted: Mon Jan 08, 2018 3:17 pm
by bennybernaer
When updating to 3.2.2 I get the following message:
The file differ failed to open Array.
[phpBB Debug] "file_get_contents(../install/update/new/language/nl/email/user_resend_inactive.txt): failed to open stream: No such file or directory" in file /home/deb78240n4/domains/zelfbeschadiging.be/public_html/phpbb/install/module/update_filesystem/task/diff_files.php on line 182
[phpBB Debug] "Array to string conversion" in file /home/deb78240n4/domains/zelfbeschadiging.be/public_html/phpbb/language/language.php on line 313
I use the full download packaget

Re: Update 3.2.1 >>> 3.2.2

Posted: Mon Jan 08, 2018 4:02 pm
by Brf
If you are following this article
Knowledge Base - Updating 3.2.x
you would not be updating your filesystem.

Re: Update 3.2.1 >>> 3.2.2

Posted: Mon Jan 08, 2018 4:17 pm
by bennybernaer
I have done so, but I can not choose to just update the database
The attachment Naamloos.png is no longer available
Naamloos.png

Re: Update 3.2.1 >>> 3.2.2

Posted: Mon Jan 08, 2018 4:20 pm
by stevemaury
Please fill out the Support Request Template and post it back here to enable us to assist you better.

Re: Update 3.2.1 >>> 3.2.2

Posted: Mon Jan 08, 2018 4:40 pm
by nl1sms
Same problem here.

Re: Update 3.2.1 >>> 3.2.2

Posted: Mon Jan 08, 2018 4:57 pm
by warmweer
bennybernaer wrote:
Mon Jan 08, 2018 3:17 pm
When updating to 3.2.2 I get the following message:
The file differ failed to open Array.
[phpBB Debug] "file_get_contents(../install/update/new/language/nl/email/user_resend_inactive.txt): failed to open stream: No such file or directory" in file /home/deb78240n4/domains/zelfbeschadiging.be/public_html/phpbb/install/module/update_filesystem/task/diff_files.php on line 182
[phpBB Debug] "Array to string conversion" in file /home/deb78240n4/domains/zelfbeschadiging.be/public_html/phpbb/language/language.php on line 313
I use the full download packaget
When using the full package, I see no reason why a file difference would be made.
Check which package you used, if it's the full package, check whether all files have been uploaded.

Is it possible that you started update instead of update database? (which is what you should have done when using the full package).

Re: Update 3.2.1 >>> 3.2.2

Posted: Mon Jan 08, 2018 5:03 pm
by Marc
If you uploaded the full package after initially starting with the automatic updater, please make sure to first delete store/install_config.php.
Afterwards you should be able to choose the, in this case needed, database update only.

Re: Update 3.2.1 >>> 3.2.2

Posted: Mon Jan 08, 2018 5:11 pm
by bennybernaer
Marc wrote:
Mon Jan 08, 2018 5:03 pm
If you uploaded the full package after initially starting with the automatic updater, please make sure to first delete store/install_config.php.
Afterwards you should be able to choose the, in this case needed, database update only.
Fixed! Thx!

Re: Update 3.2.1 >>> 3.2.2

Posted: Tue Jan 09, 2018 7:58 am
by wang5555
Marc wrote:
Mon Jan 08, 2018 5:03 pm
If you uploaded the full package after initially starting with the automatic updater, please make sure to first delete store/install_config.php.
Afterwards you should be able to choose the, in this case needed, database update only.
Thank you very much. :)

Suggest:
Write this method into the knowledge base - Updating 3.2.x ;)

Re: Update 3.2.1 >>> 3.2.2

Posted: Tue Jan 09, 2018 10:14 am
by Mick
As long as you haven’t modified core code there’s no reason to use the auto-updater.

Re: Update 3.2.1 >>> 3.2.2

Posted: Tue Jan 09, 2018 11:20 am
by PawelStroinski
I've done the same thing. I forgot I shouldn't update the whole filesystem. How to reverse the problem?

Re: Update 3.2.1 >>> 3.2.2

Posted: Tue Jan 09, 2018 11:52 am
by Mick
PawelStroinski wrote:
Tue Jan 09, 2018 11:20 am
I've done the same thing
Answered above I believe? viewtopic.php?f=556&t=2453596&p=14903956#p14903351

Re: Update 3.2.1 >>> 3.2.2

Posted: Sat Jan 27, 2018 8:00 am
by jstMusa
Marc wrote:
Mon Jan 08, 2018 5:03 pm
If you uploaded the full package after initially starting with the automatic updater, please make sure to first delete store/install_config.php.
Afterwards you should be able to choose the, in this case needed, database update only.
Very useful, thanks.