Disapearing attachments after update to 3.2.2

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
ahigh
Registered User
Posts: 1
Joined: Sun Mar 09, 2014 11:26 am

Re: Disapearing attachments after update to 3.2.2

Post by ahigh » Wed Aug 29, 2018 3:29 pm

I am experiencing this problem as well and very surprised it's been an active bug on the 3.2.2 now for over six months.

So given that am "just a regular user" what do I gotta do to get a patch for this issue on the latest stable release? Or do I have to go to the bleeding edge to fix this problem for my users that are left scratching their heads wondering what THEY did wrong?

User avatar
janus_zonstraal
Registered User
Posts: 3456
Joined: Sat Aug 30, 2014 1:30 pm

Re: Disapearing attachments after update to 3.2.2

Post by janus_zonstraal » Wed Aug 29, 2018 4:44 pm

The fix is here for 8 months:
viewtopic.php?f=556&t=2453611
Sorry! My English is bat ;) !!!

sfzeller
Registered User
Posts: 43
Joined: Mon Dec 11, 2017 9:02 pm

Re: Disapearing attachments after update to 3.2.2

Post by sfzeller » Wed Aug 29, 2018 6:17 pm

I am having the same issue after I updated to phpBB 3.2.3 this morning. Do I need to download/install an additional patch to fix this issue, and if yes, where can I find it?

Thank you,
Sascha

sfzeller
Registered User
Posts: 43
Joined: Mon Dec 11, 2017 9:02 pm

Re: Disapearing attachments after update to 3.2.2

Post by sfzeller » Wed Aug 29, 2018 6:24 pm

Never mind -- The two previous posts were not there yet when I looked at this topic. Thanks, janus!

yousafzai
Registered User
Posts: 11
Joined: Mon Oct 17, 2016 10:18 am

Re: Disapearing attachments after update to 3.2.2

Post by yousafzai » Thu Jan 03, 2019 12:56 am

Having spent the last 6 hrs trying to fix this issue of "Attachment not showing inline" even thought all the files were intact in the /files folder.

I finally got it fixed by backtracking

I did an update 3.2.1 to 3.2.5.
My wordpress was telling me a newer version of php would be better to speed things up. so i went from 5.5 to 7.1 the highest available.

I did not know this until 10 min ago that this could have been the issue. So I went and changed back to 5.5 and all of a sudden my attachment files are back.

So weird.

moreover, When I first switched from 5.5 to 7.1 I had to change
config.php from "msql" to "msqli". Reverted back to "msql" with 5.5 otherwise won't work.

working fine now. hope this helps someone.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66566
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Disapearing attachments after update to 3.2.2

Post by Lumpy Burgertushie » Thu Jan 03, 2019 4:23 am

mysql not msql

and , php 7 will not work with mysql it must be mysqli

however, php5.5 and up will work just fine with mysqli

remember, anytime you make a change to the config.php file you need to purge the cache.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
david63
Registered User
Posts: 16411
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Disapearing attachments after update to 3.2.2

Post by david63 » Thu Jan 03, 2019 7:09 am

Lumpy Burgertushie wrote:
Thu Jan 03, 2019 4:23 am
anytime you make a change to the config.php file you need to purge the cache
Not in 3.2 you don't as config is no longer cached - that was in 3.1
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
janus_zonstraal
Registered User
Posts: 3456
Joined: Sat Aug 30, 2014 1:30 pm

Re: Disapearing attachments after update to 3.2.2

Post by janus_zonstraal » Thu Jan 03, 2019 9:18 am

I did an update 3.2.1 to 3.2.5.
If it is not working than you forgot some file(s), probably the file.php in the download folder.

phpbb 3.2.5 is working even on phpbb7.2,
php5.5 is way to old and not save anymore to use!
Sorry! My English is bat ;) !!!

User avatar
John connor
Registered User
Posts: 2201
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

Re: Disapearing attachments after update to 3.2.2

Post by John connor » Thu Jan 03, 2019 3:55 pm

janus_zonstraal wrote:
Thu Jan 03, 2019 9:18 am
I did an update 3.2.1 to 3.2.5.
If it is not working than you forgot some file(s), probably the file.php in the download folder.

phpbb 3.2.5 is working even on phpbb7.2,
php5.5 is way to old and not save anymore to use!
You're English is definitely bat, yo! :lol:

ozstamps
Registered User
Posts: 46
Joined: Tue Apr 03, 2007 3:48 pm

Re: Disapearing attachments after update to 3.2.2

Post by ozstamps » Sun Jan 13, 2019 4:37 am

I am a very non-tech board owner, that has about 900,000 self-hosted images.

VERY often several images are used in QUOTE mode, and on a test board we set up late 2018 they were not all showing.

We are about to update to 3.2.5

Can anyone please advise if this bug has been fixed in 3.2.5?

Thanks in advance!

User avatar
GanstaZ
Registered User
Posts: 804
Joined: Wed Oct 11, 2017 10:29 pm
Location: Zverse

Re: Disapearing attachments after update to 3.2.2

Post by GanstaZ » Sun Jan 13, 2019 4:47 am

That bug was fixed a long time ago and it was mentioned in this topic as well.
"When answer lies in the question,.. question becomes redundant!"

ozstamps
Registered User
Posts: 46
Joined: Tue Apr 03, 2007 3:48 pm

Re: Disapearing attachments after update to 3.2.2

Post by ozstamps » Sun Jan 13, 2019 4:59 am

GanstaZ wrote:
Sun Jan 13, 2019 4:47 am
That bug was fixed a long time ago and it was mentioned in this topic as well.
It was still there in this 3.2.3 test board a mod set up in October 2018 for us to experiment on. As can be seen -

https://stampmall.com.au/forum/viewtopi ... 5&p=43#p43

File names for images also came up under each image quoted - can they be dispensed with with Admin panel etc?

Our board is very image heavy and most using it are retired age plus = 65+, so anything slightly complicated they struggle with. :mrgreen:

User avatar
Lumpy Burgertushie
Registered User
Posts: 66566
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Disapearing attachments after update to 3.2.2

Post by Lumpy Burgertushie » Sun Jan 13, 2019 5:02 am

:lol:
I would be careful making assumptions about the abilities of older users around here. ;)

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
3Di
Former Team Member
Posts: 14068
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Disapearing attachments after update to 3.2.2

Post by 3Di » Sun Jan 13, 2019 5:04 am

ozstamps wrote:
Sun Jan 13, 2019 4:37 am
VERY often several images are used in QUOTE mode, and on a test board we set up late 2018 they were not all showing.
Yeah, you need this extension of mine
viewtopic.php?f=456&t=2410161
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

ozstamps
Registered User
Posts: 46
Joined: Tue Apr 03, 2007 3:48 pm

Re: Disapearing attachments after update to 3.2.2

Post by ozstamps » Sun Jan 13, 2019 5:31 am

3Di wrote:
Sun Jan 13, 2019 5:04 am
ozstamps wrote:
Sun Jan 13, 2019 4:37 am
VERY often several images are used in QUOTE mode, and on a test board we set up late 2018 they were not all showing.
Yeah, you need this extension of mine
viewtopic.php?f=456&t=2410161
If this extension fix works, and it sounds like does, (well done!) surely it might be built into future updates of PhpBB?

I have a large board with 900,000 self hosted images, which are often "QUOTED" 3 or 4 at a time etc, and even the latest php 3.2.5 version does not seem to accept that?

A very basic user feature surely for the standard phpBB platform going forward?

Post Reply

Return to “[3.2.x] Support Forum”