Error updating from 3.2.0 to 3.2.2

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
leovj92
Registered User
Posts: 5
Joined: Tue Jan 17, 2017 8:39 am

Error updating from 3.2.0 to 3.2.2

Post by leovj92 » Tue Jan 16, 2018 4:07 am

Hi,

I hope that you can help me to solve this issue. I updated my forum from the 3.2.0 version to 3.2.2 but in the final step "Update database" the follow error appears:
The installer detected a timeout
The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI.

Installing Data: \phpbb\db\migration\data\v32x\merge_duplicate_bbcodes.
What I have to do in order to finish the installation correctly?

Best regards from México

janus_zonstraal
Registered User
Posts: 2275
Joined: Sat Aug 30, 2014 1:30 pm

Re: Error updating from 3.2.0 to 3.2.2

Post by janus_zonstraal » Tue Jan 16, 2018 6:52 am

Sorry! My English is bat ;) !!!

User avatar
RomanV
Registered User
Posts: 37
Joined: Thu Apr 03, 2003 11:17 am
Contact:

Re: Error updating from 3.2.0 to 3.2.2

Post by RomanV » Tue Jan 16, 2018 3:11 pm

I am aslo getting the same error message during conversion from 3.2.0 to 3.2.2
The progress bar went to 83%.
Then there is the error message:
The installer detected a timeout
The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI.
Then in control panel it shows:
Your phpBB installation has not been correctly updated. Please read the information below in order to fix this error.

A new feature release 3.2.2 is available. Please read the release announcement to learn about what it has to offer, and how to upgrade.

Files Version
3.2.2
Database version
3.2.1
It's not clear what to look for in the link suggested above.
Where is help on using CLI variant of database upgrade?

User avatar
RomanV
Registered User
Posts: 37
Joined: Thu Apr 03, 2003 11:17 am
Contact:

Re: Error updating from 3.2.0 to 3.2.2

Post by RomanV » Tue Jan 16, 2018 3:17 pm

OK. I found the solution given in
viewtopic.php?f=556&t=2453496

In config.php file I changed from

Code: Select all

$dbms = 'mysql';
to

Code: Select all

$dbms = 'mysqli';
Then I restarted database upgrade procedure and it did work. It's OK now.

leovj92
Registered User
Posts: 5
Joined: Tue Jan 17, 2017 8:39 am

Re: Error updating from 3.2.0 to 3.2.2

Post by leovj92 » Wed Jan 17, 2018 1:07 am

I tried all your suggests but none worked and I had to restore the forum and lost the messages of the last days.

janus_zonstraal
Registered User
Posts: 2275
Joined: Sat Aug 30, 2014 1:30 pm

Re: Error updating from 3.2.0 to 3.2.2

Post by janus_zonstraal » Wed Jan 17, 2018 6:48 am

leovj92 wrote:
Wed Jan 17, 2018 1:07 am
I tried all your suggests but none worked and I had to restore the forum and lost the messages of the last days.
Best way is to make a copy of your board and try the update with this "test board" first.
Sorry! My English is bat ;) !!!

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: alex4orly, Lumpy Burgertushie, Michael_Hoffman, Noxwizard and 20 guests