After updating from 3.2.1 to 3.2.2, errors replying to posts

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
jpfund
Registered User
Posts: 3
Joined: Fri Aug 04, 2017 6:09 pm

After updating from 3.2.1 to 3.2.2, errors replying to posts

Post by jpfund » Wed Jan 17, 2018 4:54 pm

Support Request Template
What version of phpBB are you using? phpBB 3.2.2
What is your board's URL? http://johannapfundwebdeveloper.com/dfforum
Who do you host your board with? Godaddy.com
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.2.1
What extensions do you have installed? s9e/mediaembed
VigLink
What styles do you currently have installed? prosilver
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? Experienced with PHP and phpBB
What username can be used to view this issue? phpBBtester
What password can be used to view this issue? bbTEST1437!
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Updated from 3.2.1, seemed to be successful after changing config.php mysql to mysqli. Had a problem when I tested replying to a post, thought it was with the s9e/mediaembed extension so I disabled it, which is the state it is in now. I purged the cache and tried to reply to a post again.
Please describe your problem. Fatal error: Call to undefined method s9e\TextFormatter\Parser\Logger::getLogs() in /home/stqp4mocehlt/public_html/dfforum/phpbb/textformatter/s9e/parser.php on line 199
Generated by SRT Generator

User avatar
chanlon1
Registered User
Posts: 105
Joined: Wed Mar 09, 2005 10:01 pm
Location: Belfast, N. Ireland
Contact:

Re: After updating from 3.2.1 to 3.2.2, errors replying to posts

Post by chanlon1 » Wed Jan 17, 2018 10:29 pm

Just tried to post and got the error message you state.

I'm no expert but given the path in the error message mentions "s9e\TextFormatter" and that this is some kind of plugin available, I would suggest disabling it and see what happens.

jpfund
Registered User
Posts: 3
Joined: Fri Aug 04, 2017 6:09 pm

Re: After updating from 3.2.1 to 3.2.2, errors replying to posts

Post by jpfund » Thu Jan 18, 2018 12:28 am

Hi, I did disable it, as noted in my description (easy to miss, there is a lot of detail in my description). I have not yet tried to remove the extension - only disabled at this point. Thanks for confirming the error - it is helpful to know it's not just me.

User avatar
david63
Jr. Extension Validator
Posts: 14101
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: After updating from 3.2.1 to 3.2.2, errors replying to posts

Post by david63 » Thu Jan 18, 2018 1:38 am

chanlon1 wrote:
Wed Jan 17, 2018 10:29 pm
Just tried to post and got the error message you state.

I'm no expert but given the path in the error message mentions "s9e\TextFormatter" and that this is some kind of plugin available, I would suggest disabling it and see what happens.
s9e\TextFormatter is, if I am not mistaken, part of the bbcode processing files and it is not possible to disable it unless you want to try removing it from core code
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
chanlon1
Registered User
Posts: 105
Joined: Wed Mar 09, 2005 10:01 pm
Location: Belfast, N. Ireland
Contact:

Re: After updating from 3.2.1 to 3.2.2, errors replying to posts

Post by chanlon1 » Thu Jan 18, 2018 9:48 am

david63 wrote:
Thu Jan 18, 2018 1:38 am
s9e\TextFormatter is, if I am not mistaken, part of the bbcode processing files and it is not possible to disable it unless you want to try removing it from core code
Opps, I wasn’t aware of that.

Blacktiger63
Registered User
Posts: 54
Joined: Thu Oct 17, 2013 7:43 pm

Re: After updating from 3.2.1 to 3.2.2, errors replying to posts

Post by Blacktiger63 » Mon Feb 05, 2018 7:34 pm

I'm having exactly the same after the automatic update from 3.2.1 to 3.2.2. Same parser, same line.

Code: Select all

PHP Fatal error:  Call to undefined method s9e\\TextFormatter\\Parser\\Logger::getLogs() in /home/jnkat/domains/myforums.nl/public_html/forum/phpbb/textformatter/s9e/parser.php on line 199, referer: https://www.myforums.nl/forum/posting.php?mode=reply&f=4&t=8388
Is there a way to fix this? Except putting a 3.2.1. backup back?

I did not have any timeouts, error notices or issues during the upgrade.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 19125
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: After updating from 3.2.1 to 3.2.2, errors replying to posts

Post by Mick » Mon Feb 05, 2018 7:39 pm

Have you modified any of the core code?
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

Blacktiger63
Registered User
Posts: 54
Joined: Thu Oct 17, 2013 7:43 pm

Re: After updating from 3.2.1 to 3.2.2, errors replying to posts

Post by Blacktiger63 » Mon Feb 05, 2018 7:53 pm

No I did not modify any core code except for the colours.css and common.css file.
During the automatic upgrade it said the original file would migrate my changes into it or something similar.

The only core files I modified where done today to see if the "knownn issues in 3.2.2" posted here by Marc:
viewtopic.php?f=556&t=2453611
would fix the issue, but it didn't.

For the rest I never touch core files.

User avatar
canonknipser
Registered User
Posts: 1472
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: After updating from 3.2.1 to 3.2.2, errors replying to posts

Post by canonknipser » Mon Feb 05, 2018 8:04 pm

Try to re-upload the complete vendor folder of 3.2.2, overwriting existing files
Greetings
Frank
phpbb.de support team member
English is not my native language
New arrival - Extensions and scripts for phpBB
no support via PM or mail

janus_zonstraal
Registered User
Posts: 2271
Joined: Sat Aug 30, 2014 1:30 pm

Re: After updating from 3.2.1 to 3.2.2, errors replying to posts

Post by janus_zonstraal » Mon Feb 05, 2018 8:09 pm

Blacktiger63 wrote:
Mon Feb 05, 2018 7:53 pm
No I did not modify any core code except for the colours.css and common.css file.
During the automatic upgrade it said the original file would migrate my changes into it or something similar.

The only core files I modified where done today to see if the "knownn issues in 3.2.2" posted here by Marc:
viewtopic.php?f=556&t=2453611
would fix the issue, but it didn't.

For the rest I never touch core files.
As I look to your board there is little you didn't change :lol:

Can you upload the standard prosilver style and look what is happening?
Sorry! My English is bat ;) !!!

Blacktiger63
Registered User
Posts: 54
Joined: Thu Oct 17, 2013 7:43 pm

Re: After updating from 3.2.1 to 3.2.2, errors replying to posts

Post by Blacktiger63 » Mon Feb 05, 2018 8:21 pm

@Janus: I think you looked at the wrong url, because I'm not the original poster here, so you don't know my url. :)
I'm just having the same issue after updating and I only changed the .css files mentioned. There is no reason for me to lie about that because it would only stand in the way of fixing things. 8-)

@canonknipser: Just to be sure, I deleted the complete vender folder and uploaded a fresh one.
This seems to have done the trick, posting is possible again, thanks a million!!! :D

User avatar
Lumpy Burgertushie
Registered User
Posts: 64267
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: After updating from 3.2.1 to 3.2.2, errors replying to posts

Post by Lumpy Burgertushie » Tue Feb 06, 2018 2:12 am

Blacktiger63 wrote:
Mon Feb 05, 2018 8:21 pm
@Janus: I think you looked at the wrong url, because I'm not the original poster here, so you don't know my url. :)
I'm just having the same issue after updating and I only changed the .css files mentioned. There is no reason for me to lie about that because it would only stand in the way of fixing things. 8-)

@canonknipser: Just to be sure, I deleted the complete vender folder and uploaded a fresh one.
This seems to have done the trick, posting is possible again, thanks a million!!! :D
your problem is probably related to the fact that you used the autoupdate method of updating.

from now on, the best method of updating/upgrading is a complete file replacement except for the config.php file. then update the database only.

https://www.phpbb.com/support/docs/en/3 ... ating-32x/

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Brf, david63, Google [Bot], Holger Laux, Mohammed AlSarsawi, morkus, stevemaury and 40 guests