Fatal Error Migrating existing forum to PHP 7 host

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
kinerity
Community Team Member
Community Team Member
Posts: 1337
Joined: Mon Sep 01, 2014 1:00 am
Name: Kailey Truscott
Contact:

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by kinerity » Tue Jan 23, 2018 3:08 am

Does the new host have the option of using PHP 5.5 or 5.6? If so, then switch to that version and upload your backup of your 3.0 board. Then upload the stk and run the database cleaner.
Kailey Truscott - Community Team

UXgizmo
Registered User
Posts: 34
Joined: Wed Jan 17, 2018 9:36 pm

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by UXgizmo » Tue Jan 23, 2018 3:19 am

kinerity wrote:
Tue Jan 23, 2018 3:08 am
Does the new host have the option of using PHP 5.5 or 5.6? If so, then switch to that version and upload your backup of your 3.0 board. Then upload the stk and run the database cleaner.
I was able to run php 5.4 native on the server the stk file ran through each step it didn't seem to call out any custom styles nor find any issues. So I deleted all files (except config/store/images/files ..) tried to ftp 3.2 files but now my ftp keeps kicking me out because filezilla is making too many connections. I changed the limit to 1 connection but still keeps kicking me out so now it seems I'm missing essential files when I go to upload.

User avatar
kinerity
Community Team Member
Community Team Member
Posts: 1337
Joined: Mon Sep 01, 2014 1:00 am
Name: Kailey Truscott
Contact:

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by kinerity » Tue Jan 23, 2018 3:21 am

FileZilla has been known to cause issues. Try using WinSCP.
Kailey Truscott - Community Team

UXgizmo
Registered User
Posts: 34
Joined: Wed Jan 17, 2018 9:36 pm

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by UXgizmo » Tue Jan 23, 2018 3:30 am

kinerity wrote:
Tue Jan 23, 2018 3:21 am
FileZilla has been known to cause issues. Try using WinSCP.
same
"Timeout detected. (control connection)
Copying files to remote side failed."

User avatar
kinerity
Community Team Member
Community Team Member
Posts: 1337
Joined: Mon Sep 01, 2014 1:00 am
Name: Kailey Truscott
Contact:

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by kinerity » Tue Jan 23, 2018 3:40 am

You did select "FTP" from the dropdown, correct? Default is SFTP.
Kailey Truscott - Community Team

User avatar
3Di
Registered User
Posts: 12131
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT), Frankfurt (DE)
Name: Marco
Contact:

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by 3Di » Tue Jan 23, 2018 3:41 am

UXgizmo wrote:
Tue Jan 23, 2018 3:30 am
kinerity wrote:
Tue Jan 23, 2018 3:21 am
FileZilla has been known to cause issues. Try using WinSCP.
same
"Timeout detected. (control connection)
Copying files to remote side failed."
I use WinSCP, you should play with its settings.

In some cases though, to be faster (waay faster) I am used to prepare an archive to explode inside the root, over there with the server's file manager, but you really need to feel confortable on what you are doing. In this case it's just a matter of seconds/minute.
Want to compensate me for my interest? Donate
Please PM me only to request paid works. Thx.
Extensions, Scripts, MOD porting, Update/Upgrades

UXgizmo
Registered User
Posts: 34
Joined: Wed Jan 17, 2018 9:36 pm

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by UXgizmo » Tue Jan 23, 2018 4:01 am

kinerity wrote:
Tue Jan 23, 2018 3:40 am
You did select "FTP" from the dropdown, correct? Default is SFTP.
Yes it was set to ftp

UXgizmo
Registered User
Posts: 34
Joined: Wed Jan 17, 2018 9:36 pm

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by UXgizmo » Tue Jan 23, 2018 4:02 am

3Di wrote:
Tue Jan 23, 2018 3:41 am
I use WinSCP, you should play with its settings.

In some cases though, to be faster (waay faster) I am used to prepare an archive to explode inside the root, over there with the server's file manager, but you really need to feel confortable on what you are doing. In this case it's just a matter of seconds/minute.
What's best tool for archiving? I've never done it before.

UXgizmo
Registered User
Posts: 34
Joined: Wed Jan 17, 2018 9:36 pm

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by UXgizmo » Wed Jan 24, 2018 12:34 am

still seeing these errors for post that use the "quote" button to reply. All other content seems to show upThoughts? This is the backup site that is running php 5.4 native. not php 7

Message appears at the very top of the page:

[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 445: preg_replace_callback(): Requires argument 2, '', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 112: preg_replace_callback(): Requires argument 2, '<a href="$1" class="postlink">$2</a>::<a href="$1" class="postlink">$2</a>', to be a valid callback
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4586: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4588: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4589: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4590: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)

UXgizmo
Registered User
Posts: 34
Joined: Wed Jan 17, 2018 9:36 pm

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by UXgizmo » Wed Jan 24, 2018 1:27 am

I went ahead and tried to update to 3.2.x made it up to about 97% with this error

"The installer detected a timeout
The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI."

Thoughts?

User avatar
kinerity
Community Team Member
Community Team Member
Posts: 1337
Joined: Mon Sep 01, 2014 1:00 am
Name: Kailey Truscott
Contact:

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by kinerity » Wed Jan 24, 2018 2:07 am

So close! :lol:

In your config.php file, is the DBMS value set to mysqli? That's the only thing I can think of as of right now.
Kailey Truscott - Community Team

User avatar
P_I
Registered User
Posts: 815
Joined: Tue Mar 01, 2011 8:35 pm
Location: Calgary
Contact:

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by P_I » Wed Jan 24, 2018 2:12 am

Also make sure the changes/fixes specified in Known issues in 3.2.2 are applied before the database update is started.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

UXgizmo
Registered User
Posts: 34
Joined: Wed Jan 17, 2018 9:36 pm

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by UXgizmo » Wed Jan 24, 2018 2:18 am

kinerity wrote:
Wed Jan 24, 2018 2:07 am
So close! :lol:

In your config.php file, is the DBMS value set to mysqli? That's the only thing I can think of as of right now.
Touchdown I made it to 100% 3.2 on php 5.4 native backup! However I went to my board and nothing is there? How do I turn the board back on. I can see the topics in the ACP but they aren't showing up in the index.

User avatar
kinerity
Community Team Member
Community Team Member
Posts: 1337
Joined: Mon Sep 01, 2014 1:00 am
Name: Kailey Truscott
Contact:

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by kinerity » Wed Jan 24, 2018 2:19 am

Permissions?
Kailey Truscott - Community Team

UXgizmo
Registered User
Posts: 34
Joined: Wed Jan 17, 2018 9:36 pm

Re: Fatal Error Migrating existing forum to PHP 7 host

Post by UXgizmo » Wed Jan 24, 2018 2:28 am

kinerity wrote:
Wed Jan 24, 2018 2:19 am
Permissions?
On the board index I don't see any forum topics.

When I login as founder I don't see any forum topics.

However when I go to the ACP I can see the original forum topics listed. (they just aren't showing up on the index page)

the information I see on main blog board "Information
Sorry but this board is currently unavailable."

Under
Forum administration (all topics are listed) do need re sync something?

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: AmigoJack, Google [Bot], henniee, OrchillCoarseFishery, panhead, Son sovan and 31 guests