Page 1 of 1

update error 3.2.1 - 3.2.2

Posted: Fri Jan 19, 2018 6:51 am
by newsmedia
I am puzzled as to why you continue with an update release that has obvious flaws, visible by the numbers reporting the same issue.

I have a standard installation of phpbb. Using the automatic update package and attempting to upgrade constantly produces the timeout error:
The installer detected a timeout
The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI.
rendering my board totally unuseable, not matter what I try.

CLI - whatever that is, is not an option for me with no access to php root.

Re: update error 3.2.1 - 3.2.2

Posted: Fri Jan 19, 2018 1:04 pm
by kinerity
newsmedia wrote:
Fri Jan 19, 2018 6:51 am
I have a standard installation of phpbb. Using the automatic update package
If you have a standard installation of phpBB (no modifications to core files), why are you using the automatic update package? Try uploading the FULL phpBB 3.2.2 package and run the Database Only update.

Re: update error 3.2.1 - 3.2.2

Posted: Fri Jan 19, 2018 1:14 pm
by P_I
Have you applied the changes mentioned in Known issues in 3.2.2?

Re: update error 3.2.1 - 3.2.2

Posted: Fri Jan 19, 2018 1:52 pm
by newsmedia
yes I applied the 'fixes' with no change.

There is no option to update the database.

Re: update error 3.2.1 - 3.2.2

Posted: Fri Jan 19, 2018 2:55 pm
by kinerity

Re: update error 3.2.1 - 3.2.2

Posted: Fri Jan 19, 2018 6:11 pm
by newsmedia
Further to this post: on logging in to my board as admin:
We noticed that the last update of your phpBB installation hasn’t been completed. Visit the database updater, ensure Update database only is selected and click on Submit.
Clicking the database updater link simply open install/app.php/update - there is no option to select update database - only a full update which just reverts back to the same update error.

Given all this and no fix I am now minded to permanently remove phpbb.

Re: update error 3.2.1 - 3.2.2

Posted: Fri Jan 19, 2018 6:31 pm
by newsmedia
UPDATE

OK - I logged out, changed the config.php content MySQLto MySQLi- reran the upgrade and it worked OK.

Then changed the config.php back to MySQL.

However, surely this should not be necessary ????

Re: update error 3.2.1 - 3.2.2

Posted: Fri Jan 19, 2018 6:33 pm
by Crizzo
Why the change back to MySQL?

Re: update error 3.2.1 - 3.2.2

Posted: Fri Jan 19, 2018 6:45 pm
by newsmedia
Crizzo wrote:
Fri Jan 19, 2018 6:33 pm
Why the change back to MySQL?
mainly because the original installation was MySQL, but also to see what happened. As all seems OK - will leave it at MySQL for now :)

Re: update error 3.2.1 - 3.2.2

Posted: Fri Jan 19, 2018 6:48 pm
by Crizzo
That is only the connection method. Just use MySQLi, which is supported by PHP 7.0 and higher. Which MySQL is not. ;)

See the warning: http://php.net/manual/en/mysql.requirements.php

Re: update error 3.2.1 - 3.2.2

Posted: Fri Jan 19, 2018 6:50 pm
by newsmedia
Crizzo wrote:
Fri Jan 19, 2018 6:48 pm
That is only the connection method. Just use MySQLi, which is supported by PHP 7.0 and higher. Which MySQL is not. ;)
Thanks for that - am not great on the vagaries of MySQL. Will change it back to MySQLi and leave it as so.

Re: update error 3.2.1 - 3.2.2

Posted: Fri Jan 19, 2018 6:53 pm
by P_I
newsmedia wrote:
Fri Jan 19, 2018 6:45 pm
Crizzo wrote:
Fri Jan 19, 2018 6:33 pm
Why the change back to MySQL?
mainly because the original installation was MySQL, but also to see what happened. As all seems OK - will leave it at MySQL for now :)
If you want some background, read PHP: Overview of the MySQL PHP drivers - Manual. Definitely recommend using mysqli in config.php

Re: update error 3.2.1 - 3.2.2

Posted: Sat Jan 20, 2018 3:26 pm
by ~Sentinel~
I just ran into an almost similar problem. It seems as though the server on one of the boards I admin was running php 5.4. No where in the update did it say that 5.6 was necessary before doing this update. Since I never had a problem before I just updated the usual way and got the database error. After reading this I edited my config.php file to add the "i" to the end of MySQL and it worked like a charm. I also changed the server to php 5.6 afterward.

I really think that a good idea would be to put at the top of the instructions that this new version requires that you have php 5.6 or higher before beginning the update. Seeing the number of posts about this and assuming that there are a bunch more that are not posting, it would seem a prudent thing to do.
Had I seen a warning like that I would have checked the server first and found that I was lacking, updated the server to 5.6 before performing the update, and then do the update.

But here's a quick question if I may ... since my original config had MySQL (with no "i") is there any danger to putting the "i" in there? Could putting an i in there screw anything up since it originally had no "i"?

Thanks for this topic by the way. It was a life saver.

Re: update error 3.2.1 - 3.2.2

Posted: Sat Jan 20, 2018 3:41 pm
by kinerity
~Sentinel~ wrote:
Sat Jan 20, 2018 3:26 pm
But here's a quick question if I may ... since my original config had MySQL (with no "i") is there any danger to putting the "i" in there? Could putting an i in there screw anything up since it originally had no "i"?
No, the i stands for improved. You shouldn't notice any difference as far as functionality.

Re: update error 3.2.1 - 3.2.2

Posted: Sat Jan 20, 2018 4:12 pm
by ~Sentinel~
Thank you. Very much appreciated.