Message posting slow, everything else good

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
robincarder
Registered User
Posts: 4
Joined: Mon Feb 05, 2018 9:09 pm

Message posting slow, everything else good

Post by robincarder » Mon Feb 05, 2018 9:22 pm

Support Request Template

What version of phpBB are you using? phpBB 3.2.2
What is your board's URL? www.shotsweb.co.uk/phpbb/index.php
Who do you host your board with? PurpleJelly
How did you install your board? Fresh 3.2 install tonight, 3.1.9 previosuly
What is the most recent action performed on your board? Upgrade to try and fix this issue. Didn't help
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.1.9
What extensions do you have installed? Stop Forum Spam, Tapatalk
What styles do you currently have installed? prosilver previously, trying MyInvision now - problem evident with both
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5.6.30
What is your level of experience? Experienced with PHP and phpBB
What username can be used to view this issue? test1
What password can be used to view this issue? Password1

What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable?

Nothing I am aware of. All the actions above have been to try and rectify (upgrade, and style change). Have also tried running with StopForumSpam off.

Please describe your problem: Board performance is great - but not with posting messages and replies. 35 second delay. Have tried optimizing any/all database tables - but am not a DBA. Believe this has degraded over time.

robincarder
Registered User
Posts: 4
Joined: Mon Feb 05, 2018 9:09 pm

Re: Message posting slow, everything else good

Post by robincarder » Tue Feb 06, 2018 7:51 pm

Anyone?
I have put on debug logging tonight - but didn't really show much, a few issues with headers at the top of the page - but seeing that all over the site
The SQLExplain page shows that all the queries are super quick on loading the browse pages.
How do I get a track on the SQl queries doing the "INSERT"???
Robin

User avatar
AmigoJack
Registered User
Posts: 5573
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: Message posting slow, everything else good

Post by AmigoJack » Wed Feb 07, 2018 9:04 am

Did this start with a particular day, or has the slowness increased steadily over months/years? Does it also affect composing private messages?
The worst thing about censorship is ███████████
Affin wrote:
Tue Nov 20, 2018 9:51 am
The problem is probably not my English but you do not want to understand correctly.
...
We will not come anybody anyway, nevertheless, it's best to shit this.

robincarder
Registered User
Posts: 4
Joined: Mon Feb 05, 2018 9:09 pm

Re: Message posting slow, everything else good

Post by robincarder » Wed Feb 07, 2018 9:17 am

Hi,

I think it has been gradual degradation. But starting to doubt myself now
PMs are instant and fine

I think its something environmental on the database.
Last night when I had a direct connection open via HeidiSQL and I was monitoring the process running (as I tested) - it resolved for that temporary period that the SQL client was running.

Once I shut the client down we were back to slow again !

So I am 100% convinced it is something in database territory

I pruned the userbase last night from nearly 5000 to about 1000. No improvements. I have cleared the notifications table etc that was huge. I keep optimizing and repairing any/all tables.

R

User avatar
AmigoJack
Registered User
Posts: 5573
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: Message posting slow, everything else good

Post by AmigoJack » Wed Feb 07, 2018 10:45 am

Which search backend do you use: "native"? As each post submission would add more words to the index this could be the culprit. If you are using MySQL as DBMS then switch to "MySQL fulltext" search backend - if then submitting posts is remarkebly faster then we'd only have to make sure searching still works.
The worst thing about censorship is ███████████
Affin wrote:
Tue Nov 20, 2018 9:51 am
The problem is probably not my English but you do not want to understand correctly.
...
We will not come anybody anyway, nevertheless, it's best to shit this.

robincarder
Registered User
Posts: 4
Joined: Mon Feb 05, 2018 9:09 pm

RESOLVED: Message posting slow, everything else good

Post by robincarder » Wed Feb 07, 2018 2:23 pm

My amazing Hosting provider got to the bottom of it.

Setting: Check IP against DNS Blackhole list!

This was causing all the issues. Turned it off and resolved instantly. Maybe one of the third party lookup services has delays?

User avatar
AmigoJack
Registered User
Posts: 5573
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: Message posting slow, everything else good

Post by AmigoJack » Thu Feb 08, 2018 8:40 am

If you still want to use it for registrations but not for submitting a post then open /posting.php and find:

Code: Select all

	// DNSBL check
	if ($config['check_dnsbl'] && !$refresh)
	{
		if (($dnsbl = $user->check_dnsbl('post')) !== false)
		{
			$error[] = sprintf($user->lang['IP_BLACKLISTED'], $user->ip, $dnsbl[1]);
		}
	}
and make it a comment.
The worst thing about censorship is ███████████
Affin wrote:
Tue Nov 20, 2018 9:51 am
The problem is probably not my English but you do not want to understand correctly.
...
We will not come anybody anyway, nevertheless, it's best to shit this.

neckflo
Registered User
Posts: 26
Joined: Thu Aug 01, 2013 7:55 pm

Re: Message posting slow, everything else good

Post by neckflo » Wed Jan 02, 2019 12:29 pm

Thanks for the Post. I had the same issue with delaying on postings. It was 20 seconds to write new posts. Now with the Change to off. It works.
Unbenannt.JPG

Post Reply

Return to “[3.2.x] Support Forum”