Page 1 of 1

Report post link broken after upgrade to 3.2.2

Posted: Thu Feb 15, 2018 4:31 pm
by BigBoosting
Hi, I've upgraded to 3.2.2 from 3.2.1 and it seems my Report Post link is now not functioning.

Instead of going to
myforum.com/post/8129/report
the link is sending you to
myforum.com/app.phpviewtopic.php/post/8129/report


Just wondering what file has the functionality of forming the link so I can fix this.

Thanks,
Erica

Re: Report post link broken after upgrade to 3.2.2

Posted: Thu Feb 15, 2018 4:40 pm
by stevemaury
Are you running ngnix?

Re: Report post link broken after upgrade to 3.2.2

Posted: Thu Feb 15, 2018 4:56 pm
by BigBoosting
stevemaury wrote:
Thu Feb 15, 2018 4:40 pm
Are you running ngnix?
Apache

Maybe it's relevant to say that during the upgrade, I also went from GoDaddy's web hosting to a VPS on GoDaddy. I had to change to mysqli but everything else runs just fine.

Re: Report post link broken after upgrade to 3.2.2

Posted: Thu Feb 15, 2018 7:22 pm
by stevemaury
If you have typed that filename correctly it does not exist in phpBB.

Re: Report post link broken after upgrade to 3.2.2

Posted: Thu Feb 15, 2018 9:21 pm
by BigBoosting
stevemaury wrote:
Thu Feb 15, 2018 7:22 pm
If you have typed that filename correctly it does not exist in phpBB.
myforum.com is just a place holder. The link should just be /post/POSTNUMBER/report but it's /app.phpviewtopic.php/post/POSTNUMBER/report. I'm just trying to figure out how to get the app.phpviewtopic.php part out of the link

Re: Report post link broken after upgrade to 3.2.2

Posted: Thu Feb 15, 2018 10:05 pm
by Lumpy Burgertushie
in the admin panel, do you have the "force url settings" set to yes? if so, what do you have for the blanks after that?

you should set that to no unless you really know that you need it set to yes.
do you have url rewrite set to no? if so, set it to yes.


robert

Re: Report post link broken after upgrade to 3.2.2

Posted: Thu Feb 15, 2018 10:11 pm
by BigBoosting
Lumpy Burgertushie wrote:
Thu Feb 15, 2018 10:05 pm
in the admin panel, do you have the "force url settings" set to yes? if so, what do you have for the blanks after that?

you should set that to no unless you really know that you need it set to yes.
do you have url rewrite set to no? if so, set it to yes.


robert
Force server URL settings is set to No.

Setting Enable URL Rewriting to Yes seems to have done the trick. I'll test more to make sure no new issues have popped up, but THANK YOU! I sincerely appreciate your help.

Re: Report post link broken after upgrade to 3.2.2

Posted: Thu Feb 15, 2018 10:42 pm
by 3Di
BigBoosting wrote:
Thu Feb 15, 2018 4:31 pm
Instead of going to
myforum.com/post/8129/report
the link is sending you to
myforum.com/app.phpviewtopic.php/post/8129/report
That should be (without URL rewriting)
{board_url}/app.php/post/8129/report

and (with URL rewriting)
{board_url}/post/8129/report

so apparently there is something else, wrong, if yours is
{board_url}/app.phpviewtopic.php/post/8129/report

Re: Report post link broken after upgrade to 3.2.2

Posted: Fri Feb 16, 2018 12:24 am
by Lumpy Burgertushie
yep, that is why I asked about the server settings.
how about the cookie path?
I am wild guessing here...
what do you have for the cookie domain and the cookie path?


robert

Re: Report post link broken after upgrade to 3.2.2

Posted: Fri Feb 16, 2018 12:39 am
by P_I
Does the OP have anything added to their board root level .htaccess file beyond what is provided by phpBB?