Email (SMTP) not working

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
Serenity Joe
Registered User
Posts: 7
Joined: Wed Feb 21, 2018 7:54 pm

Email (SMTP) not working

Post by Serenity Joe » Thu Feb 22, 2018 6:53 pm

Support Request Template
What version of phpBB are you using? phpBB 3.2.2
What is your board's URL? http://serenity.roguildforums.com
Who do you host your board with? IXWebHosting
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? No
What styles do you currently have installed? subsilver, k_blue_turtle
What language(s) is your board currently using? Brit English
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
What username can be used to view this issue? any new registration user
What password can be used to view this issue? <make a new user>
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? The application email did not function. My assumption is that it is prevented by the hosting (typically)
I setup a domain email account (forum[at]serenity.roguildforums.com)
I entered the email as the username (accounts require email address as the username) and password.
I initially used port 547 (or whatever it was the tech support identified as the normal alt port) but have since returned to default port 25.

I have verified the user credentials by setting up a client in outlook. It can receive/send email.
Please describe your problem. The sed test email... does nothing that I can determine.
New registration of test account(s) fail to get an activation email.
Generated by SRT Generator

Serenity Joe
Registered User
Posts: 7
Joined: Wed Feb 21, 2018 7:54 pm

Re: Email (SMTP) not working

Post by Serenity Joe » Thu Feb 22, 2018 7:40 pm

Current SMTP settings:
Image

User avatar
Meis2M
Translator
Posts: 809
Joined: Wed Mar 03, 2010 11:32 am
Location: IR.Damghan
Name: میثم نوبری
Contact:

Re: Email (SMTP) not working

Post by Meis2M » Thu Feb 22, 2018 8:03 pm

SMTP server port must be: 587

Authentication method for SMTP must be: PLAIN

Serenity Joe
Registered User
Posts: 7
Joined: Wed Feb 21, 2018 7:54 pm

Re: Email (SMTP) not working

Post by Serenity Joe » Thu Feb 22, 2018 10:19 pm

I originally was using those settings and it did not work.. so I began trying others.
As it is, I returned the settings as recommended but when I attempted to register a new account... it did not result in an email getting sent out. Is there somewhere I can see error logging?

User avatar
Lumpy Burgertushie
Registered User
Posts: 64454
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Email (SMTP) not working

Post by Lumpy Burgertushie » Fri Feb 23, 2018 12:42 am

try setting smtp to no. most people don't have to use it.
the standard php mail works just fine for most cases.

make sure whatever email address you are using for the board is one that you created with your own domain name.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

Serenity Joe
Registered User
Posts: 7
Joined: Wed Feb 21, 2018 7:54 pm

Re: Email (SMTP) not working

Post by Serenity Joe » Fri Feb 23, 2018 5:00 pm

Since a few things had changed I went back to not using SMTP.
No change, no email.

This is getting frustrating.

Setting it back to use SMTP. Is there an error log I can get to?

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Froddelaar, HiFiKabin and 28 guests