Help Needed to Upgrade From phpBB 2.0.21

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
lloyd_borrett
Registered User
Posts: 10
Joined: Sun Jun 20, 2004 2:04 am
Location: Rosebud, Victoria, Australia
Name: Lloyd Borrett
Contact:

Help Needed to Upgrade From phpBB 2.0.21

Post by lloyd_borrett » Sat Mar 10, 2018 1:11 pm

G'day,

I'm looking for a phpBB specialist who can help me to upgrade from phpBB version 2.0.21 to the latest version that can be supported on my hosting platform.

I first installed phpBB on the site back in 2006, running the subSilver theme. It was taken offline back in 2014/2015.

Well I have a need for it again, so today I restored the database and system files from backup and it seems to be running okay.

But before I announce its resurrection to the public, I'd like to have an upgrade specialist upgrade phpBB2 to the latest version that can be supported by PHP Version 5.3.29 and MySQL Version 5.5.58-cll.

Is there anyone interested in doing this work, or anyone you recommend I approach?

Best regards, Lloyd Borrett.

User avatar
GanstaZ
Registered User
Posts: 358
Joined: Wed Oct 11, 2017 10:29 pm
Location: Zverse

Re: Help Needed to Upgrade From phpBB 2.0.21

Post by GanstaZ » Sat Mar 10, 2018 1:53 pm

For the latest version to work: Requirements
Upgrade info: Here
"When answer lies in the question,.. question becomes redundant!"

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49220
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Help Needed to Upgrade From phpBB 2.0.21

Post by stevemaury » Sat Mar 10, 2018 2:22 pm

It's not allowed to hire through this board. However, there are plenty of reputable people around here. We suggest you take a look at the signatures of prominent team or community members who offer their services and send these people a private message. Or we can help you in the support forums, for free!
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

User avatar
lloyd_borrett
Registered User
Posts: 10
Joined: Sun Jun 20, 2004 2:04 am
Location: Rosebud, Victoria, Australia
Name: Lloyd Borrett
Contact:

Re: Help Needed to Upgrade From phpBB 2.0.21

Post by lloyd_borrett » Sat Mar 10, 2018 7:15 pm

GanstaZ wrote:
Sat Mar 10, 2018 1:53 pm
For the latest version to work: Requirements
Upgrade info: Here
Thanks, but I've already read those requirements and they tell me I can't upgrade to the latest version.

Where can I find the requirements for earlier versions of phpBB so that I can work out the latest version I can upgrade to? Right now upgrading PHP and MySQL isn't an option because it would break other sub-systems hosted on the account.

Best regards, Lloyd Borrett.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49220
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Help Needed to Upgrade From phpBB 2.0.21

Post by stevemaury » Sat Mar 10, 2018 7:33 pm

What requirement(s) is it that won't allow you to go to 3.2.2? As support for 2.0.x ended years ago, the only support we can give you is to upgrade. 3.0.x support has also ended, and 3.1.x support will end in June, so that pretty much means upgrading to 3.2.x.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

User avatar
lloyd_borrett
Registered User
Posts: 10
Joined: Sun Jun 20, 2004 2:04 am
Location: Rosebud, Victoria, Australia
Name: Lloyd Borrett
Contact:

Re: Help Needed to Upgrade From phpBB 2.0.21

Post by lloyd_borrett » Sun Mar 11, 2018 2:53 am

stevemaury wrote:
Sat Mar 10, 2018 7:33 pm
What requirement(s) is it that won't allow you to go to 3.2.2? As support for 2.0.x ended years ago, the only support we can give you is to upgrade. 3.0.x support has also ended, and 3.1.x support will end in June, so that pretty much means upgrading to 3.2.x.
phpBB 3.2.2 requires PHP 5.4.0+. I'm on PHP 5.3.29. Right now I can't upgrade PHP because I still have some other old subsystems that would break. Only when/if they are upgraded could I upgrade PHP and then go to phpBB 3.2.2.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 19525
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Help Needed to Upgrade From phpBB 2.0.21

Post by Mick » Sun Mar 11, 2018 9:51 am

It’s actually PHP 5.4.7 now.

Do you know for a fact your other stuff won’t work or are you guessing?
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.

User avatar
warmweer
Registered User
Posts: 974
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Help Needed to Upgrade From phpBB 2.0.21

Post by warmweer » Sun Mar 11, 2018 8:41 pm

lloyd_borrett wrote:
Sat Mar 10, 2018 1:11 pm
...
But before I announce its resurrection to the public, I'd like to have an upgrade specialist upgrade phpBB2 to the latest version that can be supported by PHP Version 5.3.29 and MySQL Version 5.5.58-cll.
The latest version which can run on your current system is phpBB3.0.14. I suggest you upgrade to 3.0.14 asap if only because phpBB2 is really outdated and not secure anymore.
Also It will give you a headstart with the new permission system (and it's at least one big part done in the upgrade procedure.)

Once your system (php, MySql) has been upgraded you can then upgrade phpBB and there are many users here who have experience with upgrading from 3.0 > 3.1 or even 3.2.
A bug is a feature that hasn't made it to the manual (yet)

User avatar
Mick
Support Team Member
Support Team Member
Posts: 19525
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Help Needed to Upgrade From phpBB 2.0.21

Post by Mick » Mon Mar 12, 2018 8:32 am

Be aware there is no support for 3.0 and support for 3.1 finishes on July 1st 2018. We can, of course, help you with upgrading.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.

User avatar
lloyd_borrett
Registered User
Posts: 10
Joined: Sun Jun 20, 2004 2:04 am
Location: Rosebud, Victoria, Australia
Name: Lloyd Borrett
Contact:

Re: Help Needed to Upgrade From phpBB 2.0.21

Post by lloyd_borrett » Tue Mar 13, 2018 9:49 pm

Thanks everyone,

I now have someone who is starting to look at my setup and work out an upgrade path.

I know the proper way forward is to upgrade to the latest version. However, as in this case, for numerous reasons, that isn't always possible. But I'll get there eventually.

Best regards, Lloyd Borrett.

User avatar
3Di
Registered User
Posts: 12685
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Help Needed to Upgrade From phpBB 2.0.21

Post by 3Di » Wed Mar 14, 2018 1:48 am

warmweer wrote:
Sun Mar 11, 2018 8:41 pm
The latest version which can run on your current system is phpBB3.0.14.
Why? Note that PHP 5.3.29 is greater than 5.3.3
Want to compensate me for my interest? Donate
Please PM me only to request paid works. Thx.
Extensions, Scripts, MOD porting, Update/Upgrades
My development's activity º PhpStorm's proud user

User avatar
warmweer
Registered User
Posts: 974
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Help Needed to Upgrade From phpBB 2.0.21

Post by warmweer » Wed Mar 14, 2018 6:59 am

3Di wrote:
Wed Mar 14, 2018 1:48 am
warmweer wrote:
Sun Mar 11, 2018 8:41 pm
The latest version which can run on your current system is phpBB3.0.14.
Why? Note that PHP 5.3.29 is greater than 5.3.3
Ow :oops: , thanks, correction noted.
A bug is a feature that hasn't made it to the manual (yet)

User avatar
lloyd_borrett
Registered User
Posts: 10
Joined: Sun Jun 20, 2004 2:04 am
Location: Rosebud, Victoria, Australia
Name: Lloyd Borrett
Contact:

Re: Help Needed to Upgrade From phpBB 2.0.21

Post by lloyd_borrett » Mon Mar 19, 2018 2:12 am

Job done, thanks to the fantastic work of Marco, 3Di.

See https://www.scubadoctor.com.au/forums/

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: BIABrewer, gsmaclean, KYPREO and 21 guests