Forum Roles Are All Set to "No"

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
H3RRS
Registered User
Posts: 7
Joined: Tue Mar 20, 2018 6:54 pm

Forum Roles Are All Set to "No"

Post by H3RRS » Wed Mar 21, 2018 1:25 am

Hi All,

When I go to set permissions for my added groups to the forum, all my forum roles are set to "No" in the advanced permissions tab. IE, Standard Access, Standard Access + Polls, Bot Access, etc. When I go to see the permissions in the "advanced Permissions" tab, they are all selected as no and it's not saving. Is there anyway, where I can get the forum roles to have their default permissions and for the roles to actually save to the group?

Thank you for all of your support!
-H3RRS

User avatar
Lumpy Burgertushie
Registered User
Posts: 64068
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Forum Roles Are All Set to "No"

Post by Lumpy Burgertushie » Wed Mar 21, 2018 1:31 am

by default, the only roles that have everything set to no under advanced permissions would be the "no access", "guest". "bots" and "newly registered users" roles.

also, once you have chosen a role for the group there is no reason to even click on the advanced permssions.

that is the whole point of the built in roles is so that you don't have to set individual permissions for each group/forum, etc.


the only time you would normally click on the advanced permissions button is if you are not using one of the standard roles.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

H3RRS
Registered User
Posts: 7
Joined: Tue Mar 20, 2018 6:54 pm

Re: Forum Roles Are All Set to "No"

Post by H3RRS » Wed Mar 21, 2018 1:35 am

Hi Robert,

Thank you for your quick response. I was just checking the "advanced permissions" to see if everything was correct in my mind of which I wanted the user to have and not have. Even when I select the forum role to the specified group, it does not save. I'm confused on why it's not saving and all forum role permissions are selected as "No." I'm unsure where to go from here.

Any advice would be truly helpful!

Thank you so much,
-H3RRS

User avatar
Lumpy Burgertushie
Registered User
Posts: 64068
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Forum Roles Are All Set to "No"

Post by Lumpy Burgertushie » Wed Mar 21, 2018 1:53 am

normally there is no need to do any of this.

when you install a phpbb board, it creates a category with a forum with a post.
when you get ready to create more4 forums you just copy permissions from those to your new forum.

if you are seeing all no for roles other than the ones I mentioned then there is something wrong with your install.

is this a new board? do you already have members and posts?


if not, or if you don't care, just wipe it out and start over.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

H3RRS
Registered User
Posts: 7
Joined: Tue Mar 20, 2018 6:54 pm

Re: Forum Roles Are All Set to "No"

Post by H3RRS » Wed Mar 21, 2018 2:14 am

Hi Robert,

It was a fresh install, and I did see "Your First Forum". However, I deleted it, as I am quite familiar with phpBB. However, yes, all forum roles are set to "No.". And it's not saving the forum roles nor groups, when I try to add the group to the forum. I was thinking it may be an install issue. Is that what you think?

Thank you and Kind Regards,
-H3RRS

User avatar
Lumpy Burgertushie
Registered User
Posts: 64068
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Forum Roles Are All Set to "No"

Post by Lumpy Burgertushie » Wed Mar 21, 2018 2:26 am

yes, that is what I think. also, keep in mind that when you choose a role and then change any permissions using the advanced permissions settings the role drop down will say "no role assigned" that does not mean the permissions are not still there. It simply means that the permissions no longer fit the "role" that was assigned before you changed it.


start over, wipe out all the files and empty/truncate the database.
then upload all new files and run the install again.

make sure that you are uploading all of the files. only use a real ftp program for this.
do NOT use your hosting company file manager, do not use anything like dreamweaver or other web site creator software.

once you get a new board installed. test it to make sure it is all working properly.

then, leave the existing category/forum/topic in place.

in the admin panel,
create a new forum
type: category
copy permissions from the existing category
create a new forum
type: forum
parent, your new category
copy permissions from the existing forum

do not make any changes to the permissions at all. just copy from the ones that are already there.
once you see how that works you can create whatever categories/forums you wish.
you can rename the default ones or delete them because now you have others with the proper permissions.



robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

H3RRS
Registered User
Posts: 7
Joined: Tue Mar 20, 2018 6:54 pm

Re: Forum Roles Are All Set to "No"

Post by H3RRS » Wed Mar 21, 2018 2:34 am

Hi Robert,

I will do a fresh install, since I was still getting the forum up. It felt like something was not right, as I have used phpBB before. Thank you for your time and expertise on this situation.

Kind Regards,
-H3RRS

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Lumpy Burgertushie and 17 guests