postimage.org

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
VeganFanatic
Registered User
Posts: 180
Joined: Mon Sep 08, 2008 8:27 pm
Location: Victoria, BC Canada
Contact:

postimage.org

Post by VeganFanatic » Wed Apr 11, 2018 5:53 pm

postimage.org had their domain blocked without notice, this has resulted massive problems with broken links

postimage has had to changed to the .cc to get images back in business

does phpBB have a tool or way to fix this kind of problem? I use wordpress and it alerted me to the problem immediately with a plugin

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49341
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: postimage.org

Post by stevemaury » Thu Apr 12, 2018 12:00 am

Are you asking how to change all the postimage .org links in your database to postimage.cc links?

Magic urls (ones that go hot without [URL] tags) appear in the posts_text like this:

Code: Select all

http://www.old_domain.com
Those in the [URL] tags appear like this:

Code: Select all

http://www.old_domain.com
So, this query will fix both types:

Code: Select all

update phpbb_posts set post_text = replace(post_text, 'postimage.org', 'postimage.cc');
update phpbb_posts set post_text = replace(post_text, 'postimage.org', 'postimage.cc');
It may be necessary to then reparse the BBCode using the CLI. Backup the posts_text table first. If your table prefix is not [phpbb_ replace appropriately.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

User avatar
KYPREO
Registered User
Posts: 68
Joined: Fri Feb 02, 2018 9:56 am
Contact:

Re: postimage.org

Post by KYPREO » Thu Apr 12, 2018 4:53 am

The embedded postimage.org links on my board appear to be working. Perhaps they have since put a redirect in place?
phpBB user since 2002
www.AusRotary.com

User avatar
potku
Registered User
Posts: 799
Joined: Wed Dec 22, 2004 10:26 pm
Location: Tampere, Finland
Contact:

Re: postimage.org

Post by potku » Thu Apr 12, 2018 5:25 am

On our site, old links (from just last week) do not work.

Their support has been lazy, so we are looking for an alternative anyway. Yes, phpBB has a good system for uploading this and that, but we have reserved that for registered members: only they can see uploads via the phpBB system.

Could anyone recommend an alternative? :)
Potku.net

"Before I speak, I have something important to say."

- Groucho Marx

postimage
Registered User
Posts: 29
Joined: Sat Jul 02, 2016 11:32 am

Re: postimage.org

Post by postimage » Thu Apr 12, 2018 5:49 pm

Correct query to fix image URLs

Code: Select all

UPDATE `phpbb_posts` SET `post_text` = replace(post_text, 'postimg.org', 'postimg.cc');
UPDATE `phpbb_posts` SET `post_text` = replace(post_text, 'postimg.org', 'postimg.cc');
Last edited by postimage on Sat Apr 14, 2018 6:54 am, edited 1 time in total.

User avatar
AmigoJack
Registered User
Posts: 5267
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: postimage.org

Post by AmigoJack » Fri Apr 13, 2018 7:30 am

postimage wrote:
Thu Apr 12, 2018 5:49 pm
Correct query to fix image URLs
That was the least helpful post and it's also wrong in the majority of cases.

You'd also have to consider to update user signatures and PM texts. Also said website was accessible thru http://postimage.io/ and http://postimages.org/ long before (even http://postimage.org/ is accessible unlike the topic title indicates, only http://postimg.org/ is denied) - not sure why nobody mentioned that.
The worst thing about censorship is ███████████

kevin08
Registered User
Posts: 1
Joined: Mon May 07, 2018 10:34 am

Re: postimage.org

Post by kevin08 » Mon May 07, 2018 10:42 am

Does anyone have a suggestion on other free/anonymous services for posting board images?

User avatar
AmigoJack
Registered User
Posts: 5267
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: postimage.org

Post by AmigoJack » Mon May 07, 2018 10:53 am

The worst thing about censorship is ███████████

User avatar
</Solidjeuh>
Registered User
Posts: 909
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: postimage.org

Post by </Solidjeuh> » Mon May 07, 2018 8:35 pm

postimage wrote:
Thu Apr 12, 2018 5:49 pm
Correct query to fix image URLs

Code: Select all

UPDATE `phpbb_posts` SET `post_text` = replace(post_text, 'postimg.org', 'postimg.cc');
UPDATE `phpbb_posts` SET `post_text` = replace(post_text, 'postimg&#46;org', 'postimg&#46;cc');

Code: Select all

UPDATE `phpbb_posts` SET `post_text` = replace(post_text, 'postimg&#46;org', 'postimg&#46;cc');
This one is not working.

#1064 - There is something wrong with the used syntax ''postimg&#46)' in line 1
Wij promoten UW muziek in ons forum & delen alles via Sociale media!
Muziek wordt ook toegevoegd in de playlist van
textradio.be!
Mail uw single + hoesje + info naar: info@muziekpromo.net of Solidjeuh@textradio.be
===============
Onze Website: https://www.muziekpromo.net

User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 2741
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: postimage.org

Post by thecoalman » Mon May 07, 2018 11:25 pm

Froddelaar wrote:
Mon May 07, 2018 8:35 pm
This one is not working.

#1064 - There is something wrong with the used syntax ''postimg&#46)' in line 1
On the left hand bottom side of the window for the query is setting for the delimiter, change to something other than a semicolon that is not used in the query. ! should work, at the end of the query change the semicolon to a !

User avatar
</Solidjeuh>
Registered User
Posts: 909
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: postimage.org

Post by </Solidjeuh> » Mon May 07, 2018 11:44 pm

thecoalman wrote:
Mon May 07, 2018 11:25 pm
Froddelaar wrote:
Mon May 07, 2018 8:35 pm
This one is not working.

#1064 - There is something wrong with the used syntax ''postimg&#46)' in line 1
On the left hand bottom side of the window for the query is setting for the delimiter, change to something other than a semicolon that is not used in the query. ! should work, at the end of the query change the semicolon to a !
And that works! Thank you :)
Wij promoten UW muziek in ons forum & delen alles via Sociale media!
Muziek wordt ook toegevoegd in de playlist van
textradio.be!
Mail uw single + hoesje + info naar: info@muziekpromo.net of Solidjeuh@textradio.be
===============
Onze Website: https://www.muziekpromo.net

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: </Solidjeuh>, invenio and 39 guests