Securing forum with https

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
buksida
Registered User
Posts: 301
Joined: Thu Feb 04, 2010 9:11 am

Securing forum with https

Post by buksida » Thu May 24, 2018 8:49 am

I notice this board is https and has a green secure marker in Chrome.

I would like the same for my own forum as even with https it still does not show as 'secure'.

I have installed the SSL certificates on the server for the domain so what are the next steps?

Thanks in advance.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 19368
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff
Contact:

Re: Securing forum with https

Post by Mick » Thu May 24, 2018 8:54 am

Have you updated your cookie settings to accommodate SSL? Please supply a link to your board so we can have a look.

FWIW - you’re NOT securing your board with SSL you are merely encrypting the data that is sent and received.
An SSL certificate is a bit of code on your web server that provides security for online communications. When a web browser contacts your secured website, the SSL certificate enables an encrypted connection.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

buksida
Registered User
Posts: 301
Joined: Thu Feb 04, 2010 9:11 am

Re: Securing forum with https

Post by buksida » Thu May 24, 2018 9:17 am

Thanks for the quick reply - here are screenshots for the settings, so no - nothing setup yet.

I do remember trying this before and it messed everything up and nobody could login so we had to disable it again.
server.jpg
server2.jpg

Can you let us know what to do to fix it. Cheers.

fagbutlil
Registered User
Posts: 12
Joined: Wed Mar 07, 2018 10:56 pm

Re: Securing forum with https

Post by fagbutlil » Thu May 24, 2018 9:28 am

Change http to https under server settings and purge the cache.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 19368
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff
Contact:

Re: Securing forum with https

Post by Mick » Thu May 24, 2018 10:46 am

Cookie secure needs enabling, see Knowledge Base - Fixing incorrect cookie settings

Also you can add something like this to the beginning of your .htaccess file to make sure everyone lands on your board using HTTPS:

Code: Select all

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
fagbutlil wrote:
Thu May 24, 2018 9:28 am
Change http to https under server settings and purge the cache.
That only works if you’ve got force server url settings set to yes.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

buksida
Registered User
Posts: 301
Joined: Thu Feb 04, 2010 9:11 am

Re: Securing forum with https

Post by buksida » Thu May 24, 2018 11:12 am

Trying this on another smaller forum.

Ok - done all that - but as before I cannot login and get a 'site unreachable' error.

Also this still shows in Firefox:


burma.jpg

SSL checker says all is good server side so it must be a phpBB config problem:
https://www.sslshopper.com/ssl-checker. ... aboard.com

User avatar
Mick
Support Team Member
Support Team Member
Posts: 19368
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff
Contact:

Re: Securing forum with https

Post by Mick » Thu May 24, 2018 1:04 pm

Mick wrote:
Thu May 24, 2018 8:54 am
Please supply a link to your board
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

buksida
Registered User
Posts: 301
Joined: Thu Feb 04, 2010 9:11 am

Re: Securing forum with https

Post by buksida » Thu May 24, 2018 1:53 pm

Its written in the attachment ... www.burmaboard.com

But when you try to log in this happens:

secure.png

fagbutlil
Registered User
Posts: 12
Joined: Wed Mar 07, 2018 10:56 pm

Re: Securing forum with https

Post by fagbutlil » Thu May 24, 2018 2:04 pm

Once you have your ssl cert in place and changed acp setting and added the htaccess force code open ftp or cpanel and delete the production folder from the cache folder also clear your browsers cache.

I just added ssl to my site.

buksida
Registered User
Posts: 301
Joined: Thu Feb 04, 2010 9:11 am

Re: Securing forum with https

Post by buksida » Thu May 24, 2018 2:45 pm

Its not as simple as that evidently. Caches cleared and we're still getting errors.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 19368
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff
Contact:

Re: Securing forum with https

Post by Mick » Thu May 24, 2018 3:12 pm

Placing https:// at the beginning of your url (https://www.burmaboard.com) works correctly with the padlock etc.

ADA2BE10-7D6F-4D3F-8303-EEC91F7C2C0A.jpeg

You need to add the .htaccess rewrite, it won’t work properly if you go in using http otherwise.

The Cookie domain burmaboard.com requires a dot in the front, see the cookie KB posted earlier.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

buksida
Registered User
Posts: 301
Joined: Thu Feb 04, 2010 9:11 am

Re: Securing forum with https

Post by buksida » Fri May 25, 2018 1:19 am

If I add the .htaccess rewrite I cant login - I get the "site unreachable" error.

rewrite.jpg
I have done it now - can you please try and register or login?

User avatar
3Di
Registered User
Posts: 12557
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Securing forum with https

Post by 3Di » Fri May 25, 2018 4:26 am

If I go to http://www.burmaboard.com (HTTP) it correctly redirects me to the HTTPS.

Purge the cache of your browser(s) and try again.
Want to compensate me for my interest? Donate
Please PM me only to request paid works. Thx.
Extensions, Scripts, MOD porting, Update/Upgrades
My development's activity º PhpStorm's proud user

buksida
Registered User
Posts: 301
Joined: Thu Feb 04, 2010 9:11 am

Re: Securing forum with https

Post by buksida » Fri May 25, 2018 7:27 am

That isnt the problem - logging in is.

We cant log in to the forum.

It only works without the .htaccess rewrite code.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 19368
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff
Contact:

Re: Securing forum with https

Post by Mick » Fri May 25, 2018 7:35 am

It isn’t redirecting for me, have you got a user test account? Have you spoken to your host about this, there should not be any issues signing in because you’ve gone https if everything is as it should be.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Froddelaar and 21 guests