7 years of data gone after upgrade

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68470
Joined: Mon May 02, 2005 3:11 am
Contact:

7 years of data gone after upgrade

Post by Lumpy Burgertushie »

Ok, guys, this is going to be a long one.

I have a situation where I upgraded a board from 3.0.9 to 3.2.1
In the process I have lost exactly 7 years of data. that includes probably 20k + posts and their forums etc. etc.

here is what I did

1. made a backup of all the files/folders to my computer using ftp.
2. exported the current/only database to my computer.
3. removed all 3.0 files except for the files and images folders and the config.php file from the server.
4. uploaded all 3.1.12 files to the server.
5. ran install/database_update.php with no problems.
6. checked board, it was all there and working except for some modules apparently missing from the admin panel.
I assumed that continuing with the upgrade to 3.2 would probably solve those issues.
7. removed all the 3.1 files except for the files and images folder and the config.php file.
8. uploaded all the 3.2.2 files
9. ran install, chose update, chose update, chose update database only.
10. timed out within about 30 seconds.
11. refreshed page, same result
12.started over: uploaded 3.0.9 files backup and restored the database to the 3.0.9 backup.

here is where the fun starts.
that database backup is missing 7 years of data.

when viewing the board after restoring all the backups, the latest post is from sep of 2011
also, there are changes to the style files that are from 2011 that were not showing on the current board before I started.

I have gone over and over all the steps I took and I can not figure out how the database backup was missing all of the data from the last 7 years.
It is not the normal problem of posts being there but not showing up. they are not there.
I checked the database and the last post showing on the board is the last post in the database backup file and all the copies of it that I made originally.

I can't even figure out anything related to the host that could have caused this.

the biggest problem I have is that the host only keeps a backup for 3 days and wants $75 to restore it.

If it matters, the host is http://lunarpages.com
thanks guys if anyone can help.
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
canonknipser
Registered User
Posts: 2096
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: 7 years of data gone after upgrade

Post by canonknipser »

Lumpy Burgertushie wrote:
Tue May 29, 2018 3:07 pm
exported the current/only database to my computer.
How did you do that? phpBB-builtin? phpMyAdmin? Bigdump? Mysql-Dumper? A tool provided by your host?

One file? Multiple files?
Lumpy Burgertushie wrote:
Tue May 29, 2018 3:07 pm
.started over: uploaded 3.0.9 files backup and restored the database to the 3.0.9 back
And that? Same questions ...


Did you check the database backup files on your PC?

Is the missing data consistent, i.e. are the posts really missing or is "only" the topic missing? Are only posts missing or complete topics? Users missing?
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB
User avatar
david63
Registered User
Posts: 18823
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: 7 years of data gone after upgrade

Post by david63 »

How did you do the backup? ACP or phpMyAdmin?

I know it is "stable doors and horses" but did you verify the integrity of the database backup before you started?

What state was the database in after the upgrade to 3.1.12?

Sorry to have to say this but it looks as if you may have to put your hand [deep] in your pocket :shock:

Edit: Snap Frank!
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
User avatar
Lumpy Burgertushie
Registered User
Posts: 68470
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 7 years of data gone after upgrade

Post by Lumpy Burgertushie »

used phpmyadmin on the server. exported all tables except for the three search tables.
used phpmyadmin to import, tried bigdump, tried mysqldumper. I was thinking maybe the phpmyadmin import function was not finishing somehow.
all methods worked and each left me with the same situation.
as I said, the actual original backup file is still sitting on my computer untouched. it simply does not have that lost data in it but other than that, it is a complete backup.

yes the database backup file was complete as far as all the tables being there.

the database backup file is simply missing those 7 years of data. it is not a case of the topics being there but not the posts or the posts being there but not the topics. the forums created in the last 7 years are not there, none of the posts in those newer forums are there or any of the posts in the original forums that were made in the last 7 years are there.
it is as if a totally fine/complete backup from 2011 is what I got by mistake. the problem is that there is only one phpbb database on the server. it is the one that the config.php file was pointing to, there is only one set of tables so it is not because of the wrong table prefix etc.

thanks,
robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
canonknipser
Registered User
Posts: 2096
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: 7 years of data gone after upgrade

Post by canonknipser »

Do you have a second set of tables (different prefix) in the database? You know the trick of switching to the next page in the tables list in phpMyAdmin?
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB
User avatar
larkyv
Registered User
Posts: 57
Joined: Wed Feb 21, 2018 3:45 pm

Re: 7 years of data gone after upgrade

Post by larkyv »

See if your host provider has a recent backup? Not going to work if you are your own provider of course....
User avatar
canonknipser
Registered User
Posts: 2096
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: 7 years of data gone after upgrade

Post by canonknipser »

larkyv wrote:
Tue May 29, 2018 3:58 pm
See if your host provider has a recent backup? Not going to work if you are your own provider of course....
->
Lumpy Burgertushie wrote:
Tue May 29, 2018 3:07 pm
the biggest problem I have is that the host only keeps a backup for 3 days and wants $75 to restore it.
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB
User avatar
larkyv
Registered User
Posts: 57
Joined: Wed Feb 21, 2018 3:45 pm

Re: 7 years of data gone after upgrade

Post by larkyv »

Ouch. Missed that.... Boy - that's painful.
omeroon
Registered User
Posts: 26
Joined: Thu Apr 26, 2018 1:39 pm

Re: 7 years of data gone after upgrade

Post by omeroon »

If the original backup is missing the data too then you're pretty much screwed. :?

Did it take long to export? Because PHP has a standard execution time of 30 sec. so maybe phpMyAdmin timed out in the process of dumping the tables However, if that is the case you should be able to see it in the dump too as you will miss the last tables.

Also check the way the dump is made. Standard is INSERT INTO tbl_naam (kol_A,kol_B) VALUES (1,2,3), (4,5,6), (7,8,9) but I always select the first option that gives each insert it's own line incl columnnames because I have the feeling that appended way doesn't always work correctly.

For what it's worth: maybe useful for next time: https://www.mysql.com/products/workbench/ (it's free)
User avatar
KaileyT
Community Team Member
Community Team Member
Posts: 2899
Joined: Mon Sep 01, 2014 1:00 am
Location: sudo rm -rf /
Name: Kailey Truscott
Contact:

Re: 7 years of data gone after upgrade

Post by KaileyT »

Slightly out of date, but for the database backup, did you happen to have a read over https://www.phpbb.com/support/docs/en/3 ... or-domain/?
Kailey Truscott - Community Team
Mohus
Registered User
Posts: 21
Joined: Sun May 13, 2018 7:10 pm

Re: 7 years of data gone after upgrade

Post by Mohus »

it is almost super hard to update the database when it is large using the installation program via web, the best that always works 99% of the time (from personal experience) is using CLI in the install/ directory.

if you don't have access to the terminal ask your web hosting provider to do it (the update)

After doing so you should be able to access the database, where it will be fully updated.

Hope this help.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68470
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 7 years of data gone after upgrade

Post by Lumpy Burgertushie »

thanks a lot for all the ideas. however the problem is not with updating the database. the problem is that the database backup is missing 7 years of data for some inexplicable reason.
however, I believe the host is going to restore from one of their backups previous to 5/28 so that we can start over and try again.

thanks again guys,


robert

oh, speaking of using the CLI, I have been doing this stuff for many years. I can not figure out what any of the information about CLI is talking about.
If it is simply a matter of having shell access to the server and using something like putty to do it that is understandable. however, the documentation I have see here seems to be talking about something you do from the command line within windows. that makes no sense to me.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
KaileyT
Community Team Member
Community Team Member
Posts: 2899
Joined: Mon Sep 01, 2014 1:00 am
Location: sudo rm -rf /
Name: Kailey Truscott
Contact:

Re: 7 years of data gone after upgrade

Post by KaileyT »

Lumpy Burgertushie wrote:
Wed May 30, 2018 2:32 am
If it is simply a matter of having shell access to the server and using something like putty to do it
Yes
Kailey Truscott - Community Team
Mohus
Registered User
Posts: 21
Joined: Sun May 13, 2018 7:10 pm

Re: 7 years of data gone after upgrade

Post by Mohus »

You could run it from any OS with web server (I think). I mostly use it on a linux server and it works like a charm in updating the database, no more timeout error messages.

https://area51.phpbb.com/docs/dev/3.2.x ... arted.html
User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 4259
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: 7 years of data gone after upgrade

Post by thecoalman »

Just for clarity the tables after phpbb_posts are included in the backup? You opened the file and looked? phpBB_zebra should be last one.
12.started over: uploaded 3.0.9 files backup and restored the database to the 3.0.9 backup
If the backup was incomplete... If you did not manually drop the tables or the drop table command is not issued from the backup you would be working off the old tables you updated hence the reason you may not get any errors about missing tables and think it was full backup.

-----edit-----
I don't know if that is possible without getting any errors but it's the only scenario I can think of that would cause what you describe.
“Results! Why, man, I have gotten a lot of results! I have found several thousand things that won’t work.”

Attributed - Thomas Edison
Post Reply

Return to “[3.2.x] Support Forum”