Problem with uploading attachment (i see only one attachment)

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
PB190
Registered User
Posts: 134
Joined: Mon Apr 30, 2018 2:50 pm

Problem with uploading attachment (i see only one attachment)

Post by PB190 » Sat Jun 09, 2018 7:06 pm

Hi, if i create new post and add attachments one and more (3 - 5) i see in attachment optinos under posts only one uploaded attachment.

In post is everything ok, all attachmens i see, but i this menu under post i see only one. So if i want any attachment delete, i cant, i must go o ACP.

Thanks for help

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50483
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Problem with uploading attachment (i see only one attachment)

Post by stevemaury » Sat Jun 09, 2018 7:45 pm

You don't see this? What style are you using?
Attachments
Screen Shot 2018-06-09 at 2.44.14 PM.jpg
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

PB190
Registered User
Posts: 134
Joined: Mon Apr 30, 2018 2:50 pm

Re: Problem with uploading attachment (i see only one attachment)

Post by PB190 » Sat Jun 09, 2018 8:21 pm

Hi, i see same like in this picture but i see only 1 file.

If i upload on my post 5 images like attachments i see this, but if i create this posts, and next time i go again in to edit i see only first uploaded attachment in this list.

I just see only first uploaded file in list, but in post i see every attachment when i upload.

I use prosilver, phpbb 3.2.2

(my ext is - topicicononindex, recenttopics, ThanksForPosts) ads, boardannouncements, mediaembed from phpbb,


I test it now, i create 5 images same, i upload all files and i click in to preview ( i see every 5 files in post) but i see only 1 file in this attachment list.

User avatar
canonknipser
Registered User
Posts: 1995
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: Problem with uploading attachment (i see only one attachment)

Post by canonknipser » Sat Jun 09, 2018 8:59 pm

Did you check the well hidden topics in this forum with the secret sign ! for "sticky" - just directly above your topic?
Screenshot_20180609_225848.png
Read: viewtopic.php?f=556&t=2453611 and change accordingly.
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB

PB190
Registered User
Posts: 134
Joined: Mon Apr 30, 2018 2:50 pm

Re: Problem with uploading attachment (i see only one attachment)

Post by PB190 » Sun Jun 10, 2018 6:44 am

Its great, thank you ! I FIX IT

So i ask, WHY YOU NOT FIX IT IN PHPBB, MAKE REPAIR VERSION, this is not normal guys this big bugs really.



Here's how to fix it

Issues involving attachments not showing, or not all showing, when posts with multiple attachments are posted or previewed, as discussed in this topic

Fix: Open phpBB/includes/functions_posting.php & find:

Code: Select all

foreach ($attachment_data as $count => $attach_row)
On a separate line BEFORE, ADD:

Code: Select all

$attachrow_template_vars = [];
Find and DELETE:

Code: Select all

$attachrow_template_vars = array();

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21122
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: Problem with uploading attachment (i see only one attachment)

Post by Mick » Sun Jun 10, 2018 7:00 am

PB190 wrote:
Sun Jun 10, 2018 6:44 am
Here's how to fix it
We know, it’s in the sticky.
"The more connected we get the more alone we become" - Kyle Broflovski

PB190
Registered User
Posts: 134
Joined: Mon Apr 30, 2018 2:50 pm

Re: Problem with uploading attachment (i see only one attachment)

Post by PB190 » Sun Jun 10, 2018 7:32 am

perfect thanks 8-)

TT90
Registered User
Posts: 42
Joined: Tue Jun 12, 2018 12:31 pm

Re: Problem with uploading attachment (i see only one attachment)

Post by TT90 » Sat Jul 07, 2018 11:13 am

Toady i test, fresh install phpBB 3.2.2, i test upload attachments. Problem still not fixed.
The only option is to fix it yourself.
If anyone has contact with the main developers phpBB, please let them know.

And please do not let me know it's fixed because it's not.
I tested it now, I uploaded 5 images and saved the post.
I have returned to my post and see only one attachment in the attachments box. There should be there to be 5.

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 3984
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: Problem with uploading attachment (i see only one attachment)

Post by HiFiKabin » Sat Jul 07, 2018 11:21 am

That is because (as has been pointed out) this is a bug in 3.2.2. It will be fixed in 3.2.3

TT90
Registered User
Posts: 42
Joined: Tue Jun 12, 2018 12:31 pm

Re: Problem with uploading attachment (i see only one attachment)

Post by TT90 » Sat Jul 07, 2018 12:01 pm

Understand, thank you. ;)

User avatar
Exclusive
Registered User
Posts: 383
Joined: Mon Jun 25, 2018 1:33 pm

Re: Problem with uploading attachment (i see only one attachment)

Post by Exclusive » Sat Apr 06, 2019 4:27 pm

Thanks for this. It solved my problem too!
Last edited by Mick on Sun Apr 07, 2019 8:41 am, edited 1 time in total.
Reason: Removed unnecessary full quoting.
Use Search Button to get Instant Results | Follow Forum Rules
Avoid Spams in the forum to prevent banning the offending account. | ⟿ Visit My Forum! ⬳

Subscribe to my YouTube Channel!

Get The Best Web Hosting | ✔ Buy Cheap Domain Names

User avatar
Lumpy Burgertushie
Registered User
Posts: 66320
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Problem with uploading attachment (i see only one attachment)

Post by Lumpy Burgertushie » Sat Apr 06, 2019 6:27 pm

that was a bug in 3.2.2 it was fixed in 3.2.3 we are now at 3.2.5

a simple update would have fixed that and any other things that might have been in the three versions you were behind on.

if you don't keep updated then little things like this add up and you have major problems down the line.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

Post Reply

Return to “[3.2.x] Support Forum”