Issue: Post attachments and edit flow

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
OxCom
Registered User
Posts: 5
Joined: Thu Jun 14, 2018 7:20 pm

Issue: Post attachments and edit flow

Post by OxCom » Mon Jun 18, 2018 6:20 pm

Hello,

Suddenly I found not correct behavior from my point of view when I'm working with attachments. What I have:
1. Create new post with 3 attachments and put one inline.
2. Click to edit this post
3. Remove one attachment
4. Stop edit post - do not save it.
5. Navigate to post and find, that deleted attachment has beed deleted from original post.

I expected that if I deleted attachment and didn't save a post, then all shoulde be fine and post should not be modified.
Is it correct behaviour or there is a bug? If no, then is there bug for that?

Thank You!
Last edited by OxCom on Mon Jun 18, 2018 7:27 pm, edited 1 time in total.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 68249
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Issue: Post preview and attachment

Post by KevC » Mon Jun 18, 2018 6:43 pm

See the fix in the sticky topic just above where you've posted

viewtopic.php?f=556&t=2453611
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
OxCom
Registered User
Posts: 5
Joined: Thu Jun 14, 2018 7:20 pm

Re: Issue: Post preview and attachment

Post by OxCom » Mon Jun 18, 2018 7:26 pm

2 KevC: no, it's different issue. In post that you mentioned issue is that we have not full list of attachments.
But this one shows that you can delete attachment during editing of the post: if you remove attachments during editing process of the post, but without saving one, then attachments will gone.

User avatar
canonknipser
Registered User
Posts: 1600
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: Issue: Post attachments and edit flow

Post by canonknipser » Mon Jun 18, 2018 8:11 pm

That is a behaviour since 3.0.0 - you can even delete attachments without editing the post at all using the attachment control center in your ucp (if not disabled by the board's administrator).
Post text and attachments are (mostly) independent from each other
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB

User avatar
OxCom
Registered User
Posts: 5
Joined: Thu Jun 14, 2018 7:20 pm

Re: Issue: Post attachments and edit flow

Post by OxCom » Mon Jun 18, 2018 8:59 pm

canonknipser wrote:
Mon Jun 18, 2018 8:11 pm
That is a behaviour since 3.0.0 - you can even delete attachments without editing the post at all using the attachment control center in your ucp (if not disabled by the board's administrator).
Post text and attachments are (mostly) independent from each other
Thanks! That exactly what I want to find. So, it's default behavior and there is no any bug for this.

Topic can be closed.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Bing [Bot], janus_zonstraal, meetdilip and 34 guests