database fails to update during re-install

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
async
Registered User
Posts: 1
Joined: Mon Jun 25, 2018 1:32 am

database fails to update during re-install

Post by async » Mon Jun 25, 2018 1:37 am

Hello all,

I have inherited a phpbb3 forum that I did not previously maintain. It was in bad condition and could not be accessed, so I opted to re-install the forum using version 3.2.2 (previous admin believes the site was on 3.2).

I copied over the config.php and the files and images folders, but when I ran the /install/app.php/update script, it failed at 50%, with the following error:

Code: Select all

    General Error:SQL ERROR [ mysql4 ]Table '`suiko_phpbb`.`phpbb3_oauth_states`' already exists [1050]SQLCREATE TABLE phpbb3_oauth_states ( user_id mediumint(8) UNSIGNED DEFAULT '0' NOT NULL, session_id char(32) DEFAULT '' NOT NULL, provider varchar(255) DEFAULT '' NOT NULL, oauth_state varchar(255) DEFAULT '' NOT NULL ) CHARACTER SET `utf8` COLLATE `utf8_bin`; in file /home/www/suikosource.com/new_forum/phpbb/db/driver/driver.php on line 996BACKTRACEFILE: (not given by php)LINE: (not given by php)CALL: installer_msg_handler()FILE: [ROOT]/phpbb/db/driver/driver.phpLINE: 996CALL: trigger_error()FILE: [ROOT]/phpbb/db/driver/mysql.phpLINE: 191CALL: phpbb\db\driver\driver->sql_error()FILE: [ROOT]/phpbb/db/tools/tools.phpLINE: 1064CALL: phpbb\db\driver\mysql->sql_query()FILE: [ROOT]/phpbb/db/tools/tools.phpLINE: 444CALL: phpbb\db\tools\tools->_sql_run_sql()FILE: [ROOT]/phpbb/db/tools/tools.phpLINE: 489CALL: phpbb\db\tools\tools->sql_create_table()FILE: (not given by php)LINE: (not given by php)CALL: phpbb\db\tools\tools->perform_schema_changes()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 714CALL: call_user_func_array()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 661CALL: phpbb\db\migrator->run_step()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 400CALL: phpbb\db\migrator->process_data_step()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 351CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 288CALL: phpbb\db\migrator->try_apply()FILE: [ROOT]/phpbb/db/migrator.phpLINE: 241CALL: phpbb\db\migrator->update_do()FILE: [ROOT]/phpbb/install/module/update_database/task/update.phpLINE: 160CALL: phpbb\db\migrator->update()FILE: [ROOT]/phpbb/install/module_base.phpLINE: 149CALL: phpbb\install\module\update_database\task\update->run()FILE: [ROOT]/phpbb/install/installer.phpLINE: 219CALL: phpbb\install\module_base->run()FILE: [ROOT]/phpbb/install/controller/update.phpLINE: 133CALL: phpbb\install\installer->run()FILE: (not given by php)LINE: (not given by php)CALL: phpbb\install\controller\update->phpbb\install\controller\{closure}()FILE: [ROOT]/vendor/symfony/http-foundation/StreamedResponse.phpLINE: 111CALL: call_user_func()FILE: [ROOT]/vendor/symfony/http-foundation/Response.phpLINE: 377CALL: Symfony\Component\HttpFoundation\StreamedResponse->sendContent()FILE: [ROOT]/install/app.phpLINE: 62CALL: Symfony\Component\HttpFoundation\Response->send()
The failed re-install forum is here: http://suikosource.com/new_forum
The previous forum is here: http://suikosource.com/phpBB3/

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49481
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: database fails to update during re-install

Post by stevemaury » Mon Jun 25, 2018 2:58 pm

Can you run this query of the database you are trying to update?

Code: Select all

SELECT config_value FROM phpbb3_config WHERE config_name = 'version'
Also post the contents of config.php, without the password.

I have a feeling there may be a mismatch between the actual db version and the version the db reports.

Can you access the ACP to see what version it reports?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: abrogard, jack terrier, Mannix_, maxwellqc13, Mick, Tarantino and 37 guests