Page 1 of 3

Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Mon Jul 09, 2018 2:37 am
by njallison
Support Request Template
What version of phpBB are you using? phpBB 3.1.9
What is your board's URL? http://railviewmrc.ca/phpBB3/
Who do you host your board with? Namespro.ca
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What version of phpBB3 did you update from? phpBB 3.1.9
What styles do you currently have installed? all but prosilver disabled
What language(s) is your board currently using? british english
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? attempted update to 3.2.2 following these instructions:

Backup up your board's files and database
2.Deactivate all styles except for prosilver
3.Deactivate any extensions which are not compatible with 3.2. You will need to check with the extension author to find out if an extension is compatible or not.
4.If you are upgrading from version 3.0.x, remove all MOD-related changes from the database. The Support Toolkit's Database Cleaner can be used for this.
5.Ensure that the activated spambot countermeasure is one of the standard phpBB plugins.
6.Set British English as the only language pack
7.Delete all of your phpBB 3.0.x/3.1.x files EXCEPT for the following: ???config.php
???The /ext/ directory
???The /images/ directory
???The /files/ directory
???The /store/ directory

8.Upload the contents of the 3.2.x Full Package (EXCEPT for config.php) into your forum's directory.
9.Browse to /install/, click the Update tab, click the Update button, select "Update database only", and click Submit. Wait for the progress bar to reach 100%.
10.Delete the /install/ directory
Please describe your problem. when I get to step 9 (browse to install and click on the update tab) it takes me to http://railviewmrc.ca/phpBB3/install/app.php/update but that appears to be the main page of my bbs informing me it is disable for up grade and no upgrade occurs.

here is the screen I go to:
bbsnotupdate.jpg
Generated by SRT Generator

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Mon Jul 09, 2018 4:05 am
by Lumpy Burgertushie
dont try to go to that url, click here:
http://railviewmrc.ca/phpBB3/install


robert

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Mon Jul 09, 2018 5:31 am
by njallison
that's where I have been going to (http://railviewmrc.ca/phpBB3/install) and when I click the update tab I end up at http://railviewmrc.ca/phpBB3/install/app.php/update which looks like the start page for the board...no update.

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Mon Jul 09, 2018 5:50 am
by janus_zonstraal
Did you upload the new .htaccess?

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Mon Jul 09, 2018 6:20 am
by njallison
yes

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Mon Jul 09, 2018 6:23 am
by janus_zonstraal
So there isn't a strange redirect left from the old htaccess?

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Mon Jul 09, 2018 2:35 pm
by njallison
no, to be sure I just deleted the .htaccess and copied the one from the download.

to be clear here I followed the instructions as I laid out in the first post...this included deleting the files as listed.

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Mon Jul 09, 2018 4:18 pm
by janus_zonstraal
Do your host use any kind of a cache service like cloudfare?

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Mon Jul 09, 2018 4:30 pm
by njallison
No

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Tue Jul 10, 2018 1:15 pm
by njallison
Any Ideas?

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Tue Jul 10, 2018 1:26 pm
by Ger
It seems to me there are 2 things involved:
1. You are not logged in
2. You have disabled the board through the ACP option

Is this correct?

If so, you should login and then be fine.

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Tue Jul 10, 2018 2:39 pm
by njallison
No, that makes no difference.

I've tried it logged out, logged in, with the board disabled with the board enabled, I've tried it with IE, Edge, Firefox, Chrome.

I logged in, logged in to the ACP, went to http://railviewmrc.ca/phpBB3/install
install.jpg
clicked the "Update" Tab and ended up here http://railviewmrc.ca/phpBB3/install/app.php/update
not so much.jpg
You can see I'm logged in but no install happened.

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Tue Jul 10, 2018 2:45 pm
by Ger
Do you have shell access (Command Line, CLI)?
In that case you can try the CLI updater.

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Tue Jul 10, 2018 2:47 pm
by janus_zonstraal
It must be a redirect on your server, did you ask your host?

Or try it by putting the files in your main directory.

Re: Unable to Upgrade from 3.1.9 to 3.2.2

Posted: Tue Jul 10, 2018 3:01 pm
by njallison
I don't have command line access.

My isp says no redirects.