Smart/Curly/Typographer's Quotes Problems

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
Muattles
Registered User
Posts: 3
Joined: Wed Jun 20, 2018 5:41 pm

Smart/Curly/Typographer's Quotes Problems

Post by Muattles » Mon Jul 09, 2018 8:59 pm

Support Request Template
What version of phpBB are you using? phpBB 3.2.2
What is your board's URL? http://www.thricecursedcity.com/Forums/
Who do you host your board with? FatCow
How did you install your board? Someone else installed my board for me
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What styles do you currently have installed? Lots of styles, ProSilver is the base of them all.
What language(s) is your board currently using? British English / American English
Which database type/version are you using? I Don't Know
What is your level of experience? New to PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? I installed a few mods and styles before the board was launched for general use. Upon others making use of the board the issue was noticed.
Please describe your problem. Smart/Curly/Typographer's Quotes

A few users on my board post from their phones which use 'Smart Quotes' that seem to be causing some issues on my board. I have a screenshot I will attach of the issue, and I have moved the thread the screenshot was from to the "Test Board" created for any guests who wish to see the issue. I can go in and edit the users posts and replace the 'Smart' quotes with regular ones and the problem goes away.

I tried to update to a new language pack to see if the problem would be solved. Since the issue exists in all styles as far as I can tell, I don't think it has anything to do with the styles. I tried putting in censorship to automatically replace the problem characters with correct characters. This unfortunately didn't work since if I didn't include a wildcard * it didn't pick up any characters attached to other words, and if I did include the wildcard *, then it picked up the word as well as the character I wanted replaced.
Generated by SRT Generator


I created a "test board" for which guest users have "standard access" to test the issue.
Characters creating problems: “ ” ’
Screenshot
Screenshot 2018-07-09 at 2.27.24 PM.png
Since in the 'preview' post function I see the characters show up just fine on this forum, I imagine it's a simple fix, but a refreshed bout of searching after noticing got me nothing. Apologies for what I assume is a novice question. Thank you for any help.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 20237
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Smart/Curly/Typographer's Quotes Problems

Post by Mick » Tue Jul 10, 2018 7:10 am

Muattles wrote:
Mon Jul 09, 2018 8:59 pm
How did you install your board? Someone else installed my board for me
Is this a one-click install provided by your host? If not please explain how you installed your board.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.

Muattles
Registered User
Posts: 3
Joined: Wed Jun 20, 2018 5:41 pm

Re: Smart/Curly/Typographer's Quotes Problems

Post by Muattles » Tue Jul 10, 2018 10:33 pm

I originally tried installing the board by using the install package from PHPBB using the instructions it came with. For some reason that didn't work. I found a way through my host, FatCow, that said it would install it in a one-click fashion. That didn't work. I contacted technical support at FatCow and they said that automatically installing a forum through PHPBB was a known issue at that time, and the tech person manually installed it for me. I imagine my issues with installing via the PHPBB install package was something I did wrong, but it might have been tied up in the same issue that prevented me from installing with the one-click install.

User avatar
Lumpy Burgertushie
Registered User
Posts: 65192
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Smart/Curly/Typographer's Quotes Problems

Post by Lumpy Burgertushie » Tue Jul 10, 2018 10:58 pm

those one click installs at the host are not the same files that you get here.

the company that provides the one click install scripts to the hosts have changed the phpbb files to work with their one click install programs.

therefore, the host does not support them nor do they support the standard install that you do using the files from here.

the only way to really get good support is to use the files you get here and follow the exact instructions found in them to install.

I suggest you start over completely and download the full version from here and follow the instructions exactly and in order and you should be fine.


the problem you are seeing is not a normal situation when phpbb is installed properly .

luck,
robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Bing [Bot], kholman, rxu and 17 guests