Fix wrong topic_first_post_id

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
Mick
Support Team Member
Support Team Member
Posts: 21683
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Fix wrong topic_first_post_id

Post by Mick » Wed Jul 18, 2018 8:18 am

Leinad4Mind wrote:
Tue Jul 17, 2018 5:31 pm
the resync should fix this problem I have
You should report it on the bug tracker.
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
Leinad4Mind
Translator
Posts: 852
Joined: Sun Jun 01, 2008 11:08 pm
Contact:

Re: Fix wrong topic_first_post_id

Post by Leinad4Mind » Wed Jul 18, 2018 8:56 am

I wasn't assuming as a bug, per se. But ok, I'll add to the tracker.
Want to access all my portuguese MOD and Extension translations?
Become my Patreon!
phpBB Portugal Translator and Moderator

User avatar
Leinad4Mind
Translator
Posts: 852
Joined: Sun Jun 01, 2008 11:08 pm
Contact:

Re: Fix wrong topic_first_post_id

Post by Leinad4Mind » Wed Aug 15, 2018 10:14 pm

I want to say that after I've fix the problem with the SQL, the problem appeared again with the news mergings. That means that phpbb 3.2.2 have indeed a bug when merging topics/posts.
Want to access all my portuguese MOD and Extension translations?
Become my Patreon!
phpBB Portugal Translator and Moderator

User avatar
eunaumtenhoid
Registered User
Posts: 885
Joined: Wed Jun 03, 2009 12:46 am
Location: ????

Re: Fix wrong topic_first_post_id

Post by eunaumtenhoid » Tue May 07, 2019 2:20 pm

Hi guys, phpBB 3.2.5 here and I'm having the exact same problem with merges. :'(

This seems a phpbb bug, can't any staff look at this? Or atleast make the sync work as Brf and Leinad4Mind said?

Thanks!
My translations of the extensions for Brazilian Portuguese
https://github.com/phpBBTraducoes

User avatar
david63
Registered User
Posts: 16722
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Fix wrong topic_first_post_id

Post by david63 » Tue May 07, 2019 2:36 pm

eunaumtenhoid wrote:
Tue May 07, 2019 2:20 pm
phpBB 3.2.5 here and I'm having the exact same problem with merges. :'(

This seems a phpbb bug, can't any staff look at this?
Nobody is going to look at a problem two versions back. Update to the latest version and see if the problem still exists and if you then believe that you have found a bur you should report it in the Bug Tracker.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Leinad4Mind
Translator
Posts: 852
Joined: Sun Jun 01, 2008 11:08 pm
Contact:

Re: Fix wrong topic_first_post_id

Post by Leinad4Mind » Tue May 07, 2019 4:17 pm

It still happens in 3.2.7. I'll create a bug tracker then, since it seems legit.

EDIT: Ok, Done. I add the issue to bug tracker. You're welcome.

Please note that many admins that report on the forums a problem that was after all a bug, should be added to the bug tracker by the staff/moderator itself. It doesnt make any sense for a regular joe that doesnt understand anything about bug tracker platforms and coding standards and how to fill something in there to add it so the bug can be heard and solved. When a regular joe reports something, you (phpbb) should be thankful. Thats the only way for a software to grow healthy, and not forcing the poor joe that is trying to solve a problem that exist on the software, to give him another problem for him to solve. No hard feelings btw. Just being honest and providing my point of view after many years of reading this same nonsense.
Want to access all my portuguese MOD and Extension translations?
Become my Patreon!
phpBB Portugal Translator and Moderator

User avatar
david63
Registered User
Posts: 16722
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Fix wrong topic_first_post_id

Post by david63 » Tue May 07, 2019 8:45 pm

The point about the person with the problem/bug being the one to report is that if more information is needed whoever is looking at the problem knows where to go. If bugs were only able be reported by Team members then not only is there a risk of them not fully understanding it but everything then becomes second-hand.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
WelshPaul
Registered User
Posts: 353
Joined: Tue Aug 19, 2014 2:09 pm

Re: Fix wrong topic_first_post_id

Post by WelshPaul » Tue May 07, 2019 9:39 pm

Leinad4Mind wrote:
Tue May 07, 2019 4:17 pm
Just being honest and providing my point of view after many years of reading this same nonsense.
Save yourself the wear and tear on your keyboard. :lol:

User avatar
mrgoldy
Jr. Extension Validator
Posts: 1182
Joined: Tue Oct 06, 2009 7:34 pm
Location: The Netherlands
Name: Gijs
Contact:

Re: Fix wrong topic_first_post_id

Post by mrgoldy » Mon Aug 12, 2019 8:55 am

What are the exact steps to reproduce?
As I tried merging a newer topic with an older topic, and the first post id is correct.
And I tried merging an older topic with a newer topic, and the first post id is correct.
What is the exact circumstance when the first post id is not the correct one?
In both cases the topic_first_post_id in my topics table is the correct one.

Post Reply

Return to “[3.2.x] Support Forum”