Locked out of Forum and I'm the Admin!

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
hoarybat
Registered User
Posts: 46
Joined: Tue Jul 22, 2008 11:23 pm

Locked out of Forum and I'm the Admin!

Post by hoarybat » Sun Jul 22, 2018 10:10 pm

A new registrant sent me an email saying they registered and logged in but within a minute or so they were automatically logged out. they then logged back in and the same thing happened logged out within a minute or so again.

I then logged in as the Administrator and the same thing happened to me. I could see my username etc. Top right all looked good but I too was logged out automatically. Did this a few times and then I was locked out of the forum with invalid password. I clicked on forgot my password it sent me a temporary one and I logged back in but was subsequently automatically logged back out. I restored my site files (No mysql) just public_html still but still had issue. Host finally agreed to restore the PHPBB3 database back a couple days and I was able to enter username and password without error but I was not logged in when the page refreshed as No username/login on upper right.

Next Step I ran this query to create a temporary admin login which ran ok in phpmyadmin but could not login with it:

Re: Admin Account Locked Out
Post by stevemaury » Wed Mar 08, 2017 1:15 pm

In phpMyAdmin, run the following, which will create an admin user named Admin1 with a password of admin. From that point you should be able to get into the ACP.
CODE: SELECT ALL

INSERT INTO phpbb_users (user_type, group_id, username, username_clean, user_regdate, user_password, user_email, user_lang, user_style, user_rank, user_colour, user_posts, user_permissions, user_ip, user_birthday, user_lastpage, user_last_confirm_key, user_post_sortby_type, user_post_sortby_dir, user_topic_sortby_type, user_topic_sortby_dir, user_avatar, user_sig, user_sig_bbcode_uid, user_jabber, user_actkey, user_newpasswd) VALUES (3, 5, 'Admin1', 'admin1', 0, '21232f297a57a5a743894a0e4a801fc3', 'admin@example.com', 'en', 1, 1, 'AA0000', 1, '', '', '', '', '', 't', 'a', 't', 'd', '', '', '', '', '', '');
Change your table prefix if it is not phpbb_

I just backed up the database so I don't do anymore damage but we're down and was told it has been this way for a week or more from another forum member Thanks for suggestions: Joe www.bathouseforum.org/forum

User avatar
Lumpy Burgertushie
Registered User
Posts: 65048
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Locked out of Forum and I'm the Admin!

Post by Lumpy Burgertushie » Sun Jul 22, 2018 10:19 pm

looks like something wrong with your host's setup of cloudfare. when I check the url it does not show me any cookie info although your site seems to have the cookies set correctly.

also, check to see if you have cookie secure set to yes. if so, set it to no since you are not running ssl on your site.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

hoarybat
Registered User
Posts: 46
Joined: Tue Jul 22, 2008 11:23 pm

Re: Locked out of Forum and I'm the Admin!

Post by hoarybat » Sun Jul 22, 2018 10:27 pm

Where do I set the cookie secure to NO... Robert. I have no problem with PM ing my CPANEL Login etc to ya Robert as you may have helped in that way in the past. I just tried to register as a regular user and I could not get past the last thing the Image confirmation code is invalid! refreshed it for easier ones tried 10 of them no luck.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49557
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Locked out of Forum and I'm the Admin!

Post by stevemaury » Sun Jul 22, 2018 10:35 pm

I just registered and posted in Bat House Discussion. I will now see if I get logged out.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49557
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Locked out of Forum and I'm the Admin!

Post by stevemaury » Sun Jul 22, 2018 10:37 pm

Run the following SQL:

Code: Select all

UPDATE phpbb_config SET config_value = 0 WHERE config_name = 'cookie_secure'
Then use FTP to delete the /production folder in the /cache folder
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

hoarybat
Registered User
Posts: 46
Joined: Tue Jul 22, 2008 11:23 pm

Re: Locked out of Forum and I'm the Admin!

Post by hoarybat » Sun Jul 22, 2018 11:09 pm

OK I ran Query above and deleted production folder. I deleted all cookies I am able to Log In but I still get booted logged out in 30 seconds even when I hit other topics which refresh the page. Also duplicated this issue in Firefox Browser which behaved the same way. Also when I try to register a new user I can't get by CAPTCHA confirmation now. Have no idea Steve how you could get by the Captcha when we couldn't when attempting to register a new user! Even my daughter with amazing vision can't register with multiple attempts: "The confirmation code you entered was incorrect." Below is what I get shortly after logging in as Admin I'm logged out within 30 seconds or so my host is Hostmonster Steve which is basically like BlueHost. Ok UPDATE: Things are getting whacky and inconsistent: My session finally lasted all the way to 3 minutes one time and 2 minutes for another before I was logged/timed out then reverting back to like 30 seconds. It seems to be varying which makes little sense to me. UH OH update I logged in and when I paused and clicked ACP it said I didn't have admin privileges so session timed out 2 seconds after login logging me out nearly immediately. A NEW RECORD! Time for zzzzzzz thanks again for your help fellas
Attachments
admin-login.PNG

hoarybat
Registered User
Posts: 46
Joined: Tue Jul 22, 2008 11:23 pm

Re: Locked out of Forum and I'm the Admin!

Post by hoarybat » Mon Jul 23, 2018 11:22 am

Update: I entered ".bathouseforum.org" in the ACP cookie domain in cookie settings and also put cookie.php file supplied in the phpBB3 community pages in the forum foldery and now everything is seemingly working fine. Have no idea why because cookie settings in ACP were blank before and I had no problems unless it is the cookie.php script. We'll see how it goes. Thanks Steve, Lumpy and everyone we'll see how it goes :mrgreen:

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: andares, kamaleon, Lumpy Burgertushie, Paul, shortmort37, stevemaury, z.ukosa and 62 guests