3.0 to 3.2

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
brianmjc
Registered User
Posts: 10
Joined: Wed Aug 29, 2012 11:47 pm

3.0 to 3.2

Post by brianmjc » Sun Jul 29, 2018 4:33 pm

Hi,

I'm trying to figure out how to get my old phpBB 2.6 site updated to 3.2. Or to at least get it back to working condition, as I would really like to access the private forum threads once more.

My forum was working fine until recently. In its current state, the index page still comes up, but it doesn't let any users (including me) login anymore: phpBB displays several PHP Warnings on the "successful login" screen, then throws the user back to the forum index without actually being logged in. I surmise it's due to the software's lack of updates in a while, coupled by my web host dropping some legacy PHP support.

What would be the best way to get phpBB 3.2 working with my old database? I obviously cannot login as an admin either, so I cannot upgrade via the admin panel. I've searched around, but can't seem to find anything useful pertaining to my situation.

What I've tried so far: I've downloaded my SQL database to my local computer. Using MAMP (so as not to screw up the original site any further, or the original database), I tried installing phpBB 3.2 on my local computer. I got up to the database configuration part of the installation and entered the old database name and so forth, but it's refusing to use the same table prefix. I guess phpBB won't recognize the old database automatically...?

Thanks,
Brian
Last edited by KevC on Sun Jul 29, 2018 7:06 pm, edited 2 times in total.
Reason: title edited to the correct version

User avatar
Crizzo
Translations & International Support Teams Manager
Translations & International Support Teams Manager
Posts: 761
Joined: Thu Apr 23, 2009 1:20 pm
Location: Germany
Name: Christian
Contact:

Re: 2.6 to 3.2

Post by Crizzo » Sun Jul 29, 2018 4:45 pm

Hi,

Please recheck your phpBB version, because there has never been a version like 2.6.


Regards
My extensions for phpBB: crizzo.de
German phpBB Support at www.phpbb.de

brianmjc
Registered User
Posts: 10
Joined: Wed Aug 29, 2012 11:47 pm

Re: 2.6 to 3.2

Post by brianmjc » Sun Jul 29, 2018 6:09 pm

Hi Crizzo,

2.6 was a guess, actually. It's probably 2.4 or 2.5 then... definitely 2.something. Since I cannot login, I am unable to see the precise version number.

User avatar
Crizzo
Translations & International Support Teams Manager
Translations & International Support Teams Manager
Posts: 761
Joined: Thu Apr 23, 2009 1:20 pm
Location: Germany
Name: Christian
Contact:

Re: 2.6 to 3.2

Post by Crizzo » Sun Jul 29, 2018 6:09 pm

Please link your board.

There is something like 2.0.x, ending with 2.0.23 and then 3.0.x , 3.1.x and 3.2.x

Please check your phpBB_config database table for the version.
My extensions for phpBB: crizzo.de
German phpBB Support at www.phpbb.de

brianmjc
Registered User
Posts: 10
Joined: Wed Aug 29, 2012 11:47 pm

Re: 2.6 to 3.2

Post by brianmjc » Sun Jul 29, 2018 7:05 pm

Sure...

Ok, so the version is actually 3.0.11 according to the database table you mentioned. I was totally off with 2.6.

Link to my board.

Thanks.

User avatar
kinerity
Community Team Member
Community Team Member
Posts: 1829
Joined: Mon Sep 01, 2014 1:00 am
Location: sudo rm -rf /
Name: Kailey Truscott
Contact:

Re: 3.0 to 3.2

Post by kinerity » Sun Jul 29, 2018 7:11 pm

Notes:
  • Your server must be running at least PHP 5.4.7 or higher.
  • phpBB 3.2 is not compatible with 3.0 and most of the previous files will need to be removed prior to upgrading.
  • Styles and MODs from 3.0 cannot be installed on phpBB 3.2. To upgrade, perform the following steps:
  1. Make a back-up of the original files and database
  2. Deactivate all styles except for prosilver
  3. Remove all MOD-related changes from the database. The Support Toolkit's Database Cleaner can be used for this.
  4. Ensure that the activated spambot countermeasure is one of the standard phpBB plugins (Simple image, GD image, GD 3D image, Q&A, reCaptacha).
  5. Set British English as the only language pack and delete all other language pack directories from your server
  6. Delete all of your phpBB 3.0.x files EXCEPT for the following:
    • The config.php file
    • The /images/ directory
    • The /files/ directory
    • The /store/ directory
  7. Upload the contents of the phpBB3 directory from the uncompressed 3.2.x Full Package (EXCEPT for config.php) into your forum's directory (Note: you don't want to overwrite your original config.php file)
  8. Browse to www.example.com/install/
  9. Click the Update tab
  10. Click the Update button
  11. Select "Update database only" and click Submit
  12. Wait for the progress bar to reach 100% and for a message indicating that the update has completed
  13. Delete or rename the /install/ directory
Last edited by kinerity on Sun Jul 29, 2018 7:12 pm, edited 1 time in total.
Reason: Moved to [3.2.x] Support Forum
Kailey Truscott - Community Team

User avatar
Lumpy Burgertushie
Registered User
Posts: 64843
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.0 to 3.2

Post by Lumpy Burgertushie » Sun Jul 29, 2018 7:16 pm

ok, on your MAMP install, you can not use your old phpbb3.0 database for the new 3.2 install.

the first thing you have to do is finish the 3.2 install like normal. using the phpmyadmin in MAMP create a new blank database.
finish the 3.2 install.
then import your old 3.0 database to the new one in phpmyadmin.
then, do NOT try to access the board, it will not work.
just put the phpbb folder named install back and then access yourboard/install

then click the update tab, then click the submit button then on the page that ways update database only, click the button and wait.


that should work, but if it doesn't then you will probably need to upgrade in steps.

3.0.x to 3.1.12 to 3.2.1
I would stop there because the update from 3.2.1 to 3.2.2 has many problems that will hopefully be solved in the 3.2.3 update that is coming soon I think.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

brianmjc
Registered User
Posts: 10
Joined: Wed Aug 29, 2012 11:47 pm

Re: 3.0 to 3.2

Post by brianmjc » Sun Jul 29, 2018 9:41 pm

Hi Lumpy,

Thanks... I've tried three times now to no avail. I get phpBB to install clean each time. The first time, I imported my database, but when I returned to the install folder, I got a blank webpage and no error messages or other indicators of what went wrong. I used a different database prefix that time. Deleting all the fresh tables and renaming the imported tables from the old site caused this blank webpage issue. So I deleted the folder and the tables and started over...

The second time, I got the same issue. This time, I more carefully deleted only those tables in the fresh database that were not duplicated by the imported tables; same problem. Somehow, I managed to use different database prefixes again.

Third time, I finally used the same prefix. But now phpMyAdmin gives me an error that the tables already exist when I import. I'm not seeing an optionto overwrite or append the old tables... am I going to have to sharpen my rusty SQL skills to manually get this to import a certain way or something?

I need to head out soon, but will plug away at this again tomorrow if not later tonight. I appreciate the help, and if you know how to get the database to correctly import, I could certainly use some guidance on that.

Thanks again!

Edit: On the first attempt, I forgot to mention: I got as far as the Update Database part you mentioned before realizing my prefixes were different. The database update was "successful," but when I tried going to the forum it was all blank. I realized it was looking at the fresh install tables with the different prefix instead of the imported ones.

brianmjc
Registered User
Posts: 10
Joined: Wed Aug 29, 2012 11:47 pm

Re: 3.0 to 3.2

Post by brianmjc » Sun Jul 29, 2018 9:46 pm

And thanks, kinerty. I'll try your instructions next if I can't get this import to work with Lumpy.

User avatar
Lumpy Burgertushie
Registered User
Posts: 64843
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.0 to 3.2

Post by Lumpy Burgertushie » Sun Jul 29, 2018 9:49 pm

not sure what you are doing. you should not be making any changes to any database tables.

you simply install a fresh 3.2 board. when the install asks you for the database info you give it the name/username/password that you created when you created the new blank database using phpmyadmin.

once you have a good working new 3.2 board with only the basic welcome to phpbb page, you then go back to phpmyadmin and import your old database to the new one. that will replace the new one with the old one. or , if you have different table prefixes it will simply add the old one to the new one.

if you have different table prefixes then you have to edit you rnew config.php file to point to the old database tables by changing the table prefix.

once all of that is in place, you go to yourboard/install
then you simplyl click the buttons to update the database only.

at no time are you making any changes to any of the database tables etc.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

janus_zonstraal
Registered User
Posts: 2609
Joined: Sat Aug 30, 2014 1:30 pm

Re: 3.0 to 3.2

Post by janus_zonstraal » Mon Jul 30, 2018 4:42 am

And if there is a error somewhere, stop doing things, but go to the error files from your host and post the errors here!
Sorry! My English is bat ;) !!!

brianmjc
Registered User
Posts: 10
Joined: Wed Aug 29, 2012 11:47 pm

Re: 3.0 to 3.2

Post by brianmjc » Wed Aug 01, 2018 2:13 am

Thanks for clarifying, Lumpy.

I found that if I don't change the table prefixes, phpBB ignores my imported data and it remains a fresh, empty board (no users, groups, posts, etc. showed up). And when I kept the table prefixes the same, phpMyAdmin complained on import that the first table already exists and it failed to import anything.

I did spot config.php and tried to edit the table prefixes there. But it broke the forum, meaning nothing came up in my browser except an empty white page. Quite literally empty: viewing the page's source code revealed only the opening and closing html, head, and body HTML tags with absolutely nothing else.

I just tried it a fourth time. Same failure: I get the fresh install to work and get the welcome page, and after importing the database via phpMyAdmin and return to the install folder, I just get a blank page. I kept the table prefixes different this time (phpbb3_ for the old tables, phpbb_ for the new). I modified the config.php file to use the phpbb3_ prefix before going to the install page. When I change it back to phpbb_, the site comes up again, but it's empty of posts, users, and other data. The log tables (phpbb3_log and phpbb_log) show no errors or other information related to this.

And thanks janus, will do. I'm not seeing any errors to report. Just blank pages when it fails.

brianmjc
Registered User
Posts: 10
Joined: Wed Aug 29, 2012 11:47 pm

Re: 3.0 to 3.2

Post by brianmjc » Wed Aug 01, 2018 2:23 am

It just occurred to me... there are some URLs in the database pointing to the live site, and I'm running this on my local MAMP server. Maybe it's lack of permissions to the live site are critically breaking the forum in this way...?

I'm pretty beat atm. But maybe my next step should be to try this on the live server instead. I'll go for it tomorrow night, wish me luck!

Peace,
Brian

janus_zonstraal
Registered User
Posts: 2609
Joined: Sat Aug 30, 2014 1:30 pm

Re: 3.0 to 3.2

Post by janus_zonstraal » Wed Aug 01, 2018 7:02 am

And thanks janus, will do. I'm not seeing any errors to report. Just blank pages when it fails.
A blank page is a (php) error and you can find the error in the error logs from your server.
Sorry! My English is bat ;) !!!

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49442
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: 3.0 to 3.2

Post by stevemaury » Wed Aug 01, 2018 2:50 pm

brianmjc wrote:
Wed Aug 01, 2018 2:13 am

I found that if I don't change the table prefixes, phpBB ignores my imported data and it remains a fresh, empty board (no users, groups, posts, etc. showed up). And when I kept the table prefixes the same, phpMyAdmin complained on import that the first table already exists and it failed to import anything.
This implies that somewhere in the process you did an INSTALLATION which was at no time required or suggested by the instructions.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Harrison76, KevC, lavalamp213, php.exe, sakm, TheButcher2, wads24 and 52 guests