I keep getting delogged. Problem comes and goes.

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
mfunk56
Registered User
Posts: 25
Joined: Mon Jul 30, 2018 3:55 pm

I keep getting delogged. Problem comes and goes.

Post by mfunk56 » Wed Aug 01, 2018 7:45 pm

Support Request Template
What version of phpBB are you using? phpBB 3.2.2
What is your board's URL? http://mnfolkishasatru.com/forum/
Who do you host your board with? GoDaddy
How did you install your board? I used a tool provided by my host
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? No
What styles do you currently have installed? ProSilver
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue? backupadmin
What password can be used to view this issue? [removed admin pw]
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? None
Please describe your problem. Unless I click "Remember Me", I keep getting delogged as a user. I keep getting delogged on the Admin Control Panel regardless. Delogs can be instant or they may be up to a couple minutes in length. In the first month of operation, I did not get delogged at all. It was happening for a couple of days. It corrected last night and sustained for 14 hours prior to reoccurring about a half hour ago. I did not do anything immediately prior to it happening or immediately prior to it correcting. Whatever is going on has nothing to do with my ACP settings. I am just seeking possible explanations regarding the factors at play. I knew nothing about this a month ago and learned a lot in the last 48 hours while trying to correct the issue. A GoDaddy tech surmised that it may be a DHCP issue on the end of my ISP.

The only difference that I noted was that I had a different IP address logged in the moderator logs when the issues stopped happening. Additionally, my wife was not facing these problems while logged in from the gym. Additionally, GoDaddy and Comcast techs were able to maintain a sustained login from their position. I have hit a wall with self research. Any help is greatly appreciated. From the user standpoint, the board is functional as long as the box is clicked. From an ACP standpoint, it is a nightmare.
Generated by SRT Generator

Added in edit: the actual URL is https://mnfolkishasatru.com/forum/ The site actually has an SSL and the http:// should be redirecting to https://
Last edited by Mick on Sat Aug 04, 2018 11:48 am, edited 1 time in total.
Reason: [removed admin pw]

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50495
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: I keep getting delogged. Problem comes and goes.

Post by stevemaury » Wed Aug 01, 2018 8:00 pm

I get Error code: 35(SSL connect error) on the https: url. The Http: url does not seem to be setting cookies. Can you post your cookie settings and your .htaccess file?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
janus_zonstraal
Registered User
Posts: 3262
Joined: Sat Aug 30, 2014 1:30 pm

Re: I keep getting delogged. Problem comes and goes.

Post by janus_zonstraal » Wed Aug 01, 2018 8:09 pm

the http:// should be redirecting to https://
It isn't
http://mnfolkishasatru.com/forum/
Sorry! My English is bat ;) !!!

User avatar
janus_zonstraal
Registered User
Posts: 3262
Joined: Sat Aug 30, 2014 1:30 pm

Re: I keep getting delogged. Problem comes and goes.

Post by janus_zonstraal » Wed Aug 01, 2018 8:11 pm

stevemaury wrote:
Wed Aug 01, 2018 8:00 pm
I get Error code: 35(SSL connect error) on the https: url. The Http: url does not seem to be setting cookies. Can you post your cookie settings and your .htaccess file?
Strange I can see both versions, http and https and the are settings cookies
Sorry! My English is bat ;) !!!

mfunk56
Registered User
Posts: 25
Joined: Mon Jul 30, 2018 3:55 pm

Re: I keep getting delogged. Problem comes and goes.

Post by mfunk56 » Wed Aug 01, 2018 8:33 pm

How do I find the .htaccess file?

Cookie domain: .mnfolkishasatru.com
Cookie name: bb_fasatru4
Cookie path: /
Cookie secure: Enabled
Cookie notice: Disabled

I will find the settings to reroute the http to the https once I get the https operational UNLESS that is a critical component in getting the https operational.

User avatar
janus_zonstraal
Registered User
Posts: 3262
Joined: Sat Aug 30, 2014 1:30 pm

Re: I keep getting delogged. Problem comes and goes.

Post by janus_zonstraal » Wed Aug 01, 2018 8:40 pm

From Spain the https is operational

The .htaccess is in the root from your board files.
But sometimes you can't see it with your ftp program.

See
https://www.lcn.com/support/articles/ho ... les-in-ftp
Sorry! My English is bat ;) !!!

mfunk56
Registered User
Posts: 25
Joined: Mon Jul 30, 2018 3:55 pm

Re: I keep getting delogged. Problem comes and goes.

Post by mfunk56 » Wed Aug 01, 2018 8:48 pm

I am currently utilizing Cpanel File Manager v3. If I search "htaccess" (without the quotes), I find it, but double clicking on it just routes to the folder. When I click "settings" the only option available to me is "Disable Character Encoding Verification Dialogs" In theory, I should have an option to see hidden files, but I can not find it. I have the following available if I run a search in the directory, but I do not know which one you want to see or how to make them display.


/public_html/forum/.htaccess

/public_html/forum/phpbb/db/migration/data/v310/.htaccess

/public_html/forum/phpbb/db/migration/data/v32x/.htaccess

/public_html/forum/phpbb/db/migration/data/v320/.htaccess

/public_html/forum/phpbb/db/migration/data/v31x/.htaccess

/public_html/forum/phpbb/db/migration/data/v30x/.htaccess

/public_html/forum/includes/.htaccess

/public_html/forum/config/.htaccess

/public_html/forum/cache/.htaccess

/public_html/forum/store/.htaccess

/public_html/forum/files/.htaccess

/public_html/forum/images/avatars/upload/.htaccess

User avatar
janus_zonstraal
Registered User
Posts: 3262
Joined: Sat Aug 30, 2014 1:30 pm

Re: I keep getting delogged. Problem comes and goes.

Post by janus_zonstraal » Wed Aug 01, 2018 8:53 pm

It is this one you have to edit /public_html/forum/.htaccess

And use a good ftp program like filezilla not the one from cpanel!!
https://filezilla-project.org/
Sorry! My English is bat ;) !!!

mfunk56
Registered User
Posts: 25
Joined: Mon Jul 30, 2018 3:55 pm

Re: I keep getting delogged. Problem comes and goes.

Post by mfunk56 » Wed Aug 01, 2018 9:00 pm

Okay, I downloaded FileZilla, but that's a new learning curve. This is what seems relevant

"Logged on
You appear to be behind a NAT router. Please configure the passive mode settings and forward a range of ports in your router.
Warning: FTP over TLS is not enabled, users cannot securely log in."

I am connected. Now what do I do? If you guide me through the specific process to get the necessary data displayed, I will display it. I have NO idea what I'm doing here, but 48 hours ago, I had no idea what I was doing on CPanel. I have a gist of how things work, but nowhere near a detailed knowledge.

User avatar
janus_zonstraal
Registered User
Posts: 3262
Joined: Sat Aug 30, 2014 1:30 pm

Re: I keep getting delogged. Problem comes and goes.

Post by janus_zonstraal » Wed Aug 01, 2018 9:21 pm

maybe first look at this movie
https://www.youtube.com/watch?v=adxmlHDim6c

Find on your server the .htaccess file and download it.
Open the file with notepad++
https://notepad-plus-plus.org/download/v7.5.8.html
Sorry! My English is bat ;) !!!

mfunk56
Registered User
Posts: 25
Joined: Mon Jul 30, 2018 3:55 pm

Re: I keep getting delogged. Problem comes and goes.

Post by mfunk56 » Wed Aug 01, 2018 10:01 pm

If I did everything correctly, I believe this is what you want.

If my own understanding is correct, I will have to revise the "#RewriteBase /" to "RewriteBase /forum/phpBB/" or "RewriteBase /forum/"

Am I correct?

Additionally, I installed two other virgin PhPbb on two other subdirectories manually for test purposes and was facing the same issue. If I am correct, installing the boards on a subdirectory, as opposed to the base public_html directory was a big no-no. Could I just move all the files up a level and make the board operational, as if I had initially installed it on the base directory? I am reticent to try this, as I am not 100% certain that I can reverse the results if they are not favorable.

Important: I changed my script path from "/forum/' to "/forum/phpBB3" and I have been steady for 15 minutes. This is especially interesting because there is no phpBB3 folder under forum. I have been steady for 15 minutes after this change. It's certainly a coincidence.

Code is below.

Code: Select all

<IfModule mod_rewrite.c>
RewriteEngine on

#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

#
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#
# If symbolic links are not already being followed,
# uncomment the line below.
# http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
#
#Options +FollowSymLinks
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>

mfunk56
Registered User
Posts: 25
Joined: Mon Jul 30, 2018 3:55 pm

Re: I keep getting delogged. Problem comes and goes.

Post by mfunk56 » Thu Aug 02, 2018 10:19 pm

The last thing I did was change the server settings script path and I have been fully operational for over a day. I believe my error stems from the fact that I installed in a subdirectory. Unless symptoms recur, I think it is solved. The only reason I found out installing in a subdirectory was a no-no was based on the text in the .htaccess file. Thank you gentlemen.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66324
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: I keep getting delogged. Problem comes and goes.

Post by Lumpy Burgertushie » Thu Aug 02, 2018 11:23 pm

just for info purposes, installing in a subdirectory is probably the way most boards are installed.
so, that is not the reason you were having a problem.

glad it got it sorted out anyway.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

mfunk56
Registered User
Posts: 25
Joined: Mon Jul 30, 2018 3:55 pm

Re: I keep getting delogged. Problem comes and goes.

Post by mfunk56 » Fri Aug 03, 2018 10:55 pm

After approximately 48 hours, the problem recurred. I am posting my .htaccess logs below. My current script path is /forum. My cookie settings are as follows. My version is 3.2.2. The files are stored at /public_html/forum . Users have no problem staying logged if they check "remember me" but this also makes using the ACP a nightmare, as no such option exists there.

Cookie domain: .mnfolkishasatru.com
Cookie name: bb_fasatru4
Cookie path: /
Cookie secure: Enabled
Cookie notice: Disabled

Code: Select all

<IfModule mod_rewrite.c>
RewriteEngine on

#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

#
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#
# If symbolic links are not already being followed,
# uncomment the line below.
# http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
#
#Options +FollowSymLinks
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>
Last edited by KevC on Sat Aug 04, 2018 9:30 am, edited 1 time in total.
Reason: code tags added

User avatar
</Solidjeuh>
Registered User
Posts: 1605
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: I keep getting delogged. Problem comes and goes.

Post by </Solidjeuh> » Fri Aug 03, 2018 11:19 pm

You have "cookie secure" enabled, but that's not working on http
Add this code in .htaccess:

Code: Select all

RewriteCond %{HTTPS} !=on
RewriteRule ^.*$ https://%{SERVER_NAME}%{REQUEST_URI} [L,R=301]
So it looks like:

Code: Select all

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTPS} !=on
RewriteRule ^.*$ https://%{SERVER_NAME}%{REQUEST_URI} [L,R=301]

#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /
Register a free account & Play!!
~~~ https://www.solidjeuh.be ~~~
Have a secret? --> https://www.tellyoursecrets.eu

Post Reply

Return to “[3.2.x] Support Forum”