Email error » EMAIL/SMTP (want to use Email delivery service)

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10322
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: Email error » EMAIL/SMTP (want to use Email delivery service)

Post by Noxwizard » Tue Aug 14, 2018 12:11 am

ibnehabib wrote:
Mon Aug 13, 2018 6:12 pm
Thanks,

I changed it to gmail and receiving below error
Email error
» EMAIL/SMTP
/adm/index.php

Could not connect to smtp host : 0 :
Email error
» EMAIL/SMTP
/memberlist.php

Ran into problems sending email at Line 1596. Response: 534 5.7.14 https://support.google.com/mail/answer/78754 t69-v6sm36838374pfj.7 - gsmtp
.
Backtrace
Connecting to smtp.gmail.com:587
LINE: 1139 <- 220 smtp.gmail.com ESMTP t69-v6sm36838374pfj.7 - gsmtp

# EHLO server242.web-hosting.com
LINE: 1486 <- 250-smtp.gmail.com at your service, [199.188.200.55]

LINE: 1486 <- 250-SIZE 35882577

LINE: 1486 <- 250-8BITMIME

LINE: 1486 <- 250-STARTTLS

LINE: 1486 <- 250-ENHANCEDSTATUSCODES

LINE: 1486 <- 250-PIPELINING

LINE: 1486 <- 250-CHUNKING

LINE: 1486 <- 250 SMTPUTF8

# STARTTLS
LINE: 1531 <- 220 2.0.0 Ready to start TLS

# EHLO server242.web-hosting.com
LINE: 1486 <- 250-smtp.gmail.com at your service, [199.188.200.55]

LINE: 1486 <- 250-SIZE 35882577

LINE: 1486 <- 250-8BITMIME

LINE: 1486 <- 250-AUTH LOGIN PLAIN XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER XOAUTH

LINE: 1486 <- 250-ENHANCEDSTATUSCODES

LINE: 1486 <- 250-PIPELINING

LINE: 1486 <- 250-CHUNKING

LINE: 1486 <- 250 SMTPUTF8

# AUTH PLAIN
LINE: 1589 <- 334

# Omitting sensitive information
LINE: 1596 <- 534-5.7.14 <https://accounts.google.com/signin/cont ... t=AKgnsbtU

LINE: 1596 <- 534-5.7.14 F0bHCr7sEN7k1IYD52Ge1k2AZK6tH50ICM3OiXX_64JBsuwAO62M-RKi5H408WhWCm6KV1

LINE: 1596 <- 534-5.7.14 9DopOzX6HWkZLgQGjACQtaWgCaKyUgb-PM9zf8H3EkP3uSB9vZ7Bm-o4pNXJXlZWc1kDtY

LINE: 1596 <- 534-5.7.14 JvENZZqZE2NwA6fAfmh5uPcu_7q-027RN9Q2dBWt9XX18OFfETISEchsUDr37ZIrHxQwQC

LINE: 1596 <- 534-5.7.14 2ne5chjT0Gs9C7R522W2_eiz2EycBdfnsTwe-NWE-wfWCRugCj> Please log in via

LINE: 1596 <- 534-5.7.14 your web browser and then try again.

LINE: 1596 <- 534-5.7.14 Learn more at

LINE: 1596 <- 534 5.7.14 https://support.google.com/mail/answer/78754 t69-v6sm36838374pfj.7 - gsmtp
From Emails address is same as user email
gmail-smtp.JPG
That is normal for first setting up Gmail. Did you follow the links in the error message and do the UnlockCaptcha step?
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

User avatar
John connor
Registered User
Posts: 1836
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Contact:

Re: Email error » EMAIL/SMTP (want to use Email delivery service)

Post by John connor » Tue Aug 14, 2018 11:17 am

I'm setting up a sparkpost account to test this. One of the requirements is to have a domain for email. You do have a domain registered with a domain provider for email?

User avatar
John connor
Registered User
Posts: 1836
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Contact:

Re: Email error » EMAIL/SMTP (want to use Email delivery service)

Post by John connor » Wed Aug 15, 2018 2:06 am

This is all too complicated, to make matters worse Sparkpost only sends email and not receives it without a bunch of configuration crap and I guess you can't use Thunderbird.

You're better off using your host's email or if you want to stay hidden behind CloudFlare use gmail like I do. Namecheap's email service is another solution but I never tried it.

Problem with gmail is that you only get so many emails a month unless you buy an account upgrade.

anglefire
Registered User
Posts: 28
Joined: Sun May 06, 2012 10:38 pm

Re: Email error » EMAIL/SMTP (want to use Email delivery service)

Post by anglefire » Wed Aug 15, 2018 6:53 am

I've had exactly this problem and whilst it isn't a phpBB problem as such and is probably the way your host is set up Sparkpost used to work just fine until very recently.

We have got around to it by installing phpMailer and then configuring ssmtp to use sparkpost. You do end up with a sent on behalf email though.

Sparkpost has depreciated TLSv1 - which is the only thing that is different.

One of these days I might try another service - but frankly it works and it will only be when I have time and inclination.

User avatar
John connor
Registered User
Posts: 1836
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Contact:

Re: Email error » EMAIL/SMTP (want to use Email delivery service)

Post by John connor » Wed Aug 15, 2018 1:40 pm

anglefire wrote:
Wed Aug 15, 2018 6:53 am
I've had exactly this problem and whilst it isn't a phpBB problem as such and is probably the way your host is set up Sparkpost used to work just fine until very recently.
How do you use Sparkpost to receive emails? Can you use Thunderbird? I've asked support about this and I have no idea how all of this is setup. I have my domain and TXT record used, but that's it. If I can't hear from my users, then the service is useless.
Last edited by Mick on Thu Aug 16, 2018 7:25 am, edited 1 time in total.
Reason: Removed unnecessary quoting.

cleverwise
Registered User
Posts: 37
Joined: Fri Feb 28, 2014 10:55 pm
Location: Atlanta, GA
Name: Jeremy

Re: Email error » EMAIL/SMTP (want to use Email delivery service)

Post by cleverwise » Thu Aug 16, 2018 3:27 pm

I fixed a Sparkpost issue on two phpBB forums that were working but stopped after TLSv1 was dropped.

You need to modify the code slightly:

1) Open /includes/functions_messenger.php in your phpBB board

2) Change the following code:

protected $socket_tls = false;

to

protected $socket_tls = true;

3) Save and upload if necessary.

4) Now use the exact Sparkpost settings as before. This fix should force phpBB to enter into a proper tls connection if your hosting provider has setup the proper environment.
Respectfully,
Jeremy

DevOPs - Linux Admin, PHP Developer, Oracle DBA OCP Training
Display phpBB statistics on WordPress (Read more...)

User avatar
raykai
Registered User
Posts: 87
Joined: Tue Apr 09, 2013 5:32 am

Re: Email error » EMAIL/SMTP (want to use Email delivery service)

Post by raykai » Fri Aug 31, 2018 11:04 pm

i can confirm this is working. Now, why was this code set to false setting as default?
Last edited by Mick on Sat Sep 01, 2018 7:46 am, edited 1 time in total.
Reason: Removed unnecessary quoting.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: </Solidjeuh>, janus_zonstraal, Paul, WiGgLr and 21 guests