Updating from 3.2.1 to 3.2.2 "The installer detected a timeout"

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
devnulljp
Registered User
Posts: 43
Joined: Fri Aug 20, 2010 4:07 pm

Updating from 3.2.1 to 3.2.2 "The installer detected a timeout"

Post by devnulljp » Sun Aug 12, 2018 6:03 am

I see a few other posts related to this issue, but haven't found a solution that works for me.
Trying to update from 3.2.1 to 3.2.2

Downloaded the update files, uploaded install and vendor directories, followed the auto update instructions from the ACP.
Get the following error.
The installer detected a timeout
The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI.
Updating files…100%
Installing Data: \phpbb\db\migration\data\v32x\fix_user_styles.
Skip “installer.update_filesystem.download_updated_files” task
Board now says
Your phpBB installation has not been correctly updated. Please read the information below in order to fix this error.
Files Version 3.2.2
Database version 3.2.1
FWIW, I did increase the timeout in php.ini bu it didn't seem to make any difference.
I don't yet have CLI access to the server, so any ideas how to update the database?


Thanks

janus_zonstraal
Registered User
Posts: 2610
Joined: Sat Aug 30, 2014 1:30 pm

Re: Updating from 3.2.1 to 3.2.2 "The installer detected a timeout"

Post by janus_zonstraal » Sun Aug 12, 2018 6:07 am

See viewtopic.php?f=556&t=2453611
For the fix (\fix_user_styles.)
Sorry! My English is bat ;) !!!

User avatar
devnulljp
Registered User
Posts: 43
Joined: Fri Aug 20, 2010 4:07 pm

Re: Updating from 3.2.1 to 3.2.2 "The installer detected a timeout"

Post by devnulljp » Sun Aug 12, 2018 6:10 am

janus_zonstraal wrote:
Sun Aug 12, 2018 6:07 am
See viewtopic.php?f=556&t=2453611
For the fix (\fix_user_styles.)
Thanks. I did all that and same issue. I'm stuck right now with v 3.2.2 files and 3.2.1 database, so things aren't working properly.

janus_zonstraal
Registered User
Posts: 2610
Joined: Sat Aug 30, 2014 1:30 pm

Re: Updating from 3.2.1 to 3.2.2 "The installer detected a timeout"

Post by janus_zonstraal » Sun Aug 12, 2018 6:14 am

Did you delete the installer folder from de cache directory?
Sorry! My English is bat ;) !!!

User avatar
devnulljp
Registered User
Posts: 43
Joined: Fri Aug 20, 2010 4:07 pm

Re: Updating from 3.2.1 to 3.2.2 "The installer detected a timeout"

Post by devnulljp » Sun Aug 12, 2018 6:20 am

janus_zonstraal wrote:
Sun Aug 12, 2018 6:14 am
Did you delete the installer folder from de cache directory?
I hadn't done that. So, I just deleted the installer folder from cache directory and re-ran the update ...
same error, same issue.

I get this at the bottom of the page with the error
Installing Data: \phpbb\db\migration\data\v32x\fix_user_styles.
Skip “installer.update_filesystem.download_updated_files” task

janus_zonstraal
Registered User
Posts: 2610
Joined: Sat Aug 30, 2014 1:30 pm

Re: Updating from 3.2.1 to 3.2.2 "The installer detected a timeout"

Post by janus_zonstraal » Sun Aug 12, 2018 6:24 am

Did you try a other browser?
Try to delete the io.lock (or something like that) from the store directory

Edit: you are using the wrong method, the auto updater isn't working very good.
Try this one https://www.phpbb.com/support/docs/en/3 ... upgrade31/

You will loose your style and edits!!
Sorry! My English is bat ;) !!!

User avatar
devnulljp
Registered User
Posts: 43
Joined: Fri Aug 20, 2010 4:07 pm

Re: Updating from 3.2.1 to 3.2.2 "The installer detected a timeout"

Post by devnulljp » Sun Aug 12, 2018 8:03 am

janus_zonstraal wrote:
Sun Aug 12, 2018 6:24 am
Did you try a other browser?
Try to delete the io.lock (or something like that) from the store directory
Thanks for the info.
I deleted the io.lock.lock file from store
Deleted installer directory from cache
Re-uploaded the install and vendor directories from the updater.

I'm stuck now on one file it says is modified and won't let me proceed

includes/acp/acp_board.php

I replaced the file with the original from 3.2.1 but still get the error
Conflict files
» View/Hide file list
The following files are modified and do not represent the original files from the old version. phpBB determined that these files create conflicts if they are tried to be merged. Please investigate the conflicts and try to manually resolve them or continue the update choosing the preferred merging method. If you resolve the conflicts manually check the files again after you modified them. You are also able to choose between the preferred merge method for every file. The first one will result in a file where the conflicting lines from your old file will be lost, the other one will result in losing the changes from the newer file.
downloaded and looked at the merged diff file and not sure what to do with it now.

EDIT: I'll try the other method

User avatar
devnulljp
Registered User
Posts: 43
Joined: Fri Aug 20, 2010 4:07 pm

Re: Updating from 3.2.1 to 3.2.2 "The installer detected a timeout"

Post by devnulljp » Sun Aug 12, 2018 3:48 pm

So that means starting over again from scratch right?
Damn, this auto update has really screwed my site :(

janus_zonstraal
Registered User
Posts: 2610
Joined: Sat Aug 30, 2014 1:30 pm

Re: Updating from 3.2.1 to 3.2.2 "The installer detected a timeout"

Post by janus_zonstraal » Sun Aug 12, 2018 3:55 pm

So that means starting over again from scratch right?
For the update yes, not for your board.
Damn, this auto update has really screwed my site
Nothing happend, you can place back the files from your backup (Vendor folder) and it will work.

Other option is to wait for phpbb3.2.3
Sorry! My English is bat ;) !!!

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Google [Bot], janus_zonstraal, Mannix_, Paul and 38 guests