SMTP SETTINGS SSL not working

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
wads24
Registered User
Posts: 394
Joined: Fri Jun 10, 2005 4:44 am

SMTP SETTINGS SSL not working

Post by wads24 » Sun Aug 19, 2018 2:29 am

Support Request Template
What version of phpBB are you using? phpBB 3.2.2
What is your board's URL? http://cbradtalk.com
Who do you host your board with? Occhosting
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.2.1
What extensions do you have installed? BOARD RULES
PAGES
CONTACT BOARD ADMINISTRATION
AJAX BASE
STOP FORUM SPAM
APPLICATION FORM
BOARD ANNOUNCEMENTS
GOOGLE SEARCH
YOUTUBE VIDEOGATE GALLERY
SITEMAP
ADSENSE AND ADS FOR PHPBB
REFERRAL EXTENSION
BOARDTALK FIXED MENU
DONATION EXTENSION
HANGMAN MANAGEMENT
IMAGE UPLOAD
ADVANCED LOGIN
TOP STATS
SHARE ON
USER RECENT ACTIVITY
AUTHORIZED FOR URLS
SOCIAL BUTTONS
CUSTOM SITE LOGO
TOPIC PREVIEW
MCHAT
What styles do you currently have installed? Prosilver
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? I never have used SMTP for the board because never worked
Please describe your problem. I contacted my web host to check on the SMTP set up for phpbb but it didn't help it. This was their reply...
select smtp service for email (yes)
smtp service adderss - select mail.floridaserver.com
for smtp service port - 465
authentication method - I doubt is option "not plain"
smtp authentication is required
verify ssl certifcate - try yes, since you will be using our SSL and should work
POP before SMTP - yes

I have tried ssl:// and tls://
Still no go

Error log
TimeAugust 18 2018, 17:25 PM
ActionEmail error
?? EMAIL/SMTP
/adm/index.php

Could not connect to smtp host : 111 : Connection refused

Errno 2: stream_socket_client(): unable to connect to ssl://mail.floridaserver.com:465 (Connection refused) at [ROOT]/includes/functions_messenger.php line 1122

I've tried all the choices for Authentication method for SMTP: also
Generated by SRT Generator
Thanks in advance for a reply.

User avatar
david63
Jr. Extension Validator
Posts: 14651
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: SMTP SETTINGS SSL not working

Post by david63 » Sun Aug 19, 2018 7:14 am

Out of curiosity why do you want to use SMTP?
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Mick
Support Team Member
Support Team Member
Posts: 19986
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: SMTP SETTINGS SSL not working

Post by Mick » Sun Aug 19, 2018 7:25 am

You should search the interweb for “Could not connect to smtp host : 111 : Connection refused“, there are many hits from Drupal to XP.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.

User avatar
wads24
Registered User
Posts: 394
Joined: Fri Jun 10, 2005 4:44 am

Re: SMTP SETTINGS SSL not working

Post by wads24 » Sun Aug 19, 2018 2:23 pm

My host said I should change the port. They are not sure why using 111.

How do I change the port?
Thanks in advance for a reply.

janus_zonstraal
Registered User
Posts: 2610
Joined: Sat Aug 30, 2014 1:30 pm

Re: SMTP SETTINGS SSL not working

Post by janus_zonstraal » Sun Aug 19, 2018 4:28 pm

You can change it in the SMTP setting (SMTP-serverpoort:)
Sorry! My English is bat ;) !!!

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51320
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: SMTP SETTINGS SSL not working

Post by Brf » Sun Aug 19, 2018 7:20 pm

111 is the error, not the port. According to your error message the port is 465.

User avatar
wads24
Registered User
Posts: 394
Joined: Fri Jun 10, 2005 4:44 am

Re: SMTP SETTINGS SSL not working

Post by wads24 » Sun Aug 19, 2018 11:07 pm

Thank you. I will check with the host...

I wanted to use SMTP so that my forum emails are authenticated and not marked as spam
Thanks in advance for a reply.

User avatar
wads24
Registered User
Posts: 394
Joined: Fri Jun 10, 2005 4:44 am

Re: SMTP SETTINGS SSL not working

Post by wads24 » Thu Aug 23, 2018 10:07 pm

My host hasn't a clue why it's not working... I've tried several different ports and several other admin settings they can't seem to get SMTP to work with phpbb
Thanks in advance for a reply.

User avatar
Lumpy Burgertushie
Registered User
Posts: 64876
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: SMTP SETTINGS SSL not working

Post by Lumpy Burgertushie » Fri Aug 24, 2018 12:12 am

using smtp should have no bearing on whether your emails are considered spam or not.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

EA117
Registered User
Posts: 20
Joined: Wed Aug 15, 2018 3:23 am

Re: SMTP SETTINGS SSL not working

Post by EA117 » Fri Aug 24, 2018 4:56 pm

wads24 wrote:
Thu Aug 23, 2018 10:07 pm
My host hasn't a clue why it's not working... I've tried several different ports and several other admin settings they can't seem to get SMTP to work with phpbb
One approach that could be used to try and further isolate the problem would be to use a different email account for which you have SMTP sending access. e.g. An additional gmail.com or some other non-floridaserver.com / non-OCC email account for which you have confirmed the correct and successful SMTP settings are working outside of your phpBB server.

I have no idea how common it is and whether it might also apply to OCC or not, but what we learned about GoDaddy's hosting was that they were intentionally restricting "external mail service connections" from their shared host servers. (Which resulted in the same "connection refused" condition.) You explicitly "had to use" either the PHP mail() function, or set SMTP to use localhost and port 25, in order to send mail. But I would expect OCC to know and tell you that, too, if it was truly the reason in this case.

If temporarily putting in the settings in for this other non-mail.floridaserver.com account also results in "connection refused", I'd say the chances are much higher that the OCC host is just blocking /any/ direct SMTP mail connection off the box.

If the alternate SMTP host actually works from phpBB, then not only do you have a potential interim workaround, but then that's also a new discussion point to have with OCC regarding why it might be specifically their mail server refusing the connection from your hosting account; as opposed to any blocking action that is controlled by the virtual server host itself.

-Trench

User avatar
thunderchero
Registered User
Posts: 129
Joined: Sun Nov 03, 2013 10:16 pm

Re: SMTP SETTINGS SSL not working

Post by thunderchero » Fri Aug 24, 2018 10:23 pm

This might not apply in this case, but some mail providers have started Deprecation of TLSv1.0.

So you might want to ask floridaserver.com if they still support TLSv1.0

If this is the case this fix might help.
viewtopic.php?f=556&t=2481971&p=15070271#p15070271

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: abrogard, janus_zonstraal, Lumpy Burgertushie, Rosain and 47 guests