Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
cridler
Registered User
Posts: 94
Joined: Fri Dec 16, 2011 8:09 pm

Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by cridler » Tue Sep 18, 2018 3:55 pm

Hi,

It has been several years since I have needed PHP help , but first off , thank you for a wonderful product.

I am not too techy and our members have an average age of 60 so do not like change much, hence we didn't upgrade until i bit the bullet last night. I run www.cridler.com/forum or www.wisden.club

We have things working today but I have a few issues re the ACP (sql errors)

In terms of the install, we had a time out error at 42% but looking on here putting SQLl instead of SQL in a script fixed this, but i do mention it as it warned of corruption.

One the forum was updated, I noticed our old skin was not supported and we reverted to the pro silver default, however the header was hyge and a lot of the buttons were in the wrong place and it was very ugly. To fix this i downloaded the latest porsilver skin from here and installed that and apart from an odd /twig/ error which went on its own accord it loaded fine.

So we are working :-) Great, but we have lost our skin and all our modifications which I am looking to add back in (or their more recent equivalent), when I tried this I have 3 issues and a follow up questions regarding corrupted posts.

1) The last 2 tabs on the ACP do not work - the extensions tab gives me this when i click on it.....

General Error
Cannot find module ./../includes/acp/acp_colorized_unread_links.php

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 573
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()

2) The last tab gives me this when I click on it.

General Error
Cannot find module ./../includes/acp/acp_mods.php

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 573
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()

3) When I ftp an unzipped extension into the EXT folder, the ACP will not find it (under customize tab then extension management) , it finds VIGLINK but not the one I have placed next to VIGLINK. Any advice here?

4) Finally , and the only thing causing users pain, is that on our old forum we edited the script to open links in a new window , this suits are site (I can explain more on this if needed) but now we have the code that opens the links in the same window, now when i click on an old link it stalls. Please can you help me set the site so that the links open in a new window? I have seen an extension but the issues above are stopping me trying it out.

Many Thanks for your help on these 4 points,
Cheers
Chris

cridler
Registered User
Posts: 94
Joined: Fri Dec 16, 2011 8:09 pm

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by cridler » Tue Sep 18, 2018 4:09 pm

I have seen this message occasionally too since i re imported the default skin...(at the top of the acp when i click on customize tab)

[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 2674: file(./../styles/prosilver/style.cfg): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 2677: Invalid argument supplied for foreach()

sakm
Registered User
Posts: 511
Joined: Sun Jan 21, 2007 8:14 pm
Location: Hull, uk
Name: Stu
Contact:

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by sakm » Tue Sep 18, 2018 4:11 pm

You are having that due to not uninstalling all mods before upgrading

similar thread here viewtopic.php?p=15085531#p15085531

User avatar
AbaddonOrmuz
Registered User
Posts: 426
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo Ramos
Contact:

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by AbaddonOrmuz » Tue Sep 18, 2018 4:14 pm

The upgrade did not complete, you should try again, recover from a backup and then start over.

Make sure you follow this guide: https://www.phpbb.com/support/docs/en/3 ... /upgrade3/
A proudly user of Arch Linux :: /r/sddm_themes

cridler
Registered User
Posts: 94
Joined: Fri Dec 16, 2011 8:09 pm

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by cridler » Tue Sep 18, 2018 4:18 pm

I had messages saying evertthing was good . I’m not techy so need to follow a step by step guide , the upgrade one was great.

The forum other than link issue is super , it is just the acp that has errors.

Cheers
Chris

cridler
Registered User
Posts: 94
Joined: Fri Dec 16, 2011 8:09 pm

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by cridler » Tue Sep 18, 2018 4:35 pm

PS Not sure how to deactivate Mods now as when i click extensions I get the SQL error.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49729
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by stevemaury » Tue Sep 18, 2018 5:40 pm

Use your backups to revert back and then follow this - https://www.phpbb.com/support/docs/en/3 ... /upgrade3/
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

cridler
Registered User
Posts: 94
Joined: Fri Dec 16, 2011 8:09 pm

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by cridler » Tue Sep 18, 2018 6:55 pm

To me "use your backups" is something difficult,

I took a back up of every file by FTPing them to my PC , so I have all the files, but what do I do now, put them back as the main forum? They are 3.0.9 and have lots of out of date info like skins etc.

This just sounds dangerous, I have a working forum. I just dont have a working ACP and links that go to a new window. I just need to patch it up to make the ACP work.

I followed the link , line by line, I didnt have any errors apart from over flow which i fixed (It doesnt say to edit SQL to SQLl in the note) , so there must be a quicker answer than "start again"?

Thanks for the messages too, ill follow them. If they work ill post on here.

Cheers
Chris

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49729
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by stevemaury » Tue Sep 18, 2018 7:30 pm

I am not saying "start again". I am saying start and do it correctly. There are numerous things apparently done wrong. Not sure how restoring a backup is "dangerous". Do you have a database backup (which is way more important than the files.)?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

cridler
Registered User
Posts: 94
Joined: Fri Dec 16, 2011 8:09 pm

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by cridler » Tue Sep 18, 2018 7:45 pm

Hi,

I am not that technical and followed the instructions - I must not have the ability to do it properly - the back up is with my hosts but I don't think starting again is necessary as the forum is working fine, apart from the link issue.

If I reverted the back up , I can see the forum just failing.

Cheers anyway, was hoping for a simple way forward.
Chris

PS Where do you put an extension to be picked up by the ACP? Root/ext/DOWNLOAD?

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49729
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by stevemaury » Tue Sep 18, 2018 11:29 pm

No one is saying to "start again". It was not done right the first time. Do you, or do you not, have access to the database backup file and when was it made?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

cridler
Registered User
Posts: 94
Joined: Fri Dec 16, 2011 8:09 pm

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by cridler » Wed Sep 19, 2018 9:24 am

Hi,

Alas I am not too technical and reading this post, I may not have a database back up , what I did was I opened Frontpage and logged into the server, I found my config.php file and copied that to my pc a couple of times. I then took my root directory and copied that from the server to my local website file. I was following the 3.0.9 help in the acp and not the one on this forum , that told to do the php copy back but although saying backup database the task I performed seemed to cover this , is this not the case? My hosts must do backups but I think all this is a mute point because the forum is great, all the data is fine, ok we have lost all the nice add ons we did and the skin is very different to before but it works.


It would just be nice to get rid of those errors.

Cheers
Chris

PS the 3.0.9 help was great , it just didnt have the detail but I still got to the end ok (ish)
PPS thanks for all your time on this.

cridler
Registered User
Posts: 94
Joined: Fri Dec 16, 2011 8:09 pm

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by cridler » Wed Sep 19, 2018 9:38 am

I have managed to add an extension it is the phrase ROOT directory that is confusing some what.

I downloaded elonw and this had file structure *elonw*/rmcgirr83/elonw/stuff

I loaded it into phpBB/ext/*elonw*/rmcgirr83/elonw but that didn't work , it did work when I loaded it into phpBB/ext/rmcgirr83/elonw and it did work, thanks to the message that helped me on this.

Why do you remove the *elnow* and is this the same for all extensions, what is the logic I need to follow (other than put it in root/ext , it is not as straightforward as that), also for styles.

I told you I wasn't that technical ,lol.
Cheers
Chris

User avatar
Mick
Support Team Member
Support Team Member
Posts: 20332
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by Mick » Wed Sep 19, 2018 12:33 pm

cridler wrote:
Wed Sep 19, 2018 9:24 am
Frontpage
Dreamweaver and Frontpage are not good choices when it comes to file editors and FTP clients (find out why). See Tools needed to set up and customise phpBB for suggestions.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.

cridler
Registered User
Posts: 94
Joined: Fri Dec 16, 2011 8:09 pm

Re: Upgrade from 3.0.9 to 3.2.3 is 90% OK but need some help as getting error in ACP

Post by cridler » Wed Sep 19, 2018 12:49 pm

Frontpage 2003 , It is a bit old but I can work it :-) , I use my hosts ftp when it is big stuff though.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: AmigoJack, Bermudez, invenio, lopoto, Nick225 and 35 guests