Page 1 of 1

Unable to access board after upgrade.

Posted: Thu Oct 11, 2018 6:02 pm
by Heuerman
Support Request Template
What version of phpBB are you using? phpBB 3.2.3
What is your board's URL? www.myetype.co.uk/forum
Who do you host your board with? one.com
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? Yes
Do you have any extensions installed? No
What version of phpBB3 did you update from? phpBB 3.0-B1
What MODs do you have installed? Can't remember!
What styles do you currently have installed? prosilver
What language(s) is your board currently using? No answer given
Which database type/version are you using? MySQL 3
What is your level of experience? Please select your answer
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Updated the board from 3.1.9 but whilst some areas worked I started getting crashes/error messages. I was able to disable all extensions but the board continued to crash. I decided to load a backup and the board crashed with an error message. Now unable to access the board.
Please describe your problem. Trying to access the board produces this:

Fatal error: Uncaught TypeError: Argument 5 passed to pico\autodbbackup\cron\task\auto_db_backup::__construct() must be an instance of phpbb\db\tools, instance of phpbb\db\tools\tools given, called in /customers/9/8/6/myetype.co.uk/httpd.www/forum/cache/production/container_4335734bbdd20f586549a504dff5f80c.php on line 2937 and defined in /customers/9/8/6/myetype.co.uk/httpd.www/forum/ext/pico/autodbbackup/cron/task/auto_db_backup.php:26 Stack trace: #0 /customers/9/8/6/myetype.co.uk/httpd.www/forum/cache/production/container_4335734bbdd20f586549a504dff5f80c.php(2937): pico\autodbbackup\cron\task\auto_db_backup->__construct('./', 'php', Object(phpbb\config\db), Object(phpbb\db\driver\factory), Object(phpbb\db\tools\tools), Object(phpbb\log\log), Object(phpbb\user)) #1 /customers/9/8/6/myetype.co.uk/httpd.www/forum/vendor/symfony/dependency-injection/Container.php(297): phpbb_cache_container->getPico_Autodbbackup_Cron_Task_Core_AutoDbBackupService() #2 /customers/9/8/6/myetype.co.uk/httpd.www/forum/vendor/symfony/dependency in /customers/9/8/6/myetype.co.uk/httpd.www/forum/ext/pico/autodbbackup/cron/task/auto_db_backup.php on line 26
Generated by SRT Generator

Thanks

Re: Unable to access board after upgrade.

Posted: Thu Oct 11, 2018 6:17 pm
by GanstaZ
Clear cache/production folder and remove that auto backup extension, seems it doesn't work with 3.2.x. Try this one Auto db Backup

Re: Unable to access board after upgrade.

Posted: Thu Oct 11, 2018 7:08 pm
by Heuerman
Just cleared the cache, deleted the pico autobackup from within the php database but the error message is still there on accessing the board.

Re: Unable to access board after upgrade.

Posted: Thu Oct 11, 2018 7:35 pm
by GanstaZ
Did you clear the cache/production folder using ftp?

Re: Unable to access board after upgrade.

Posted: Thu Oct 11, 2018 9:59 pm
by Heuerman
Yes, deleted all the contents of the cache folder.