3.2.0-a2 empty posts

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
e314
Registered User
Posts: 9
Joined: Sat Oct 13, 2012 11:57 am

3.2.0-a2 empty posts

Post by e314 » Mon Oct 15, 2018 5:58 pm

Hi,

after upgrading to 3.2.0-a2 from 3.0.1 (I think, as it happened long time ago), several posts display as blank, although the text is present in the database records.

Being unable to revert to the previous version, I have tried to upgrade to the latest version in hope that the problem would be solved, but it seems all the upgrade paths failed.

Before trying again and gather details on how exactly the upgrade fails, I was wondering if it's possible to make a clean install of the latest version, and somehow just import data from the old database.

IIS10, PHP 7.0.0, MySQL 5.7.20

Thanks,
e

User avatar
EA117
Registered User
Posts: 98
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: 3.2.0-a2 empty posts

Post by EA117 » Mon Oct 15, 2018 6:35 pm

The symptom (some posts don't render) brings to mind behavior seen with specific bbcodes when the messages haven't been reparsed yet post-upgrade. Other posts within the same topic would render fine, but specific posts within the same topic would look "blank". In our case this also happened when the bbcode was actually being referenced in a user's signature, rather than the message itself; and therefore "all posts by user X" would seem affected.

But "upgrade occurred a long time ago" makes it seem like the phpBB cron job that is reparsing the 100 posts at a time maybe should have already gotten though all your messages; depending on how long ago we're really talking about, how busy the board is to have kept the cron active, and how many total posts there are to process.

You can rule out whether reparsing is the root cause of this behavior by manually invoking a full reparse of the board as described in Knowledge Base - phpBB 3.2+ Text Reparser.

e314
Registered User
Posts: 9
Joined: Sat Oct 13, 2012 11:57 am

Re: 3.2.0-a2 empty posts

Post by e314 » Mon Oct 15, 2018 8:28 pm

Thanks, attempted, with this unexpected result:

Code: Select all

[37;41m                                                                  [39;49m
[37;41m  [Symfony\Component\Console\Exception\CommandNotFoundException]  [39;49m
[37;41m  There are no commands defined in the "reparser" namespace.      [39;49m
[37;41m                                                                  [39;49m

User avatar
EA117
Registered User
Posts: 98
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: 3.2.0-a2 empty posts

Post by EA117 » Mon Oct 15, 2018 8:51 pm

Yeah, yikes. On the one hand, if reparsing is even the issue, maybe this failure relates to why the messages haven't already been reparsed successfully before now. But someone other than me who actually knows about the phpBB reparser or namespaces design would have to comment on whether this error message suggests something missing or incomplete from just a database perspective, or from the file system perspective, would possibly be corrected by performing an upgrade to a later version, etc. Or maybe is even some kind of expected condition. I do not know the answer.

From just an end-user's perspective, seeing that message would make me think something was incomplete or damaged about my current 3.2.0 installation, and I would make copious file system and database backups before trying to then upgrade to a current phpBB release. Not because there is an expectation "that is probably a known issue and has been fixed", but more to the point of just attempting to impose correct database and file system changes again on the board in hopes of instantiating what's currently missing.

Waiting for additional input first would probably be the smartest move, in case the "missing reparser commands" brings something specific to mind for someone else. If and when you pursue performing an upgrade, do choose to take the "full package" route, since automatic update seems to have been raising more than it's expected share of issues recently.

User avatar
3Di
Registered User
Posts: 12998
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: 3.2.0-a2 empty posts

Post by 3Di » Mon Oct 15, 2018 9:17 pm

You can try this but do a full DB & Files backup before to go ahead.

https://download.phpbb.com/pub/release/3.2/3.2.3/phpBB-3.2.0-a2_to_3.2.3.zip
https://download.phpbb.com/pub/release/ ... _3.2.3.zip

If not already tried.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate

:game_die: The new Dice Roller extension for phpBB 3.2 is out! :game_die:

Extensions, Scripts, MOD porting, Update/Upgrades
My development's activity º PhpStorm's proud user

e314
Registered User
Posts: 9
Joined: Sat Oct 13, 2012 11:57 am

Re: 3.2.0-a2 empty posts

Post by e314 » Tue Oct 16, 2018 7:09 am

3Di wrote:
Mon Oct 15, 2018 9:17 pm
You can try this but do a full DB & Files backup before to go ahead.

https://download.phpbb.com/pub/release/3.2/3.2.3/phpBB-3.2.0-a2_to_3.2.3.zip
https://download.phpbb.com/pub/release/ ... _3.2.3.zip

If not already tried.
So, I tried this, and the update process went through. However I end up with this

Code: Select all

Fatal error: Uncaught Error: Class 'Patchwork\Utf8\Bootup' not found in D:\Web\LALISTA\forum\includes\utf\utf_tools.php:27 Stack trace: #0 D:\Web\LALISTA\forum\common.php(97): require() #1 D:\Web\LALISTA\forum\index.php(23): include('D:\\Web\\LALISTA\\...') #2 {main} thrown in D:\Web\LALISTA\forum\includes\utf\utf_tools.php on line 27
So I thought... "ok, the DB has been converted to 3.2.3. What I can do now is just make a 3.2.3 fresh install, and point it to my old DB". However that doesn't seem to work too, with the board working but simply saying "Sorry, this forum is currently unavailable".

User avatar
david63
Jr. Extension Validator
Posts: 14941
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: 3.2.0-a2 empty posts

Post by david63 » Tue Oct 16, 2018 7:24 am

e314 wrote:
Tue Oct 16, 2018 7:09 am
with the board working but simply saying "Sorry, this forum is currently unavailable".
Have you deleted/renamed the install folder?
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

e314
Registered User
Posts: 9
Joined: Sat Oct 13, 2012 11:57 am

Re: 3.2.0-a2 empty posts

Post by e314 » Tue Oct 16, 2018 7:45 am

david63 wrote:
Tue Oct 16, 2018 7:24 am
e314 wrote:
Tue Oct 16, 2018 7:09 am
with the board working but simply saying "Sorry, this forum is currently unavailable".
Have you deleted/renamed the install folder?
Ugh, yes I totally forgot to do that.
However after doing so:
This board has no forums.

e314
Registered User
Posts: 9
Joined: Sat Oct 13, 2012 11:57 am

Re: 3.2.0-a2 empty posts

Post by e314 » Tue Oct 16, 2018 7:46 am

Fixed, after restarting IIS.

User avatar
3Di
Registered User
Posts: 12998
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: 3.2.0-a2 empty posts

Post by 3Di » Tue Oct 16, 2018 11:31 am

e314 wrote:
Tue Oct 16, 2018 7:46 am
Fixed, after restarting IIS.
Good, now you should be able to run the CLI reparser - do you confirm?
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate

:game_die: The new Dice Roller extension for phpBB 3.2 is out! :game_die:

Extensions, Scripts, MOD porting, Update/Upgrades
My development's activity º PhpStorm's proud user

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: AetherBytes, Hayley455, J-W43, kelderkold, KYPREO, Mannix_, Michael235 and 196 guests