Incomplete Update to 3.2.3

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Heuerman
Registered User
Posts: 26
Joined: Wed Jun 15, 2016 3:41 pm

Incomplete Update to 3.2.3

Post by Heuerman » Mon Oct 15, 2018 6:12 pm

I tried updating my Forum from 3.1.9 to 3.2.3 but I am getting a message saying : "Your phpBB installation has not been correctly updated. Please read the information below in order to fix this error."

Files version: 3.2.3
Database version: 3.1.9

As instructed I went to the linked 'Database Updater' but I am getting "The requested page could not be found."

I am now unsure as to how I should proceed? Any help most appreciated.

Thanks

David

User avatar
warmweer
Registered User
Posts: 1249
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Incomplete Update to 3.2.3

Post by warmweer » Mon Oct 15, 2018 8:30 pm

How exactly did you try to update?
Use the Support Request Template (https://www.phpbb.com/support/srt/) so that basic info is available to the Support Team.
A bug is a feature that hasn't made it to the manual (yet)

Heuerman
Registered User
Posts: 26
Joined: Wed Jun 15, 2016 3:41 pm

Re: Incomplete Update to 3.2.3

Post by Heuerman » Tue Oct 16, 2018 3:37 pm

Support Request Template
What version of phpBB are you using? phpBB 3.2.3
What is your board's URL? www.myetype.co.uk/forum
Who do you host your board with? one.com
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? Yes
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.1.9
What extensions do you have installed? No answer given
What styles do you currently have installed? prosilver
What language(s) is your board currently using? english
Which database type/version are you using? I Don't Know
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Upgraded to 3.2.3 from 3.1.9 but database remains at 3.1.9. Trying to update database produces a time out after 35%. Tried upgrading database using CLI but get a parse error.
Please describe your problem. Parse error: syntax error, unexpected end of file in /customers/9/8/6/myetype.co.uk/httpd.www/forum/includes/message_parser.php on line 1662
Generated by SRT Generator

I tried to update by copying all the 3.2.3 files across by FTP and then browsing to /install. The conversion got to 35% and stopped.

I have now tried using the CLI and I get this error message:
Parse error: syntax error, unexpected end of file in /customers/9/8/6/myetype.co.uk/httpd.www/forum/includes/message_parser.php on line 1662
Last edited by Heuerman on Tue Oct 16, 2018 5:04 pm, edited 1 time in total.

Heuerman
Registered User
Posts: 26
Joined: Wed Jun 15, 2016 3:41 pm

Re: Incomplete Update to 3.2.3

Post by Heuerman » Tue Oct 16, 2018 4:21 pm

Edit: Somehow I see in the ACP that the database has gone from 3.1.9 to 3.2.0-dev

User avatar
Lumpy Burgertushie
Registered User
Posts: 65192
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Incomplete Update to 3.2.3

Post by Lumpy Burgertushie » Tue Oct 16, 2018 4:35 pm

that is what it means by incomplete.

make sure your config.php file has mysqli instead of mysql

follow these instructions exactly and in order and it should complete properly:
https://www.phpbb.com/support/docs/en/3 ... ating-32x/

in the future, those are the proper instructions for updating.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

Heuerman
Registered User
Posts: 26
Joined: Wed Jun 15, 2016 3:41 pm

Re: Incomplete Update to 3.2.3

Post by Heuerman » Tue Oct 16, 2018 6:27 pm

Thanks! Followed the instructions and the database conversion went through perfectly.

I now have another problem as it seems an extension is causing the board to crash with:
Fatal error: Call to undefined method s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\CachedDefinitionCollection::getIds() in /customers/9/8/6/myetype.co.uk/httpd.www/forum/ext/s9e/mediaembed/listener.php on line 31

I can't get into the ACP to disable the rogue extension. Any thoughts?

User avatar
warmweer
Registered User
Posts: 1249
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Incomplete Update to 3.2.3

Post by warmweer » Tue Oct 16, 2018 7:24 pm

try this
https://www.phpbb.com/support/docs/en/3 ... s-at-once/

BTW when updating (certainly upgrading): in future disable all extensions just in case.
A bug is a feature that hasn't made it to the manual (yet)

Heuerman
Registered User
Posts: 26
Joined: Wed Jun 15, 2016 3:41 pm

Re: Incomplete Update to 3.2.3

Post by Heuerman » Tue Oct 16, 2018 8:32 pm

That was the first thing I did. Used CLI with the associated script but it still crashed. I do have disable extension but I did not upload it for fear of causing other problems during the update.

Can I delete the s9 extension folder via FTP and hope that allows the ACP to get back on action?

Thanks for your input.

David

User avatar
warmweer
Registered User
Posts: 1249
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Incomplete Update to 3.2.3

Post by warmweer » Tue Oct 16, 2018 8:42 pm

Heuerman wrote:
Tue Oct 16, 2018 8:32 pm
That was the first thing I did. Used CLI with the associated script but it still crashed. I do have disable extension but I did not upload it for fear of causing other problems during the update.
Why mess around withCLI when it's so much easier uploading and running the file?
Heuerman wrote:
Tue Oct 16, 2018 8:32 pm
Can I delete the s9 extension folder via FTP and hope that allows the ACP to get back on action?
no - because it should be disabled first.
Run the disable -all file , log in and then delete the extension through the ACP.
A bug is a feature that hasn't made it to the manual (yet)

User avatar
Lumpy Burgertushie
Registered User
Posts: 65192
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Incomplete Update to 3.2.3

Post by Lumpy Burgertushie » Tue Oct 16, 2018 8:43 pm

no. you need to disable that extension. deleting the folder will cause more problems.

either disable them all with the php file or go to the database using phpmyadmin and find the ext table and find that extension and set it to 0 instead of 1


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

Heuerman
Registered User
Posts: 26
Joined: Wed Jun 15, 2016 3:41 pm

Re: Incomplete Update to 3.2.3

Post by Heuerman » Wed Oct 17, 2018 9:39 am

Ran the php disable file but now getting a different error message:

Parse error: syntax error, unexpected end of file in /customers/9/8/6/myetype.co.uk/httpd.www/forum/includes/functions_admin.php on line 2209

Thanks for any advice

David

User avatar
GanstaZ
Registered User
Posts: 566
Joined: Wed Oct 11, 2017 10:29 pm
Location: Zverse

Re: Incomplete Update to 3.2.3

Post by GanstaZ » Wed Oct 17, 2018 9:51 am

Extension or extensions are not disabled. Use phpmyadmin and do what Robert mentioned above. After clear cache/production folder. You may have older versions of extensions that conflict with 3.2.x branch.
"When answer lies in the question,.. question becomes redundant!"

Heuerman
Registered User
Posts: 26
Joined: Wed Jun 15, 2016 3:41 pm

Re: Incomplete Update to 3.2.3

Post by Heuerman » Wed Oct 17, 2018 10:45 am

OK I have set every extension to 0 using phpmyadmin and still getting this message:

Fatal error: Call to undefined method s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\CachedDefinitionCollection::getIds() in /customers/9/8/6/myetype.co.uk/httpd.www/forum/ext/s9e/mediaembed/listener.php on line 31

Where do I go next?

User avatar
GanstaZ
Registered User
Posts: 566
Joined: Wed Oct 11, 2017 10:29 pm
Location: Zverse

Re: Incomplete Update to 3.2.3

Post by GanstaZ » Wed Oct 17, 2018 2:19 pm

Clear cache production folder. If you have a second layer of cache turn that off.
"When answer lies in the question,.. question becomes redundant!"

Heuerman
Registered User
Posts: 26
Joined: Wed Jun 15, 2016 3:41 pm

Re: Incomplete Update to 3.2.3

Post by Heuerman » Wed Oct 17, 2018 5:27 pm

Did that, same result. I am going to restore from a full backup and try the update again. This time I will be sure to disable all mods/extensions first!

Thanks for your help.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: bsa_m21, Chico Gois, EA117, Paul, rxu and 27 guests