3.0.12 to 3.2.3 - install routine not engaging

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
timcumine
Registered User
Posts: 16
Joined: Tue Jul 20, 2010 8:20 pm

3.0.12 to 3.2.3 - install routine not engaging

Post by timcumine » Fri Oct 19, 2018 8:40 pm

I need to upgrade to 3.2.3 and only have a backup of a board constructed in 3.0.12, so I think I need to:
1. re-install 3.0.12; and
2. restore the backup there; before
3. following the routine for upgrading to 3.2.3

I have Filezilla-ed 3.0.12 into place, yet when I follow the instructions to point the browser at the install folder, I am prompted to enter my ftp credentials and all that happens is that I am shown the contents of the install folder, no installation routine.

What am I doing wrong?
Last edited by timcumine on Fri Oct 19, 2018 9:51 pm, edited 1 time in total.

User avatar
Crizzo
Translations & International Support Teams Manager
Translations & International Support Teams Manager
Posts: 785
Joined: Thu Apr 23, 2009 1:20 pm
Location: Germany
Name: Christian
Contact:

Re: 3.0.12 to 3.2.3

Post by Crizzo » Fri Oct 19, 2018 9:40 pm

Hi,

no need to install 3.0.12.

Just upload 3.2.3, restore the 3.0.12 database via phpmyadmin or similar, create a new config.php by yourself and go to /install/

Regards
My extensions for phpBB: crizzo.de
German phpBB Support at www.phpbb.de

timcumine
Registered User
Posts: 16
Joined: Tue Jul 20, 2010 8:20 pm

Re: 3.0.12 to 3.2.3 - install routine not engaging

Post by timcumine » Fri Oct 19, 2018 9:55 pm

Woah! That sounds super straight forward. I am due to sleep soon. It shall be all the sweeter knowing those straits have been fathomed. It'll be a day or two before I can head off down them. Many thanks tho. I'll report back.

User avatar
EA117
Registered User
Posts: 87
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: 3.0.12 to 3.2.3 - install routine not engaging

Post by EA117 » Fri Oct 19, 2018 10:32 pm

Note your "old board" is more than just the database. The database contains all the messages, posts and configuration options. Any files/attachments that had been uploaded, and any avatars or other forum images that were in use, are part of the file system and not the database.

So if you're truly intending to "upgrade the 3.0.12 board we had running before", you likely need to be doing FTP uploads of the /images and /files directories from the 3.0.12 board, in addition to restoring the 3.0.12 database. So that the 3.2.3 upgrade process has access to all the files being referenced by the database. Unless you just happened to be in a case of "the old board had zero attachments, zero avatars, etc."

As to your original issue of "entering the /install URL just displays the folder contents", that sounds like a case of entering "ftp://mydomain.com/install" instead of "http://mydomain.com/install". The "ftp://" prefix is asking for an FTP connection instead of the web server, even though the paths are otherwise identical. To start the phpBB install/upgrade process, you need to use "http://mydomain.com/install".

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49640
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: 3.0.12 to 3.2.3 - install routine not engaging

Post by stevemaury » Sat Oct 20, 2018 3:36 am

If the op does what crizzo says, his files and images will remain intact
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

User avatar
EA117
Registered User
Posts: 87
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: 3.0.12 to 3.2.3 - install routine not engaging

Post by EA117 » Sat Oct 20, 2018 3:59 am

stevemaury wrote:
Sat Oct 20, 2018 3:36 am
If the op does what crizzo says, his files and images will remain intact
Agreed, if we were talking about a running board that exists. OP's premise is "they have a backup of a board", and the only confirmed upload thus far was the 3.0.12 installation files.

Just wanted to interject and confirm that the restoration of files from their backup is also needed, since only restoration of the database from their backup had been cited thus far.

timcumine
Registered User
Posts: 16
Joined: Tue Jul 20, 2010 8:20 pm

Re: 3.0.12 to 3.2.3 - install routine not engaging

Post by timcumine » Sat Oct 20, 2018 4:30 am

No time to respond to ALL the details above, but I can confirm that I had copied the URL from Filezilla, so I was indeed pointing my browser to ftp... not http... Can't wait to make THAT thing work!

And briefly, the 'old board' is a slow work in progress and the backup is of lots of work on a precious structure, without many significant posts / avatars / traffic of any welcome kind - mostly unexpected sign-ups form Mars during periods of inattention.

Thanks All!

timcumine
Registered User
Posts: 16
Joined: Tue Jul 20, 2010 8:20 pm

Re: 3.0.12 to 3.2.3 - install routine not engaging

Post by timcumine » Mon Oct 22, 2018 7:30 pm

I'm back in the saddle and there are some actions in Crizzo's reply that I need to learn...
no need to install 3.0.12.

Just upload 3.2.3, restore the 3.0.12 database via phpmyadmin or similar, create a new config.php by yourself and go to /install/
  • Upload 3.2.3 - I did this with Filezilla
  • restore db via phpmyadmin - I headed off looking at BigDump and installed notepad ++ - Is this really necessary? Is there an easier way?
  • create new config.php by myself - Is there a step by step guide somewhere?
Last edited by timcumine on Mon Oct 22, 2018 7:53 pm, edited 1 time in total.

User avatar
GanstaZ
Registered User
Posts: 566
Joined: Wed Oct 11, 2017 10:29 pm
Location: Zverse

Re: 3.0.12 to 3.2.3 - install routine not engaging

Post by GanstaZ » Mon Oct 22, 2018 7:49 pm

Info about bigdump and info about config.
"When answer lies in the question,.. question becomes redundant!"

timcumine
Registered User
Posts: 16
Joined: Tue Jul 20, 2010 8:20 pm

Re: 3.0.12 to 3.2.3 - install routine not engaging

Post by timcumine » Mon Oct 22, 2018 8:06 pm

Many thanks.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: bsa_m21, Chico Gois, EA117, Paul, rxu, Yandex [Bot] and 27 guests