Search index fails, ACP red notice, "Module not accessible", new installation

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
ngovolunteer
Registered User
Posts: 2
Joined: Sun Oct 21, 2018 12:16 pm

Search index fails, ACP red notice, "Module not accessible", new installation

Post by ngovolunteer » Sun Oct 21, 2018 1:21 pm

When I log into the Admin Control Panel, a red notice turns up at the top of the screen (above the normal control panel stuff):

Warning

The selected search backend does not have a search index.
Please create the index for “phpBB Native Fulltext” in the search index section.


When I click on the link for "search index" section, I get this:

General Error
Module not accessible

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 565
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()


I am running version 3.2.3
I just upgraded from version 3.1.6 where I got the same red notice and experience (which is why I tried upgrading to the latest version).
I had just migrated from a very old vBulletin 3.8 to phpBB 3.1.6 and am trying to use phpBB instead for the first time.

All 3 of the above steps today.

Thus far, everything else seems to be working well, it's just this one search index thing which is a problem, as far as I have seen thus far.

Actually, I had an old copy of 3.1.6 which I had not used before. I first migrated a small vBulletin forum into it, which went smoothly, by using an old "convertor" add-on ( vb3-to-phpBB3.1-master.zip as recommended on this forum, taken from GitHub, fairly old). Since the script said version 3.1 that's what I ported to. That went smoothly and all looked good except just one thing -- the above search index problem. Hoping to fix it by an upgrade, I upgraded phpBB 3.1.6 to the latest 3.2.3 to see whether or not that would fix it, following the instructions carefully (pretty simple). The new version has the same problem. (I carefully went back to look for the convertor scripts to see whether or not any might be interfering, but it's all gone, so that can be ruled out.)

I have not tinkered with phpBB much at all. Just started trying it today, hoping to move to free open source software. This is a plain installation without any extensions nor anything fancy to potentially interfere, except that I imported data from a very old vBulletin 3.8 forum which I apparently need to index for searching.

I don't think it's a problem with my version of CentOS, Apache, PHP, or MySQL/Maria. I also copied everything to a new server. I have the exact same problem on:
phpBB 3.1.6 on CentOS 6 with Apache/2.2.15, PHP 5.3.3, MySQL 5.1.17
phpBB 3.2.3 on CentOS 7 with Apache/2.4.6, PHP 5.4.16, 5.5.56-MariaDB

Does anybody know any fix to this?
If not, is there any other way to "create the index for 'phpBB Native Fulltext' "?
(I run my own servers and am fine to do things like SSH in and running commands, dealing with Maria / MySQL databases, etc.)

ngovolunteer
Registered User
Posts: 2
Joined: Sun Oct 21, 2018 12:16 pm

How to generate a search index by URL or CLI ?

Post by ngovolunteer » Mon Oct 22, 2018 8:53 pm

Actually, the search function on the top right corner of this forum page also doesn't work for me, the search box on the same line as the menu (About ... Downloads ... Customise ... etc.) on the far right. I can put in various search queries and hit Enter, right here on this forum's page, and just get no result.

However, if I go to
search.php
... then that works.

On my own forum, neither work.

If there's no known fix for this within the ACP, does anybody know how to generate the required index for a phpBB internal search, from the command line or a special URL, so that one or the other search boxes work on another forum site such as mine?

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: 13685, 1mix, Bermudez, invenio, lopoto, Lumpy Burgertushie and 267 guests