Read only setting not working

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
menz01
Registered User
Posts: 125
Joined: Thu Oct 27, 2016 4:45 pm

Read only setting not working

Post by menz01 » Sun Oct 21, 2018 8:12 pm

i created a group to put my users in if they "mess up" and it supposed to make them read only for the board. i put my users in this group and make it their default group and when i go "test that users permissions" i see that i can still post in all my forums. why isn't read only working?

User avatar
pikachuturkey
Registered User
Posts: 290
Joined: Wed Dec 20, 2006 10:34 pm
Name: Rıza
Contact:

Re: Read only setting not working

Post by pikachuturkey » Sun Oct 21, 2018 8:19 pm

İf a User or users at 2 or more groups same time, they have all permissions of all groups which they are member.
You must set "never" option at least one group for restrict.
Health For Everyone ==> www.saglikforum.org

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69294
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Read only setting not working

Post by KevC » Sun Oct 21, 2018 8:20 pm

When you test a users permissions you are still you and can do the things you can do.

If that group has the permission of 'can post replies' and 'can start topics' set to NEVER then they will not be able to post in those forums. If you set it to NO, then the YES permission from the registered users group that they should still be in will override it.
The default setting just selects their username colour and has no say over the permission priority.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

menz01
Registered User
Posts: 125
Joined: Thu Oct 27, 2016 4:45 pm

Re: Read only setting not working

Post by menz01 » Sun Oct 21, 2018 9:27 pm

KevC wrote:
Sun Oct 21, 2018 8:20 pm
When you test a users permissions you are still you and can do the things you can do.
really...cause when i get the permissions right, and "test a users permissions" i am not able to post if that is what i set the permissions as, then i "revert" and i get my admin permissions back

KevC wrote:
Sun Oct 21, 2018 8:20 pm
If that group has the permission of 'can post replies' and 'can start topics' set to NEVER then they will not be able to post in those forums. If you set it to NO, then the YES permission from the registered users group that they should still be in will override it.
The default setting just selects their username colour and has no say over the permission priority.
that was it... i never knew the difference between "No" and "Never" now i do. my read only users were getting their permissions from the registered users group as well as you stated

thanks for the help

Post Reply

Return to “[3.2.x] Support Forum”