no Emoji in the Backend?

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
enter a valid email
Registered User
Posts: 286
Joined: Mon May 30, 2016 4:50 pm
Location: VIE
Contact:

no Emoji in the Backend?

Post by enter a valid email » Sun Oct 28, 2018 2:46 pm

I tried to add "🚨" in front of my SOS Topic (or how to called).
So in the end the Backend show me some SQL Error. It look like its not possible to add an Emoji as Forum Topic ting or how does it get called in English.
Is there an way to fix it myself?
Thanks

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50926
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: no Emoji in the Backend?

Post by stevemaury » Sun Oct 28, 2018 2:57 pm

Show us what code you added and where you added it. Also tell us the error displayed.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

enter a valid email
Registered User
Posts: 286
Joined: Mon May 30, 2016 4:50 pm
Location: VIE
Contact:

Re: no Emoji in the Backend?

Post by enter a valid email » Sun Oct 28, 2018 3:21 pm

Here in front of the SOS: https://publictransportforum.at/viewforum.php?f=13

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Incorrect string value: '\xF0\x9F\x9A\xA8 S...' for column 'forum_name' at row 1 [1366]

SQL

UPDATE phpbb_forums SET parent_id = 12, forum_type = 1, forum_status = 0, forum_parents = '', forum_name = '🚨 SOS/ Notfälle', forum_link = '', forum_desc = '', forum_desc_uid = '', forum_desc_options = 7, forum_desc_bitfield = '', forum_rules = '', forum_rules_uid = '', forum_rules_options = 7, forum_rules_bitfield = '', forum_rules_link = '', forum_image = '', forum_style = 0, display_subforum_list = 1, display_on_index = 0, forum_topics_per_page = 0, enable_indexing = 1, enable_icons = 0, enable_prune = 0, enable_shadow_prune = 0, prune_days = 7, prune_viewed = 7, prune_freq = 1, prune_shadow_days = 7, prune_shadow_freq = 1, forum_flags = 48 WHERE forum_id = 13

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 997
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysql.php
LINE: 191
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysql->sql_query()

FILE: [ROOT]/includes/acp/acp_forums.php
LINE: 1363
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/includes/acp/acp_forums.php
LINE: 199
CALL: acp_forums->update_forum_data()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_forums->main()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10348
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: no Emoji in the Backend?

Post by Noxwizard » Sun Oct 28, 2018 3:39 pm

Correct, not all fields are set up to allow emojis.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

enter a valid email
Registered User
Posts: 286
Joined: Mon May 30, 2016 4:50 pm
Location: VIE
Contact:

Re: no Emoji in the Backend?

Post by enter a valid email » Sun Oct 28, 2018 3:42 pm

Is there any way round?

Sry when I ask here w/o another Topic. Can I make the Name, Topic or how the calles in 2 Rows? Like one for the English and the other for German?

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21738
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: no Emoji in the Backend?

Post by Mick » Mon Oct 29, 2018 8:35 am

You need an extension for that or, if you wish, you can ask in phpBB Custom coding.
"The more connected we get the more alone we become" - Kyle Broflovski

enter a valid email
Registered User
Posts: 286
Joined: Mon May 30, 2016 4:50 pm
Location: VIE
Contact:

Re: no Emoji in the Backend?

Post by enter a valid email » Mon Oct 29, 2018 11:38 am

For the Emoji or 2 Row thing?
I dont need both but the look more nice.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21738
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: no Emoji in the Backend?

Post by Mick » Mon Oct 29, 2018 12:15 pm

Both will need an extension or coding.
"The more connected we get the more alone we become" - Kyle Broflovski

Post Reply

Return to “[3.2.x] Support Forum”