[Solved] Notifications are not displayed properly on mobile devices

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
executifs
Registered User
Posts: 12
Joined: Wed Mar 26, 2014 1:45 am

[Solved] Notifications are not displayed properly on mobile devices

Post by executifs »

Support Request Template
What version of phpBB are you using? phpBB 3.2.3
What is your board's URL? http://cocyclics.tremplinsdelimaginaire.com
Who do you host your board with? OVH
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? No
What version of phpBB3 did you update from? phpBB 3.2.2
What styles do you currently have installed? prosilver and our own fork of it (the bug happens on vanilla prosilver as shown below).
What language(s) is your board currently using? French
Which database type/version are you using? MySQL 5
What is your level of experience? Experienced with PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Upgrading from phpBB 3.2.2 to phpBB 3.2.3
Upgrading from PHP5 to PHP7.1
Please describe your problem. The notifications popout is not displayed correctly on mobile devices anymore:

Image

The problem is difficult to reproduce as it doesn't seem to affect all users. Both Android and iOS devices seem to be affected. The popout is displayed properly when the device is held in portrait mode. That issue didn't occur with the previous version of phpBB, but it's also possible that the upgrade to PHP 7.1 is the source of this problem.
Last edited by executifs on Fri Nov 02, 2018 2:47 am, edited 1 time in total.
User avatar
P_I
Registered User
Posts: 1191
Joined: Tue Mar 01, 2011 8:35 pm
Location: Staying home - Calgary
Contact:

Re: Notifications are not displayed properly on mobile devices

Post by P_I »

I've got two forums (stock prosilver) that are showing the same issue, but cannot reproduce it here on phpBB.com.

We've narrowed it down somewhat and don't think it is dependent on OS or browser, but rather mobile device size. I can reproduce this using Chrome's Inspect Element tool if I set my device to iPhone 5/SE (320px wide) but it works properly on iPhone 6/7/8 (375px wide). On a desktop with Chrome's Inspect Element tool in "Responsive mode", I see the element disappear at 350 px and reappear at 351 px.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams
User avatar
P_I
Registered User
Posts: 1191
Joined: Tue Mar 01, 2011 8:35 pm
Location: Staying home - Calgary
Contact:

Re: Notifications are not displayed properly on mobile devices

Post by P_I »

Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 909
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Notifications are not displayed properly on mobile devices

Post by AbaddonOrmuz »

It's already fixed in the master branch, make the following change:

https://github.com/phpbb/phpbb/pull/5229/files
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
executifs
Registered User
Posts: 12
Joined: Wed Mar 26, 2014 1:45 am

Re: Notifications are not displayed properly on mobile devices

Post by executifs »

The fix solved the issue for me. Thanks a lot!
Post Reply

Return to “[3.2.x] Support Forum”