Page 1 of 1

3.2.3 to 3.2.4-RC1: "The installer detected a timeout" error

Posted: Sun Nov 11, 2018 12:25 pm
by tm8544
Installer reports a timeout, if I'm using PHP7.3.0RC5.
I tried this several times. There are no errors in Apache log, just this from the installer: The installer detected a timeout
The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI.


With PHP 7.2.12, installer runs just fine. No settings changed.

Re: 3.2.3 to 3.2.4-RC1: "The installer detected a timeout" error

Posted: Sun Nov 11, 2018 12:57 pm
by david63
tm8544 wrote:
Sun Nov 11, 2018 12:25 pm
I'm using PHP7.3.0RC5.
Therein lies the problem. As PHP 7.3.x has not been released yet then I doubt that phpBB will have been tested with it.

It might be an idea to flag it up in the Bug Tracker though.

Re: 3.2.3 to 3.2.4-RC1: "The installer detected a timeout" error

Posted: Sun Nov 11, 2018 1:01 pm
by </Solidjeuh>
I also think it's the PHP version. I'm running 3.2.4 RC.1 on 2 forums without a problem with PHP 7.2.11

Re: 3.2.3 to 3.2.4-RC1: "The installer detected a timeout" error

Posted: Mon Nov 12, 2018 4:48 pm
by tm8544
david63 wrote:
Sun Nov 11, 2018 12:57 pm
Therein lies the problem. As PHP 7.3.x has not been released yet then I doubt that phpBB will have been tested with it.
I guess the PHP Community makes Release Candidate versions available so that they can be used for testing purposes.
What's the point to wait until GA is released and then start testing?
Features are freezed already in beta versions, and RC versions are rather stable so testing would be useful.

Re: 3.2.3 to 3.2.4-RC1: "The installer detected a timeout" error

Posted: Mon Nov 12, 2018 4:52 pm
by </Solidjeuh>
phpBB 3.2.4 is an RC version, so that's for testing.
PHP is a whole different thing that is not being developed by phpBB

Re: 3.2.3 to 3.2.4-RC1: "The installer detected a timeout" error

Posted: Mon Nov 12, 2018 5:03 pm
by warmweer
tm8544 wrote:
Mon Nov 12, 2018 4:48 pm
I guess the PHP Community makes Release Candidate versions available so that they can be used for testing purposes.
What's the point to wait until GA is released and then start testing?
Features are freezed already in beta versions, and RC versions are rather stable so testing would be useful.
Wow, nice intro!?
RC says it all: release CANDIDATE, + you mentioned it yourself: rather stable.
Use at your own risk and always be prepared to roll back.

Re: 3.2.3 to 3.2.4-RC1: "The installer detected a timeout" error

Posted: Mon Nov 12, 2018 5:34 pm
by david63
There is little point testing a RC version as there is a possibility that there could be changes and the testing will have to be done again. Wait for a final version and test the software against that is the normal practice.

Yes by all try it and as I said before if you find a potential problem flag it up in the bug tracker.

Re: 3.2.3 to 3.2.4-RC1: "The installer detected a timeout" error

Posted: Tue Nov 13, 2018 8:07 am
by Paul
This time out probarbly means that there has been a php error causing the installer to think that a timeout. Can you look in your error_log from your webserver to see if there is a error in there?

Re: 3.2.3 to 3.2.4-RC1: "The installer detected a timeout" error

Posted: Tue Nov 13, 2018 2:57 pm
by tm8544
Paul wrote:
Tue Nov 13, 2018 8:07 am
Can you look in your error_log from your webserver to see if there is a error in there?
See the first post, no errors in Apache log