Unable to attach photos

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
mainevette
Registered User
Posts: 66
Joined: Thu Jul 30, 2009 1:30 am
Location: East Waterboro, Maine
Contact:

Unable to attach photos

Post by mainevette » Mon Nov 12, 2018 1:50 am

About two months ago my site was hacked and I had to work with my webhost to do a restoration of my site. The forum seems to be working fine except that neither I, nor my users, are able to attach any files to their posts. When a user attempts to upload a file the upload fails and the error message "The image file you tried to attach is invalid" is given.

I thought perhaps the permissions for one of my file directories was set incorrectly, or that my board settings had been changed, but I've checked both of those and they seem appropriate.

I'm running PHPBB Board version 3.2.1 and PHP version 5.6.38

Any ideas on what I should check?

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49731
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Unable to attach photos

Post by stevemaury » Mon Nov 12, 2018 5:18 pm

What file extensions are you allowing to be uploaded? What is your setting for "Check attachment files" in Attachment settings?

Please fill out the Support Request Template and post it back here to enable us to assist you better.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

dekagv
Registered User
Posts: 1
Joined: Sun Mar 23, 2014 1:49 am
Contact:

Re: Unable to attach photos

Post by dekagv » Mon Nov 12, 2018 7:58 pm

sometimes the same thing happened to me but it was due to the size allowed in mb by my hosting

mainevette
Registered User
Posts: 66
Joined: Thu Jul 30, 2009 1:30 am
Location: East Waterboro, Maine
Contact:

Re: Unable to attach photos

Post by mainevette » Tue Nov 13, 2018 1:45 am

stevemaury wrote:
Mon Nov 12, 2018 5:18 pm
What file extensions are you allowing to be uploaded? What is your setting for "Check attachment files" in Attachment settings?

Please fill out the Support Request Template and post it back here to enable us to assist you better.
I've tried uploading jpgs, png and bmp files and none seem to work. The files I'm trying to upload are relatively small and the board setting is set to allow up to 20 MiB files. The "Check Attachment Files" is set to "yes"

Here's the support template filled out:

Support Request Template
What version of phpBB are you using? phpBB 3.2.1
What is your board's URL? www.corvette-restoration.com
Who do you host your board with? www.siteground.com
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.0-B1
What extensions do you have installed? Google Analytics
Image Redirect Extension
Advertisement Management (disabled)
tas2580 Failed logins (disabled)
Viglink (disabled)
What styles do you currently have installed? Prosilver SE
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
What username can be used to view this issue? test_acct
What password can be used to view this issue? adminpassword
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? restored website from an automatic backup provided by my webhost
Please describe your problem. Board was working fine for quite some time. My website was hacked and I had to recover the site from a backup that was auto generated by my webhost. After restoring the site users are no longer able to attach photos. When a user tries to attach a photo an error message reading "The image file you tried to attach is invalid". This issue seems to exist for all users of all ranks.

Photos that were previously attached still show up in old posts, users simply can't attach new photos.
Generated by SRT Generator

Here are snippets of my current attachment settings:
1.JPG
2.JPG

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49731
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Unable to attach photos

Post by stevemaury » Tue Nov 13, 2018 2:55 pm

Change "Check attachment files" to No. Also, what Extensions for attachments have you enabled in the ACP, Attachments, Manage extension?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

mainevette
Registered User
Posts: 66
Joined: Thu Jul 30, 2009 1:30 am
Location: East Waterboro, Maine
Contact:

Re: Unable to attach photos

Post by mainevette » Wed Nov 14, 2018 2:26 am

I changed the "Check Attachment Files" setting as suggested but the problem persists.

Here are the image file types that are currently listed under ACP > Posting > Attachments > Manage attachment extensions
3.JPG

User avatar
Mick
Support Team Member
Support Team Member
Posts: 20343
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Unable to attach photos

Post by Mick » Wed Nov 14, 2018 8:12 am

Can you check the values on the PHP info page in the ACP and post the results for the following entries please?

upload_max_filesize
post_max_size
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.

mainevette
Registered User
Posts: 66
Joined: Thu Jul 30, 2009 1:30 am
Location: East Waterboro, Maine
Contact:

Re: Unable to attach photos

Post by mainevette » Thu Nov 15, 2018 12:50 am

upload_max_filesize = 128 MB
post_max_size = 128 MB

mainevette
Registered User
Posts: 66
Joined: Thu Jul 30, 2009 1:30 am
Location: East Waterboro, Maine
Contact:

Re: Unable to attach photos

Post by mainevette » Sun Nov 18, 2018 3:51 pm

TTT - Any other ideas on what I can check? I'm at a loss...

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49731
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Unable to attach photos

Post by stevemaury » Sun Nov 18, 2018 4:13 pm

Is the permission on the /files folder 777?

If you want, you can PM me an Admin account and the URL and I will take a look.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

mainevette
Registered User
Posts: 66
Joined: Thu Jul 30, 2009 1:30 am
Location: East Waterboro, Maine
Contact:

Re: Unable to attach photos

Post by mainevette » Sun Nov 18, 2018 4:45 pm

stevemaury wrote:
Sun Nov 18, 2018 4:13 pm
Is the permission on the /files folder 777?

If you want, you can PM me an Admin account and the URL and I will take a look.
Hi, I verified the permissions on the /file folder is set to 777.

I'll PM you the information. Any help would be greatly appreciated.

mainevette
Registered User
Posts: 66
Joined: Thu Jul 30, 2009 1:30 am
Location: East Waterboro, Maine
Contact:

Re: Unable to attach photos

Post by mainevette » Thu Nov 22, 2018 11:06 pm

Problem has been solved. Posting the solution here for the benefit of others who may encounter a similar issue.

After checking my attachment settings and directory permissions (which were all correct) I contacted my webhost and explained the issue. They reported back that they simply had to restart my services. Everything now works as it should.

Thanks to all who offered assistance

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Crizzo, janus_zonstraal, madelharri, Paul, urkomurko and 31 guests