Upgrade from 3.2.2 to 3.2.3 went wrong, lost

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
flea77
Registered User
Posts: 35
Joined: Sun Jan 05, 2014 10:40 pm

Upgrade from 3.2.2 to 3.2.3 went wrong, lost

Post by flea77 » Tue Nov 13, 2018 6:51 pm

I seem to always have problems upgrading, guess I am just not cut out for this...

Following the directions here : https://www.phpbb.com/support/documents ... pdate_auto

I downloaded everything in my /forum directory, then deleted everything except /etc /files /images and then uploaded everything from the full 3.2.3 install file into the /forum directory, then uploaded my old config.php file. Last, I went to /forum/install/app.php/update and got the following error:

Code: Select all

Fatal error: Uncaught Symfony\Component\Config\Exception\FileLoaderImportCircularReferenceException: Circular reference detected in "/homepages/38/d161242139/htdocs/allan/forum/config/installer/container/parameters.yml" ("/homepages/38/d161242139/htdocs/allan/forum/config/installer/container/parameters.yml" > "/homepages/38/d161242139/htdocs/allan/forum/config/installer/container/parameters.yml"). in /homepages/38/d161242139/htdocs/allan/forum/vendor/symfony/config/Loader/FileLoader.php:91 Stack trace: #0 /homepages/38/d161242139/htdocs/allan/forum/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php(105): Symfony\Component\Config\Loader\FileLoader->import(Array, NULL, false, '/homepages/38/d...') #1 /homepages/38/d161242139/htdocs/allan/forum/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php(54): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->parseImports(Array, '/homepages/38/d...') #2 /homepages/38/d161242139/htdocs/allan/forum/vendor/symfony/config/Loader/FileLoader.php(101): Symfony in /homepages/38/d161242139/htdocs/allan/forum/vendor/symfony/config/Loader/FileLoader.php on line 91
Any ideas what I did wrong?

User avatar
warmweer
Registered User
Posts: 1470
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Upgrade from 3.2.2 to 3.2.3 went wrong, lost

Post by warmweer » Tue Nov 13, 2018 7:00 pm

flea77 wrote:
Tue Nov 13, 2018 6:51 pm
Following the directions here : https://www.phpbb.com/support/documents ... pdate_auto

Any ideas what I did wrong?
Yes: you used the autoupdate which is not the way to go when your board has no file modifications.

Use: https://www.phpbb.com/support/documents ... pdate_full and you should be up to speed in a jiffy.
A bug is a feature that hasn't made it to the manual (yet)

User avatar
</Solidjeuh>
Registered User
Posts: 1154
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Upgrade from 3.2.2 to 3.2.3 went wrong, lost

Post by </Solidjeuh> » Tue Nov 13, 2018 7:20 pm

And it also seems that you deleted to much.
You need to keep:
  • The config.php file
    The images/ directory
    The files/ directory
    The store/ directory
    The ext/ directory
We offer fun HTML5 games for young and old.
Register a free account & enjoy all functions!
Save your score, challenge other members or play along with our tournaments.


~~~ https://www.solidjeuh.be ~~~

flea77
Registered User
Posts: 35
Joined: Sun Jan 05, 2014 10:40 pm

Re: Upgrade from 3.2.2 to 3.2.3 went wrong, lost

Post by flea77 » Tue Nov 13, 2018 7:26 pm

First, I think the link I posted might have been misleading.... I went to section 4.i. in that document, downloaded the FULL INSTALL package phpBB-3.2.3.zip and followed the direction for using that full install package. I did NOT do the update package.

Also, I kept:
The config.php file
The images/ directory
The files/ directory
The store/ directory
The ext/ directory

(I actually deleted the /store directory but since I had a backup, I uploaded it back, didn't change anything. Besides, that document says to keep "files/, images/ and ext/ " but does NOT mention the store directory.

Any other ideas?

User avatar
warmweer
Registered User
Posts: 1470
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Upgrade from 3.2.2 to 3.2.3 went wrong, lost

Post by warmweer » Tue Nov 13, 2018 7:35 pm

flea77 wrote:
Tue Nov 13, 2018 7:26 pm
... but does NOT mention the store directory.
Good point, I thought something was missing but wasn't lucid enough to notice that.

One thing I just noticed is that the error has something to do with extensions.
What I do when updating is to disable all extensions first (and then check whether they should be updated or not (after updating the board).

Since you can't login at this time, I've attached a php file to disable all extensions at once. Try that before updating again (since all files are in place - all you need to do before starting the update = emptying the cache (leave .htaccess and index.htm)
ext_disable.php
Disable all extensions at once
(7.63 KiB) Downloaded 2 times
BTW I didn't make that file but I guarantee it works.
A bug is a feature that hasn't made it to the manual (yet)

flea77
Registered User
Posts: 35
Joined: Sun Jan 05, 2014 10:40 pm

Re: Upgrade from 3.2.2 to 3.2.3 went wrong, lost

Post by flea77 » Tue Nov 13, 2018 7:54 pm

Downloaded and ran the script to disable the extensions, got errors:
Warning: require_once(./mobiquo/mbqFrame/3rdLib/classTTConnection.php): failed to open stream: No such file or directory in /homepages/38/d161242139/htdocs/allan/forum/ext/tapatalk/tapatalk/event/main_listener.php on line 225

Fatal error: require_once(): Failed opening required './mobiquo/mbqFrame/3rdLib/classTTConnection.php' (include_path='.:/usr/lib/php7.0') in /homepages/38/d161242139/htdocs/allan/forum/ext/tapatalk/tapatalk/event/main_listener.php on line 225
Cleared EVERYTHING out of the cache directory except for .htaccess and index.htm and uploaded a backup of the /mobiquo directory to the /forum directory since I read that in the above directory, that seems to solve the error with the script because then I got a message about the board being unavailable but I saw the logos and headers correctly, even saw an adsense ad so that is good.

Then I went back to the /forum/install/app.php/update and got what I think is the same error:
Fatal error: Uncaught Symfony\Component\Config\Exception\FileLoaderImportCircularReferenceException: Circular reference detected in "/homepages/38/d161242139/htdocs/allan/forum/config/installer/container/parameters.yml" ("/homepages/38/d161242139/htdocs/allan/forum/config/installer/container/parameters.yml" > "/homepages/38/d161242139/htdocs/allan/forum/config/installer/container/parameters.yml"). in /homepages/38/d161242139/htdocs/allan/forum/vendor/symfony/config/Loader/FileLoader.php:91 Stack trace: #0 /homepages/38/d161242139/htdocs/allan/forum/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php(105): Symfony\Component\Config\Loader\FileLoader->import(Array, NULL, false, '/homepages/38/d...') #1 /homepages/38/d161242139/htdocs/allan/forum/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php(54): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->parseImports(Array, '/homepages/38/d...') #2 /homepages/38/d161242139/htdocs/allan/forum/vendor/symfony/config/Loader/FileLoader.php(101): Symfony in /homepages/38/d161242139/htdocs/allan/forum/vendor/symfony/config/Loader/FileLoader.php on line 91

User avatar
warmweer
Registered User
Posts: 1470
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Upgrade from 3.2.2 to 3.2.3 went wrong, lost

Post by warmweer » Tue Nov 13, 2018 8:09 pm

hmm? forget what I said about a jiffy.
tapatalk?? that one seems to have caused a couple of problems in the past.

Would it be an option to put the 3.2.2 files back, see if you can login, then disable tapatalk extension and then try the update again?

Or perhaps wait for suggestions from the SupportTeam?

edited at 22:20 (local time) which is more than an hour after I made this post:
I've spent the last hour reading posts about tapatalk and frankly speaking: I wouldn't use it because a) I don't see the need for it - but that's personal and b) I see more messages (not only on phpBB) about problems than anything else.
So I'll change my "option" to a "suggestion" to try and disable tapatalk, and run the update again.
A bug is a feature that hasn't made it to the manual (yet)

flea77
Registered User
Posts: 35
Joined: Sun Jan 05, 2014 10:40 pm

Re: Upgrade from 3.2.2 to 3.2.3 went wrong, lost

Post by flea77 » Tue Nov 13, 2018 10:08 pm

OK, tried that, now it says "Information phpBB is not installed yet."

User avatar
warmweer
Registered User
Posts: 1470
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Upgrade from 3.2.2 to 3.2.3 went wrong, lost

Post by warmweer » Tue Nov 13, 2018 10:26 pm

flea77 wrote:
Tue Nov 13, 2018 10:08 pm
OK, tried that, now it says "Information phpBB is not installed yet."
Did you overwrite your config.php?

Perhaps it would be better to restore your 3.2.2 backup and the 3.2.2 files and start fresh from there (with disabling your extensions).
A bug is a feature that hasn't made it to the manual (yet)

flea77
Registered User
Posts: 35
Joined: Sun Jan 05, 2014 10:40 pm

Re: Upgrade from 3.2.2 to 3.2.3 went wrong, lost

Post by flea77 » Tue Nov 13, 2018 10:58 pm

It seems that when I had everything selected to copy from the new install 3.2.3 and then deselected the three directories and config file, it really didnt deselect the config file. Restoring my old config file over that one fixed it.

Seems I needed to disable the plugins and/or remove tapatalk before doing the upgrade. I will play with it some more but so far it seems good.

Thanks for the assist!

User avatar
warmweer
Registered User
Posts: 1470
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Upgrade from 3.2.2 to 3.2.3 went wrong, lost

Post by warmweer » Wed Nov 14, 2018 8:34 am

flea77 wrote:
Tue Nov 13, 2018 10:58 pm
It seems that when I had everything selected to copy from the new install 3.2.3 and then deselected the three directories and config file, it really didnt deselect the config file. Restoring my old config file over that one fixed it.

Seems I needed to disable the plugins and/or remove tapatalk before doing the upgrade. I will play with it some more but so far it seems good.

Thanks for the assist!
Good news and the thing to remember (and learn) from this experience is that whatever goes wrong, a backup can undo.

Concerning tapatalk, or extensions in general, always test them on localhost before using them online, also when updating.
A bug is a feature that hasn't made it to the manual (yet)

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: appnews, janus_zonstraal, WiGgLr and 26 guests