Page 2 of 3

Re: Known issues in 3.2.4

Posted: Sun Nov 18, 2018 8:43 pm
by P_I
I fully appreciate that everyone involved here does so on a volunteer and best efforts basis. That said ...

For the boards that I operate we've been well served by the policy to use only official phpBB releases and officially released extensions, so this precludes applying fixes directly from GitHub as they're not officially sanctioned phpBB releases.

Thus the essence of the problem for me is the known and now publicized security issue that affects phpBB 3.2.3 (and I presume lower) and the lack of clarity of whether the extensions that our boards use will be affected by the issue flagged in the first post of this topic. All my offline testing of the update has gone well but there is no way to know if this known issue will show up if we update our production board(s).

The known issue has been flagged as Major, but I would suggest based on what we know so far it probably could be considered "Blocking", I know that is how it is viewed for the boards I run.

In my specific case the only extension that seems like it might be affected is one of the Official extensions from the phpBB team, so I was hopeful there would be an answer from the developers on whether or not the extension was affected by this known issue. That's the only way I'd be comfortable moving forward to phpBB 3.2.4 based on the information that has been made available so far.

Re: Known issues in 3.2.4

Posted: Sun Nov 18, 2018 9:42 pm
by Talk19Zehn
Hi, the EOM => end of maintenance https://www.phpbb.com/about/release/
is due at the end of 2018 for 3.2.x (Rhea) and therefore a PL should be perhaps feasible. Bertie would certainly want a deserved PL in terms of 3.2.x (Rhea) as well (?!)... ;)

The version controls will certainly allow / enable this approach. Please do not say now, that would not be in view of an EOM.
I also think a PL or a very timely new phpBB-system version "3.2.5" is more effective for everyone Extension Writers involved.


Greetings and thanks.

Re: Known issues in 3.2.4

Posted: Sun Nov 18, 2018 10:15 pm
by Scanialady
I agree - it would be better to release a patched update 4.2.4. Most of the language packs aren't outside today, so the main group of people does not have downloaded this version yet. I don't think it is funny to answer hundreds of unnecessary support requests depending on this early known bugs.

Re: Known issues in 3.2.4

Posted: Sun Nov 18, 2018 10:34 pm
by 3Di
I don't think there will be a 3.2.4-PL1 release, a lot of work has been already done/merged for 3.2.5(rc1) over there.

Maybe a note (link) in the download page, that should do IMHO.

Re: Known issues in 3.2.4

Posted: Sun Nov 18, 2018 10:51 pm
by Talk19Zehn
Sure, I've already seen.
https://area51.phpbb.com/ --> nightly´s ...

Hence the thought of including version control. So then only a fast action remains, which a 3.2.5 before the end (EOM) remedy creates. Delays don't help and a cut must be possible.

Many greetings

Re: Known issues in 3.2.4

Posted: Mon Nov 19, 2018 1:18 am
by Big Mac
Marc wrote:
Sat Nov 17, 2018 10:35 pm
A fix for this can be found on Github and will be included in the 3.2.5 release:
Is there an estimated time of arrival for the 3.2.5 release?

Re: Known issues in 3.2.4

Posted: Mon Nov 19, 2018 8:45 am
by warmweer
Big Mac wrote:
Mon Nov 19, 2018 1:18 am
Is there an estimated time of arrival for the 3.2.5 release?
Probably ASAP and hopefully BIITL ;)

Re: Known issues in 3.2.4

Posted: Mon Nov 19, 2018 9:33 am
by Siava
Module "Language packs" moves from "ACP -> Customise -> Language management" to "ACP -> System -> General tasks" after update from 3.2.3 to 3.2.4.
You can see it in "Module management".

Re: Known issues in 3.2.4

Posted: Mon Nov 19, 2018 9:55 am
by Crizzo
Could you provide two Screenshots from both menu points, please?

Re: Known issues in 3.2.4

Posted: Mon Nov 19, 2018 10:10 am
by Siava
In ACP I see:
Image
Image
But in Module management Language Packs really in different place:
Image
Image

The same on two different forums after update from 3.2.3 to 3.2.4.
php 7.0.30 and php 7.2.12 if it helps.

Re: Known issues in 3.2.4

Posted: Mon Nov 19, 2018 10:47 am
by david63
As it is not there on a clean install I am guessing that it is something carried over from a mod/extension in a previous version and it is probably safe to delete it.

Re: Known issues in 3.2.4

Posted: Thu Nov 22, 2018 6:47 am
by canonknipser
IMHO it would be a good idea to link this topic in the update announcement so regular board owners are aware of these issues. Currently it is just mentioned in the middle of page 2 in the discussion topic, surrounded by some semi-off-topic discussion about Bertie and his mustache ....

Re: Known issues in 3.2.4

Posted: Fri Nov 23, 2018 4:17 pm
by HiFiKabin
To make your life easier I have attached a zip containing the 2 changed files referenced in this topic

Download and unzip the attached. You will then find a folder called phpBB3 on your desktop. Within that folder there is another one called includes. Upload that to your boards root (where config.php is) and you will be asked if you want to overwrite bbcode.php and functions_content.php Accept that and the files will upload.

Then purge your boards cache, either from the ACP or (if you can not access the acp) by removing the contents of the cache directory on your server, leaving just index.htm and .htaccess

https://phpbb.hifikabin.me.uk/download/file.php?id=954

Re: Known issues in 3.2.4

Posted: Thu Nov 29, 2018 12:01 pm
by useronthenet
Your probably heard this question before but still having problem with managing extensions in version 3.2.4
I see the default extension (VigLink) in directory ext/phpbb but when I upload the same to either /ext or /ext/phpbb nothing shows in the extension manager. any ideas ?

Thanks for your help.

Re: Known issues in 3.2.4

Posted: Thu Nov 29, 2018 12:10 pm
by KevC
useronthenet wrote:
Thu Nov 29, 2018 12:01 pm
Your probably heard this question before but still having problem with managing extensions in version 3.2.4
I see the default extension (VigLink) in directory ext/phpbb but when I upload the same to either /ext or /ext/phpbb nothing shows in the extension manager. any ideas ?

Thanks for your help.
You're better of starting a new topic. It's likely to just be that they're not uploaded to the correct place.

Only extensions made by the phpBB team go in to /ext/phpbb
Start a new topic with the name of the extensions and a screenshot of your FTP window /ext folder