'Forgot Password' Emails not being sent, but other emails are.

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 3160
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: 'Forgot Password' Emails not being sent, but other emails are.

Post by thecoalman » Mon Jan 28, 2019 4:59 am

EA117 wrote:
Sun Jan 27, 2019 12:52 pm
It's not clear, for me anyway, that we're looking at a blocked or blacklisted scenario currently. Since success or failure seems to depend upon the content of the message being sent. ("Forgot password" fails, others do not fail.) If the reputation of the originating mail server was the issue, I would be expecting all messages to fail.
Not sure why this would make a difference but AFAIK the registration and forgot password emails are sent at runtime. Notifications and whatever else are queued. That is why I asked if the registration emails were failing.

Spam filters score an email, a reverse DNS issue for example would cause a score that would always cause a rejection on most of them. Minor issues may not cause an email to be rejected however if you have enough minor issues they may add up to a score to reject it. There may be minor difference between the forgot password emails and the notifications causing the rejection of the forgot password email but there is other underlying problems.

For example if you do not have SPF record that can cause higher score, fix that problem and the minor issues become irrelevant. Using the mail tester it can tell you what these problems may be.
To me the biggest "crime" in all of this is that you weren't immediately receiving back a rejection notice, by email, confirming that the send attempt was being dropped.


When this occurs it's usually reverse DNS issue that most email servers drop into a blackhole because it will almost always be a spammer. This is not something that should occur and if that is the issue you need to contact your host to fix it. It's not something you can fix yourself even on higher end server plans.

User avatar
EA117
Registered User
Posts: 584
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: 'Forgot Password' Emails not being sent, but other emails are.

Post by EA117 » Mon Jan 28, 2019 11:17 am

thecoalman wrote:
Mon Jan 28, 2019 4:59 am
...fix that problem and the minor issues become irrelevant. Using the mail tester it can tell you what these problems may be.
Thank you. Appreciate the info and clarifications.

So the push back to OP is that if sending a "Forgot Password" email to mail-tester.com gets dropped / never arrives just like is currently happening to board users, be sure to also give mail-tester.com the opportunity to see one of the emails from phpBB that are "working", too.

Since the mail tester site may identify existing issues, which on their own just didn't happen to score the email high enough to be dropped. But which, in combination with other factors or content specific to the "Forgot Password" email, contribute to a score high enough to get dropped.

sjgarth
Registered User
Posts: 35
Joined: Fri Jan 11, 2013 12:37 pm

Re: 'Forgot Password' Emails not being sent, but other emails are.

Post by sjgarth » Mon Jan 28, 2019 7:39 pm

Okay, I have changed the domain name, and so the email domain, but it is with the same provider on a shared server.
Now, please advise, if an email server was incorrectly set up (eg. no PTr and reverser DNS) or was blocked by a spam killer or other reason, would it not affect all emails from that address?
My provider says (about Reverse DNS);

Code: Select all

Email isn't sent out via the server IP it is sent to the mail gateway "mail-gw.unlimitedwebhosting.co.uk" which uses various managed IP's and has RDNS setup correctly.
So my provider confirms that the reverse DNS is correctly set up, I have checked via number of checkers and the domain is not blocked, neither is the IP address.
I have tested sending emails - I can use the forum to email another user, I am also receiving notifications, and yet forgotten password fails. I tried registration as well and it too fails.
I am at a loss and will probably switch off the forgotten password facility, and I dont normally have registration on anyway.
Steve Garth
A complete idiot who requires a forum like this to tie his shoelace.

User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 3160
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: 'Forgot Password' Emails not being sent, but other emails are.

Post by thecoalman » Mon Jan 28, 2019 8:58 pm

sjgarth wrote:
Mon Jan 28, 2019 7:39 pm
Now, please advise, if an email server was incorrectly set up (eg. no PTr and reverser DNS) or was blocked by a spam killer or other reason, would it not affect all emails from that address?
A reverse DNS record will almsot always cause an email to go into a black hole, if it's set correctly that is good.

Once again spam filters score an email. Suppose a score of 5 is rejection. No SPF record for example might worth a 2, the content since it's common may be worth a one, numerous other lillte things might be a .5

Your notification emails may be at a threshold with total score of 4.5 and something with the password emails is causing it to go to 5 so they get rejected. You donlt try and fix the little thing causing it to go over, you fix the big thing. Chances are you do not have a SPF record and having that set up correctly greatly increases the deliverability of emails for many reasons including reducing a spam score from spam filter. This can also be the big reason an email will be delivered but go to someones spam box.

Have you tried the mail tester I posted above?

sjgarth
Registered User
Posts: 35
Joined: Fri Jan 11, 2013 12:37 pm

Re: 'Forgot Password' Emails not being sent, but other emails are.

Post by sjgarth » Mon Jan 28, 2019 9:18 pm

Yes mate I did use the free version of that service.
I gave a user the test email address and emailed him user to user and received a score of 10/10 no problems.
I got a new test email and changed the user and used the forgot password function and the email was not received, although the email tracker for my provider informs me it was sent.
Mass mail to user - 10/10 no problems.
Steve Garth
A complete idiot who requires a forum like this to tie his shoelace.

User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 3160
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: 'Forgot Password' Emails not being sent, but other emails are.

Post by thecoalman » Mon Jan 28, 2019 9:27 pm

sjgarth wrote:
Mon Jan 28, 2019 9:18 pm
I gave a user the test email address and emailed him user to user and received a score of 10/10 no problems.
The way you would utilize this service is register an account on your forum with the email address they provide. The registration email would then go to testing service so they can analyze it.

sjgarth
Registered User
Posts: 35
Joined: Fri Jan 11, 2013 12:37 pm

Re: 'Forgot Password' Emails not being sent, but other emails are.

Post by sjgarth » Mon Jan 28, 2019 9:35 pm

I did that, registered with the test email, and the registration email was not received by the checking website. However ISP email tracker says it was successfully sent;

Code: Select all

DELIVERY EVENT DETAILS;
Event:	success success
User:	rblrorgu
Domain:	rblr.org.uk
From Address:	admin@rblr.org.uk
Sender:	admin@rblr.org.uk
Sent Time:	Jan 28, 2019, 9:31:21 PM
Sender Host:	cloud604.unlimitedwebhosting.co.uk
Sender IP:	149.255.62.65
Authentication:	dovecot_login
Spam Score:	
Recipient:	test-g2l7d@mail-tester.com
Delivery User:	-remote-
Delivery Domain:	
Delivered To:	test-g2l7d@mail-tester.com
Router:	dkim_lookuphost
Transport:	dkim_remote_smtp
Out Time:	Jan 28, 2019, 9:31:21 PM
ID:	1goEVb-000VKv-8p
Delivery Host:	149.255.60.65
Delivery IP:	149.255.60.65
Size:	1.7 KB
Result:	Accepted
Same result with forgotten password (for account I manually registered).

I really do appreciate you trying to help me on this, sorry if I am a bit behind.
Steve Garth
A complete idiot who requires a forum like this to tie his shoelace.

User avatar
janus_zonstraal
Registered User
Posts: 3215
Joined: Sat Aug 30, 2014 1:30 pm

Re: 'Forgot Password' Emails not being sent, but other emails are.

Post by janus_zonstraal » Mon Jan 28, 2019 10:07 pm

Ask your host
http://www.blacklistalert.org/ gives a error on the A record
WARNING: No matching A-Record exists for: no-dns-yet.unlimited.uk.net.
DNS is INCONSISTENT.
Please request your Admin or Provider to fix this.
Sorry! My English is bat ;) !!!

User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 3160
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: 'Forgot Password' Emails not being sent, but other emails are.

Post by thecoalman » Mon Jan 28, 2019 10:27 pm

sjgarth wrote:
Mon Jan 28, 2019 9:35 pm
I did that, registered with the test email, and the registration email was not received by the checking website. However ISP email tracker says it was successfully sent;
The email tester will accept any email so that would suggest it wasn't actually delivered or something is mangled and it can't be opened by the testing site.

sjgarth
Registered User
Posts: 35
Joined: Fri Jan 11, 2013 12:37 pm

Re: 'Forgot Password' Emails not being sent, but other emails are.

Post by sjgarth » Mon Jan 28, 2019 10:32 pm

This is winding me up something chronic.

janus_zonstraal i sent your report to them and they replied;

Code: Select all

Hi Steve
That is the server IP and not used for sending the email, the gateway IP is used.
They are now looking at the gateway logs to see if they can see anything.
Steve Garth
A complete idiot who requires a forum like this to tie his shoelace.

sjgarth
Registered User
Posts: 35
Joined: Fri Jan 11, 2013 12:37 pm

Re: 'Forgot Password' Emails not being sent, but other emails are.

Post by sjgarth » Mon Jan 28, 2019 11:13 pm

I got this response from the ISP Help team;
"Hi Steve
Checking its the same issue: "base64 encoded unnecessarily"
It seems to be a known issue with PHPBB email headers as its listed here: https://tracker.phpbb.com/browse/PHPBB3-15729 but no response since July last year.
And a similar issue here: viewtopic.php?t=2449516

So the PHPBB generated email headers are being caught in the spam gateway, we can't diable this gateway on the shared hosting, an alternative if no PHPBB fix can be found is a VPS server which doesn't use this gateway at all so you should have no issues using that service."

:( :(
Steve Garth
A complete idiot who requires a forum like this to tie his shoelace.

sjgarth
Registered User
Posts: 35
Joined: Fri Jan 11, 2013 12:37 pm

Re: 'Forgot Password' Emails not being sent, but other emails are.

Post by sjgarth » Wed Jan 30, 2019 10:09 pm

Sorted it.
The answer was found at;

https://wiki.phpbb.com/Support/Email_Troubleshooting

I was using the SMTP settings that come with the emails address, but once I set the SMTP server to local host and removed the username and password, and ignored the settings that were for the email address, it worked.

Thank you so much for the time and efforts all the responders put into this.
Steve Garth
A complete idiot who requires a forum like this to tie his shoelace.

Post Reply

Return to “[3.2.x] Support Forum”