Forum has blank pages after 3.2.2>3.2.4 update (caused by bbcode parsing?)

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
13685
Registered User
Posts: 7
Joined: Thu Feb 19, 2015 12:07 am

Forum has blank pages after 3.2.2>3.2.4 update (caused by bbcode parsing?)

Post by 13685 » Tue Nov 20, 2018 12:28 am

Hey guys. So I seem to have a problem! ;)

I've just updated two forums from 3.2.2 to 3.2.4. Both are vanilla forums, both are on the same server, and in both cases I've used the "changed files" package, run the db update script successfully and deleted the install dir.

One of the forums has updated perfectly and works fine.

The other one, however, now only shows a blank page for the main index and all posts (but not for the ACP or for forum indices, which seem to work fine).

The server error log gives me:

Code: Select all

PHP Fatal error: Call to undefined method bbcode::bbcode() in /forum/includes/functions_content.php on line 630
So, I tried commenting out that exact line in this installation...

Code: Select all

			{
				//$bbcode->bbcode($bitfield);
			}
...And now it loads fine; but of course all the bbcodes don't display at all.

Or, actually, even weirder, it seems like some threads load fine, including all bbcodes, but most just display unparsed, as I expected.

Anyway, as both forums are otherwise identical and hosted on the same server, is there anything that anyone could think of that would cause this?

PHP is version 5.4.45, and the forum with the problem only has the same few simple custom bbcodes set as the one that works (fewer, actually).

I've tried manually clearing the cache, and that didn't seem to help.

So, well, I'm stuck. Any suggestions? :)

Ryan

User avatar
</Solidjeuh>
Registered User
Posts: 1154
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Forum has blank pages after 3.2.2>3.2.4 update (caused by bbcode parsing?)

Post by </Solidjeuh> » Tue Nov 20, 2018 12:35 am

We offer fun HTML5 games for young and old.
Register a free account & enjoy all functions!
Save your score, challenge other members or play along with our tournaments.


~~~ https://www.solidjeuh.be ~~~

13685
Registered User
Posts: 7
Joined: Thu Feb 19, 2015 12:07 am

Re: Forum has blank pages after 3.2.2>3.2.4 update (caused by bbcode parsing?)

Post by 13685 » Tue Nov 20, 2018 12:42 am

</Solidjeuh> wrote:
Tue Nov 20, 2018 12:35 am
Please read: viewtopic.php?f=556&t=2492371
Here is the fix: https://github.com/phpbb/phpbb/pull/5448/files
Thanks for the response, but just browsing that thread, and that seems to be a bug affecting forums with extensions, whereas this is a completely vanilla forum, so I think probably not the issue? Especially as the other forum (which is exactly the same in all respects, is on the same server, and has been historically updated together with this one, so should have no differences) seems to work fine... :?

Ryan

User avatar
</Solidjeuh>
Registered User
Posts: 1154
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Forum has blank pages after 3.2.2>3.2.4 update (caused by bbcode parsing?)

Post by </Solidjeuh> » Tue Nov 20, 2018 12:43 am

You can always try it.. I'm pretty sure it will fix the problem.
We offer fun HTML5 games for young and old.
Register a free account & enjoy all functions!
Save your score, challenge other members or play along with our tournaments.


~~~ https://www.solidjeuh.be ~~~

User avatar
GanstaZ
Jr. Extension Validator
Posts: 642
Joined: Wed Oct 11, 2017 10:29 pm
Location: Zverse

Re: Forum has blank pages after 3.2.2>3.2.4 update (caused by bbcode parsing?)

Post by GanstaZ » Tue Nov 20, 2018 12:51 am

It's not about extensions, but about data storage. It was explained why update is working normally for some and buggy for others. Just do what was suggested above.
"When answer lies in the question,.. question becomes redundant!"

13685
Registered User
Posts: 7
Joined: Thu Feb 19, 2015 12:07 am

Re: Forum has blank pages after 3.2.2>3.2.4 update (caused by bbcode parsing?)

Post by 13685 » Tue Nov 20, 2018 1:04 am

Okay, so just tried applying the fixes from that thread, and it seems to have solved the blank pages. Thanks for the pointer. :)

I do wonder why it would only affect one of the two forums though, given that they're identical installs and on the same server, with the same bbcodes even? :|

Thanks again for the super-quick help, in any case! :)

Ryan

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: </Solidjeuh>, appnews, Baidu [Spider], Dlan, Exabot [Bot], janus_zonstraal, Noxwizard and 25 guests